Issues installing on nanopi r4s


i am having issues installing openwrt or friendlywrt on my nanopi r4s.

when i install a tf card with the firmware, nothing happens. besides the power led, none of the leds light up. i also cannot ping the router. i have tried different tf cards and different builds of openwrt.

any suggestions on how to fix this? i feel like i might of just received a defective unit


Unless the device is completely DOA, serial console access should tell you more (you really, really want a usb2serial adapter for devices like this).

Your profile shows that you have a nanopi r4se. That is not a OpenWrt supported system like the nanopi r4s is.
If you have an R4SE, please see the instructions on the friendlyelec wiki about booting from a tf card. and seek support from friendlyelec device support channels.
If you have an R4S, please provide detailed info on how you installed OpenWrt on the tf card and which tf cards you used.

i have both, a r4se and a r4s. the tf cards i have tried are a kingston canvas select plus and a samsung pro endurance. i had used the samsung card to flash software on the r4se, and had zero issues with card. i used win32diskimager to flash the tf card

Perhaps is related to this ext4 bug NanoPi R2S doesn't seem to boot from canonical ext4 image - #11 by m4r

1 Like

Some ideas for the r4s assuming it is new and you have not ever gotten it to boot.

Make sure the power supply is providing enough power and don't have any peripherals plugged in yet. If using usb for power, try another power supply.

Details you could provide to help us assist you are things like which image you are using, which installation instructions you are following with any deviations you did.
One detail that might not be clear in the instructions is that you decompress the .gz file at or after download and you image the physical sd card with the .img file as source. Others have incorrectly tried imaging a partition on the sd card or tried imaging from the compressed .gz file as a source.

The image that worked for myself and others is the 22.03.2 squashfs image:

Note that version 22.03.3 is building on the build-bots and will be available soon (maybe in a day or two if no problems appear).

I don't have a windows computer for reference but if you have a tool to see partitions, with the squashfs image on the sd card you should see two fairly small partitions on the sd card after imaging.

Hopefully others can help if you are using the ext4 filesystem image or you can try the squashfs image and I may be able to assist in more detail.

For more r4s info, see the device page at and look at any linked info like installing on an sd-card.

Beyond these ideas, you may need serial console access to see more of what is happening as slh indicated.


thanks for the detailed reply! i got it to work using the image you linked. i also used a different file archiver to decompress the gz file, as i think 7zip was casuing some of the issues

1 Like

You are welcome. I'm glad you got it running.

Good luck with the rest of your setup. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.