Issues getting internet connection to work on newly flashed Netgear r7800

First time installing OpenWrt 18.06.01 on my Netgear r7800.

I am unable to get an internet connection to work. I have my modem's ethernet plugged into the router and enabled radio0 and radio1 but I haven't changed anything else. Please tell me what settings do I have to change to get an internet connection working for my home router.


Does your ISP require any special configuration? Has this worked before using a different router?


My ISP (Spectrum) does not require any special configuration. My current modem has been used with a previous router just fine. I'm able to access the router via the wireless network after enabling radio0 and radio1. Any recommended settings changes would be welcome.

The fact is, of your ISP does not require any special configuration, then default settings should work fine, and changing them could make it worse. Let's try to see what happens when the router tries to bring up the WAN interface: log into the router, execute "logread -f", then restart the WAN interface, and post the messages here.

...except if the lease is still active and locked to a mac address which is quite common for a cable service which Spectrum seems to be according to Google (contact ISP support and tell them you have a new router).

Have you bridge your modem? Otherwise you'll possibly either have an IP address conflict and addition to that double NAT.

Try rebooting both the modem and the router if you not have done so already, the modem keeps a list of MACs it allows DHCP for which locks after a short uptime.

Good luck

1 Like