Issue with Wifi client mode - no internet - mixed WPA/WPA2 - PSK

Hello, I read all the topics in the forum but I believe there is no information about my problem.
First, you have to know that my configuration is working fine if the OpenWrt client is connected to some WPA2 encrypted router, the problem is only with mixed WPA/WPA2 - PSK.
I tried to use the automatic encryption as well as 'option encryption 'psk2'' or 'option encryption 'psk-mixed'' but the result was the same.

I'm sending you my wireless configuration:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ar933x_wmac'
	option disabled '0'
	option country 'GR'
	option htmode 'HT20'
	option channel '9'
	option legacy_rates '0'

config wifi-iface
	option network 'wwan'
	option ssid 'COSMOTE-488289'
	option device 'radio0'
	option mode 'sta'
	option bssid '58:76:AC:E8:15:D1'
	option key '*Indigochild8'
	option encryption 'psk-mixed'

And this is my network configuration:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdfc:58de:da8b::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'

config interface 'wwan'
	option proto 'dhcp'

Best regards Boyan.

Welcome to the community!

  • It's not clear if you're asking a question.
  • It's also not clear what's not working for you. I assume you're having an issue after disconnecting from the first and attempting to connect to a second AP?

Is this the working config or the non-working config?

What results?

I ask because your title says both "issue with Wifi client mode" and "no Internet" (as if you were able to connect) - but you then go on to discuss the encryption option. So to be clear, does your OpenWrt successfully associate with the upstream AP?

I figured out the problem. I was not related to the wifi encryption. I just change the OpenWRT client router network IP to be in a different scope and the problem was fixed.
@tmomas / or someone else - please delete my post.

1 Like

No worries, that was gonna be my suggestion.

The post is OK to be left - in order to help others.

WPA (1) has been deprecated for many years now, as it is considerably less secure than WPA2. There is essentially no hardware remaining in use that can't support WPA2.

"Mixed mode" was a stopgap for APs so that old WPA1 clients could still connect. When setting up a client, it isn't necessary since there are no WPA1 only APs any more. On your client, configure it to force a strong standard: at least WPA2 or WPA3 if supported by the AP.

2 Likes