Issue with VPN

Hi guys!

A VPN server is configured on the router Linksys WRT1900ACS. When connecting to it from a Windows PC (via openvpn), there are no problems (normal speed, all network resources are normally opened). But on Linux (Arch Linux, tried with two PC) with the same VPN client configuration as for Windows - the speed is much lower. Also, when changing and saving the settings of the web page of the router, an error occurs that the connection is not protected (firefox) and doesn't save anything. Through ssh often hangs, I have to reconnect the VPN connection. In general, it seems that something is blocking the VPN.

If you need any data, I can write it. Thank you.

you will need to provide a lot more detail (what VPN, what are your configs, etc.).

Just a thought, though... if you are using OpenVPN, you may be using dev tap for windows. That doesn't usually play nice with linux. Try dev tun instead (which may break windows compatibility)

@Spring Please include the information requested under Troubleshooting for your next post.

  • Please also include the OpenVPN [program] version running on the router, as well as on each of the two clients.

Unless fitting very specific use case scenarios, TUN should always be utilized.

  • Users utilizing TAP know exactly why they are, as there are specific use cases where TAP must be utilized.

I'm not aware of any issues with Windows utilizing TUN (at least as far back as Win8)... Could you elaborate on that please?

@JW0914 - I agree that tun should be used in the vast majority of cases.
Regarding tun issues with Windows -- I don't have a source to cite and have never tried it myself (I'm Mac, Linux, and iOS based, no Windows at all), but I have a recollection of someone saying that they could only use dev tap on Windows (dev tun failed). Maybe that was an edge case, or maybe something else with the config or the Windows firewall was really the root of the problem, but for some reason I was under the impression that Windows wasn't always happy with dev tun.

I configured the VPN from this link: OpenVPN (Server Setup). There is used dev tun.

Please include the information requested under Troubleshooting for your next post.

@psherman They were either doing something wrong, or perhaps were confused with the TAP adapter on Windows, and possibly believing that meant they had to use TAP

  • The Windows TCP/IP stack is completely different than Unix based OSes, and because of this, dummy/vLANs/new interfaces cannot be created without physical hardware for them to be tied to... This is why OpenVPN had to build separate software just to create a TAP adapter, which is awesome, because you can use their TAP adapter software to create as many interfaces as you want to create vLANs for separate uses =] (it's normally not possible to create vLANs with Windows)

Any chance you can share how you got openvpn running mate ? Did you follow any tutorials?


Hi guys! Sorry that I did not reply for a while. It seems I solved the problem. I tried to connect to VPN from another network and in Linux works fine now! It seems that the problem was only in one network. I will sort this out. Thank you all for your help!

Sorry that's the server setup I just want the client.

You can see this link: OpenVPN Setup Guide for Beginners

Thanks for the reply will have a look

Thanks again

That's the old OpenWrt wiki, which doesn't receive any updates any more.

New OpenWrt wiki:

Thanks will give it a blast.