Issue with RavPower RP-WD009 network settings

so im currently out of town and having issues setting up our routers for use with openwrt.

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr ''
option netmask ''

config globals 'globals'
option ula_prefix 'fdb8:9415:2428::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
option netmask ''
option ip6assign '60'
option ipaddr ''
option dns ''
option gateway ''

config switch
option name 'switch0'
option reset '1'
option enable_vlan '0'
i have connection to the internet via the wifi from the device, however i cant access LUCI as i have no web GUI and cant download the opkg update files as it continuously says request not permitted.
im positive its a easy fix however crawling the posts already made havent helped, looking for some help!

The DNS and the gateway are obviously wrong.

1 Like

So I have no control over the network as its a hotel but I've been connecting my computer to the ethernet from the hotel and doing a ipconfig to check the network settings, then using the info for the gateway which I've switched to but I was wondering what the DNS address should be? Is it just the DNS and gateway that are wrong? The is the address from the hotel it assigned my laptop and I used that after switching the ethernet.

This device has only one ethernet port. Therefore if you want to connect to the ethernet port of a hotel and share it wirelessly, you need to follow a few steps.
First reset the device to defaults.
Enable the wireless and configure it to your liking, wpa2 encryption, key.
Connect from wireless to the router. Then from the lan interface turn off bridge and remove eth0.
Create a new 'wan' interface with dhcp protocol, assign it to eth0 interface and assign it to wan firewall zone.

1 Like