Issue with multicast (SSDP) discovery on LAN bridge

I would like to use AirConnect on my Espressobin which I use as my internet router.
AirConnect discovers Sonos devices, broadcasts them as Airplay targets, and routes Airplay streams to them. (I have a bunch of older Sonos devices without built-in Airplay)

While the binary runs fine, it does not discover the Sonos devices in OpenWrt. It looks like the multicast packets are not routed properly. My issue is essentially this (I ran the same tests with equivalent results): it seems "normal multicast (SSDP) discovery is not working"

I can run the AirConnect binaries on a PC on the lan and it works as expected. I ran a test with the ARM binary in Armbian on the Espressobin, and things seems to work fine, so it seems a configuration issue in OpenWrt, but I am not sure where to go from here.

I opened port 5353 from/to lan on the firewall in various ways, I turned IGMP snooping for the LAN bridge interface on/off, tried to option " echo 0 > /sys/devices/virtual/net/br-lan/bridge/multicast_snooping" and so on, all to no avail.

Thanks for any advice.