Issue With Latest Trunk Builds?

I recently bricked my TPLink TL-W8960 V3 router when I flashed the LEDE snapshot on 18 March and just now I bricked my TPLink TL-MR3420 V2 router the same way, using the latest snapshot build.
First I thought it was because of the device itself(first one above), as the wiki suggested it might brick, but the stable build did not brick the device and only the wifi was not working due to no drivers but then i re-flashed a custom built snapshot firmware and now the device only has a boot-loop.
The 2nd device was having some problem with the stable build as the processor would go bonkers at time and so much load while it never happened before with the same configuration. I tried to trim out the problem but couldnt see anything unusual. So i decided to give it a try with latest snapshot build and now the same boot-loop for the 2nd device also.
Well I am back to basics now with two of my devices out of the way. I will have to wait for my TTL adapter to arrive to fix them.

So I want to ask is there something wrong with the snapshot builds or is it just me? Did anyone else have any problems with those builds?

Try this tutorial, which works for several TP-Link routers -

Rename the stock firmware files...



1 Like

W8960 V3 gets recognized as a LAN device after 1 or 2 reboots using a static IP of 192.168.1.x but the firmware never gets transferred. On the other hand MR3420 v2 never gets recognized.

Common issues I see when it doesn't work...

  1. TFTP server running on the attached computer does not have permissions through the firewall.

  2. Router not powered off first.

  3. Reset button not held in for at least 10 seconds after the router is powered on.

I know all of those already. I disabled everything, including firewall and antivirus. Still the file never gets transferred and I know my tftp server is working because the first time when i flashed the firmware from telnet I used the same with both antivirus and firewall turned on and it worked the first time.

The only thing I want to know right now is, whether the snapshots build can be relied upon and that the next time I flash one of those it doesn't brick the router. I am hoping someone might know if there is indeed a problem with the current builds.