Issue with installing several packages

Hi guys!

I couldn't install luci-app-transmission - git-17.119.62808-1497d4a-1 ... wen't to investigate, and found that other packages were affected. When I did the opkg install for transmission, this came up:

Error printed out is.

uci: Parse error (invalid command) at line 1, byte 0
uci: Entry not found
uci: Parse error (invalid command) at line 1, byte 0
Debugged the opkg output and what fails is when running /usr/lib/opkg/info/luci-app-transmission.postinst ... went there and found the file, and also a file called luci-app-transmission.postinst**-pkg**

Then found all of this "uncompleted upgrades" ...

root@RouterACS:/usr/lib/opkg/info# ls *-pkg
kmod-crypto-crc32.postinst-pkg     luci-app-statistics.postinst-pkg
kmod-crypto-des.postinst-pkg       luci-app-upnp.postinst-pkg
kmod-crypto-ecb.postinst-pkg       luci-mod-admin-full.postinst-pkg
kmod-crypto-md4.postinst-pkg       luci-theme-bootstrap.postinst-pkg
kmod-fs-cifs.postinst-pkg          tar.postinst-pkg
kmod-fs-f2fs.postinst-pkg

I'm on david's latest build, and I'm upgrading LEDE packages as they are released.

Is there something wrong with opkg?

Last time I found a similar issue, there was a typo in one of my "/etc/config" files: opkg calls uci during some installations, and uci reviews all config files each time; if there is a typo in your config files, opkg will fail (even if the typo is irrelevant to the packages being installed).

Execute "uci changes" and see if it reports any error.

#uci changes
uci: Parse error (invalid command) at line 1, byte 0
uci: Entry not found
uci: Parse error (invalid command) at line 1, byte 0

Same stuff :frowning:

I've found that it was throwing several errors because I've placed weird files in the /etc/config directory. I've moved them out, and now uci changes is just reporting one line with an error:

uci: Parse error (invalid command) at line 1, byte 0

FIXED IT!!! I had also a script in the /etc/config folder... just removed it and now UCI Changes is not reporting any errors,a nd I was able to install the packages. Thanks for the tip!