Issue using Luci with EAP-225


I'm working on doing an outdoor wifi deployment, and am using the TP-Link EAP225-Outdoor v3.
The issue is a bit confusing, because I am using two identical devices, and the other one can be accessed fine.
It may also be useful to note that I can only use the snapshot image currently available for this hardware, and that is is pretty thin on flash storage. It has 7.06MiB shown in the overview page.
I've obviously added luci to the package I downloaded, and also tried to remove dnsmasq, odhpcd and firewall packages.

Where my issue comes into play is when I try to connect the device to my network. Luci comes up fine on my laptop when directly connected, but when I plug it into my unmanaged, untagged switch, it will not connect to Luci. I can and have ssh'd into it on the network, though, and if needs must I could configure it through that, but.. I'd very much prefer not to.

Could anyone suggest what may be the issue and/or the fix?

still using the same IP ?

is uhttpd running ?

I have tried connecting to it both using the same IP as a static interface, and as an assigned IP as a DHCP client. Neither worked, unfortunately.

uhttpd must be running, at least it is for sure running before the switch is made, because I can access Luci at reset configuration fine.

did you try to copy the relevant parts of /etc/config/network from the working, to the non working device, and only changing the IP in the process ?

I did- unfortunately, due to this problem and other considerations, I reflashed and returned the devices in lieu of another model, Thanks very much for your help regardless.