Issue installing OpenWrt 18.06 on factory Linksys EA3500

I would like to use OpenWRT on my Linksys EA3500. According to the Table of Hardware, it's been supported since 2015, and I know from other forum posts that OpenWRT 18.06 runs on the EA3500. However, whenever I try to flash the factory.bin file using the Linksys Web UI, it doesn't take. Instead it reboots three times, then restores the original firmware. I had the same results with the 17.01.0, 17.01.5, 18.06.0, and 18.06.0-rc2 linksys_audi factory.bin files. Then when I tried the snapshot factory.bin (which is actually dated December 2017), the OpenWRT firmware seemed to take and it connected to the internet, but the Luci interface refused to connect. According to this reddit post, it seems I'm not the only one with this issue. Does anybody know of a workaround for this? For now I would rather not bother with the serial interface, but I might try building my own image and see how that goes.

1 Like

The ea3500 has had installation problems going all the way back to 17.01.0-rc1, snapshots usually do work though, but snapshots don't come with Luci installed, to install it you'll need to ssh into the ea3500 and run -

opkg update

opkg install luci

then Luci should be available @, if not clear your cookies and cache and try again.


Thank you for that info! I should have tried to SSH into it before restoring the factory image, but I assumed at the time that it wouldn't work if I tried. After installing Luci, I was able to use the firmware update tool to downgrade to the 18.06.0 release image. It worked just fine after resetting the configs to their default state. I would assume sysupgrade could accomplish the same task if I wanted to do it through the CLI.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.