Issue building php8-pecl-zmq package with OpenWrt 22.03

Hello everyone,

I am currently facing an issue while attempting to transition from OpenWrt 19.07 to OpenWrt 22.03. Specifically, I am trying to build a package named php8-pecl-zmq with OpenWrt 22.03. However, during the build process, I encountered the following error:

/builder/openwrt-22.03/build_dir/target-mipsel_24kc_musl/pecl-php8/zmq-1.1.3/libtool: line 482: CDPATH: command not found
libtool: Version mismatch error. This is libtool 2.4.2, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.2
libtool: and run autoconf again.
make[4]: *** [Makefile:209: zmq.lo] Error 63
make[4]: Leaving directory '/builder/openwrt-22.03/build_dir/target-mipsel_24kc_musl/pecl-php8/zmq-1.1.3'
make[3]: *** [Makefile:47: /builder/openwrt-22.03/build_dir/target-mipsel_24kc_musl/pecl-php8/zmq-1.1.3/.built] Error 2
make[3]: Leaving directory '/builder/openwrt-22.03/feeds/packages/lang/php8-pecl-zmq'
time: package/feeds/packages/php8-pecl-zmq/compile#0.08#0.01#0.09
ERROR: package/feeds/packages/php8-pecl-zmq failed to build.
make[2]: *** [package/Makefile:120: package/feeds/packages/php8-pecl-zmq/compile] Error 1
make[2]: Leaving directory '/builder/openwrt-22.03'
make[1]: *** [package/Makefile:114: /builder/openwrt-22.03/staging_dir/target-mipsel_24kc_musl/stamp/.package_compile] Error 2
make[1]: Leaving directory '/builder/openwrt-22.03'
make: *** [/builder/openwrt-22.03/include/toplevel.mk:230: world] Error 2

I would like to seek assistance in resolving this issue. Below are the details of the Makefile that i am using:

# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.

include $(TOPDIR)/rules.mk

PECL_NAME:=zmq
PECL_LONGNAME:=PHP extension for ZeroMQ software library
PKG_VERSION:=1.1.3
PKG_RELEASE:=1
PKG_HASH:=c492375818bd51b355352798fb94f04d6828c6aeda41ba813849624af74144ce

PKG_NAME:=php8-pecl-zmq
PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=http://pecl.php.net/get/

define Package/php8-pecl-zmq
    TITLE:=PHP ZeroMQ Extension
endef

define Package/php8-pecl-zmq/description
    PHP ZeroMQ Extension description
endef


PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>

PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE

PKG_BUILD_DIR:=$(BUILD_DIR)/pecl-php8/$(PECL_NAME)-$(PKG_VERSION)
PKG_BUILD_PARALLEL:=1

PKG_FIXUP:=autoreconf

include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
include ../php8/pecl.mk

CONFIGURE_ARGS+= \
        --with-zmq=yes \
        --with-czmq=no

$(eval $(call PHP8PECLPackage,$(PECL_NAME),$(PECL_LONGNAME),+libzmq))
$(eval $(call BuildPackage,$(PKG_NAME)))

Notably, I want to emphasize that the build process for this package was successful with OpenWrt 19.07. Any guidance or suggestions on how to resolve this issue and successfully build the php8-pecl-zmq package with OpenWrt 22.03 would be greatly appreciated.

Thank you for your support.