ISP's streaming boxes will not connect to my AP

Anyone spot something that would cause the ISP's boxes to not connect? Other devices such as iPhones, and iPads connect fine.

  1. I see the SSID (named Guest-5G) in the box's GUI so it is seeing it advertised
  2. I enter the password to the SSID in the GUI but the box fails to connect stating that the password is bad.

I do not see any output in logread -f that leads me to believe that the box is attempting to connect at all.

Hardware is R7800 running nightly snapshot.

/etc/config/wireless
onfig wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option country 'US'
	option cell_density '1'
	option beacon_int '101'
	option htmode 'VHT80'
	option txpower '25'
	option channel '149'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
	option band '2g'
	option htmode 'HT20'
	option country 'US'
	option cell_density '1'
	option beacon_int '101'
	option channel '6'
	option disabled '1'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Bee Hive-IOT'
	option encryption 'sae-mixed'
	option key 'xxx'
	option ieee80211w '1'
	option dtim_period '3'
	option wpa_disable_eapol_key_retries '1'
	option disabled '1'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Bee Hive'
	option network 'lan'
	option encryption 'sae-mixed'
	option key 'xxx'
	option ieee80211w '1'
	option dtim_period '3'
	option wpa_disable_eapol_key_retries '1'

config wifi-iface 'wifinet4'
	option device 'radio0'
	option mode 'ap'
	option network 'guest'
	option dtim_period '3'
	option ssid 'Guest-5G'
	option key 'xxx'
	option encryption 'sae-mixed'
	option wpa_disable_eapol_key_retries '1'

Strangely enough, if disable my R7800, and I use the ISP's provided all-in-one modem/wifi/router device with the very same SSID and password, they connect just fine.

Try either wpa2 or wpa3 instead of mixed mode - many devices do not work well with mixed mode operation.

Another thing that might be of issue is if you have Protected Management Frames (802.11w) enabled on your router wireless. Older devices, and even some modern streaming devices will not connect with PMF if it is set to "required."
If you still want PMF to be available for compatible devices though, set it to "optional" instead of "required."

1 Like

Thanks for the replies. These cheap android boxes indeed do not like mixed mode. Going to pure WPA2 fixed it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.