ISP Telekom IPv6 only (no IPv4)

Good day everyone!

I use OpenWrt 22.03 with the Linksys WRT32xr router directly behind the Telekom fibre optic modem. I can access the internet via the Telekom, set up via PPPoE. However, only IPv6 is supported. IPv6 ping from the router is possible. With IPv4 ping, I get the message

PING openwrt.org (139.59.209.225): 56 data bytes
ping: sendto: Network unreachable

I have completely reset one of the partitions and would like to get the connection running stably first and then restore my old one. I think this makes sense for troubleshooting.
Small note, I live in Germany and apparently have to be in VLAN7 to communicate with the ISP via PPPoE.
Below is my entire configuration:

ubus call system board; \
> uci export network; uci export dhcp; uci export firewall; \
> head -n -0 /etc/firewall.user; \
> iptables-save -c; ip -4 addr ; ip -4 ro li tab all ; ip -4 ru
{
        "kernel": "5.10.146",
        "hostname": "OpenWrt",
        "system": "ARMv7 Processor rev 1 (v7l)",
        "model": "Linksys WRT32X",
        "board_name": "linksys,wrt32x",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "22.03.2",
                "revision": "r19803-9a599fee93",
                "target": "mvebu/cortexa9",
                "description": "OpenWrt 22.03.2 r19803-9a599fee93"
        }
}
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'XXXXXXXXXXXX::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'

config device
        option name 'wan'
        option macaddr 'XXXXXXXXXXXX'

config interface 'wan'
        option proto 'pppoe'
        option device 'wan.7'
        option username 'XXXXXXXXXXXXXXX'
        option password 'XXXXXXXXXXXXXXX'
        option ipv6 'auto'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '7'
        option name 'wan.7'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

package firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

head: /etc/firewall.user: No such file or directory
-ash: iptables-save: not found
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
14: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-lan
       valid_lft forever preferred_lft forever
192.168.2.0/24 dev br-lan scope link  src 192.168.2.1
broadcast 127.0.0.0 dev lo table local scope link  src 127.0.0.1
local 127.0.0.0/8 dev lo table local scope host  src 127.0.0.1
local 127.0.0.1 dev lo table local scope host  src 127.0.0.1
broadcast 127.255.255.255 dev lo table local scope link  src 127.0.0.1
broadcast 192.168.2.0 dev br-lan table local scope link  src 192.168.2.1
local 192.168.2.1 dev br-lan table local scope host  src 192.168.2.1
broadcast 192.168.2.255 dev br-lan table local scope link  src 192.168.2.1
0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default

I hope the data are halfway usable and my problem is understandable, thank you very much!

If you have only IPv6 from the ISP then you need to install 464xlat.

2 Likes

Please show the output of:

nslookup openwrt.org
nslookup ipv4only.arpa.
2 Likes

OK, I have now installed 464xlat, unfortunately nothing has changed.

Do I have to configure anything else accordingly?

Outputs:

nslookup openwrt.org
Server:         127.0.0.1
Address:        127.0.0.1:53

Non-authoritative answer:
Name:   openwrt.org
Address: 139.59.209.225

Non-authoritative answer:
Name:   openwrt.org
Address: 2a03:b0c0:3:d0::1af1:1
 nslookup ipv4only.arpa.
Server:         127.0.0.1
Address:        127.0.0.1:53

Non-authoritative answer:
Name:   ipv4only.arpa
Address: 192.0.0.170
Name:   ipv4only.arpa
Address: 192.0.0.171

Non-authoritative answer:

Please run nslookup ipv4.tlund.se

Done

nslookup ipv4.tlund.se
Server:         127.0.0.1
Address:        127.0.0.1:53

Non-authoritative answer:
Name:   ipv4.tlund.se
Address: 193.15.228.195

Non-authoritative answer:

It looks like something is broken with IPv4, it does not look like IPv6 only scenario.
There is no Pref64 discovery, DNS64 does not work,...
If you connect your computer directly to the ISP modem and configure a PPPoE connection on it - what you will get?

I see you're on "22.03.2", please update to the latest if possible.

1 Like

This is expected, as Deutsche Telekom uses NAT64 only in the mobile network. On the fixed network, they provide dual stack access. The WAN configuration seems correct, so it is strange that there isn't any IPv4 address on the pppoe-wan interface.

@Lith7ium: Do you see an IPv4 address in the syslog messages from pppd? (If not you could try to add option pppd_options 'debug' to the WAN interface config section to see in more detail what is going on.)

And just to make sure, is Telekom your actual ISP, or do you have a contract with another provider that just uses their infrastructure? Because 1&1 typically uses DS-Lite. And in that case the package ds-lite would be required to get IPv4 access working.

3 Likes

Yes what you have posted shows no ISP connection at all. When PPP connects the driver should spawn an interface named pppoe-wan, and if the ISP supports v6, another interface called wan_6 (not wan6).

If your ISP uses NAT64 as the compatibility mechanism, their DNS server should be a DNS64 as well. When you nslookup an v4 only site, the DNS64 should provide a fake IPv6 which includes the site's IPv4 as the last 32 bits. (When your browser requests this IPv6 through their V6 only network, the ISP translates it to V4 by a big NAT64 box at the edge of their network which has a connection to the v4 Internet). The nslookups you have done do not show DNS64, they return no IPv6 for a V4 only site.

1 Like

The ip command is called with the option -4, so the posted data seems consistent with an IPv6-only connection.

I tried to set up the whole thing as a PPPoE connection via my Windows computer, but apparently I'm too stupid to do it.

On my router, I only get IPv6 addresses with an active PPPoE connection, but these then also work (such as the internal packet management in OpenWRT).

@janh - That is indeed a point. My provider is Vodafone, which uses the Deutsche Telekom network. So the possibility of DS-Lite sounds quite plausible.
I have now installed the package, but I am not sure about the configuration.

I found some pppd logs, if I understand it correctly, it seems to look quite good?

Wed Oct 18 16:07:01 2023 daemon.info pppd[2835]: PPP session is 3219
Wed Oct 18 16:07:01 2023 daemon.warn pppd[2835]: Connected to 20:e0:XXXXXXXX via interface wan.7
Wed Oct 18 16:07:01 2023 kern.info kernel: [   28.030327] pppoe-wan: renamed from ppp0
Wed Oct 18 16:07:01 2023 daemon.info pppd[2835]: Renamed interface ppp0 to pppoe-wan
Wed Oct 18 16:07:01 2023 daemon.info pppd[2835]: Using interface pppoe-wan
Wed Oct 18 16:07:01 2023 daemon.notice pppd[2835]: Connect: pppoe-wan <--> wan.7
Wed Oct 18 16:07:01 2023 daemon.info pppd[2835]: CHAP authentication succeeded: access accepted : vodafone-ftth.XXXXXXXXXXXX
Wed Oct 18 16:07:01 2023 daemon.notice pppd[2835]: CHAP authentication succeeded
Wed Oct 18 16:07:01 2023 daemon.notice pppd[2835]: peer from calling number 20:XXXXXXXXX authorized
Wed Oct 18 16:07:01 2023 daemon.notice pppd[2835]: local  LL address fe80:XXXXXXXXXX:ed28
Wed Oct 18 16:07:01 2023 daemon.notice pppd[2835]: remote LL address fe80:XXXXXXXXXX:9801
Wed Oct 18 16:07:01 2023 daemon.notice netifd: Network device 'pppoe-wan' link is up

I think we're on the right path there, aren't we?

Run ifstatus pppoe-wan (it may just be ifstatus wan).

I thought that the log would show the assignment of v4 and/or v6 addresses if the ISP pushes them.

Sure

 ifstatus wan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 1908,
        "l3_device": "pppoe-wan",
        "proto": "pppoe",
        "device": "wan.7",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "fe80:XXXXXXXXXXXX:ed28",
                        "mask": 128
                }
        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [

        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}

So you don't have any usable v4 or v6 IPs, only a link-local.

I don't know much about ppp but maybe some parameter needs to be set to request addresses. There is a working link to the ISP on vlan 7 since password etc was negotiated.

Please edit /etc/ppp/options to include the word "debug" as the very first line, then reconnect and repost the log.

1 Like

Are you sure that you need PPPoE?

2 Likes

Debug is switched on and all interfaces are restarted.

I assume that I have to use PPPoE, I received the corresponding access data for manual configuration. Unfortunately, it did not say which protocol should be used, but in the past I have always used PPPoE with DSL (not fibre - this is also the first time I have used fibre) and never had any problems with it. I therefore thought that this would also be correct.

Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'lan' is enabled
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'lan' is setting up now
Wed Oct 18 20:03:08 2023 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::22e0:9cff:fe37:9801%pppoe-wan: Address not available
Wed Oct 18 20:03:08 2023 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::22e0:9cff:fe37:9801%pppoe-wan: Address not available
Wed Oct 18 20:03:08 2023 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::22e0:9cff:fe37:9801%pppoe-wan: Address not available
Wed Oct 18 20:03:08 2023 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::22e0:9cff:fe37:9801%pppoe-wan: Address not available
Wed Oct 18 20:03:08 2023 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::22e0:9cff:fe37:9801%pppoe-wan: Address not available
Wed Oct 18 20:03:08 2023 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::22e0:9cff:fe37:9801%pppoe-wan: Address not available
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'lan' is now up
Wed Oct 18 20:03:08 2023 daemon.notice netifd: bridge 'br-lan' link is up
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'lan' has link connectivity
Wed Oct 18 20:03:08 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Wed Oct 18 20:03:08 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Wed Oct 18 20:03:08 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 2 addresses
Wed Oct 18 20:03:08 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Wed Oct 18 20:03:08 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Wed Oct 18 20:03:08 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Wed Oct 18 20:03:08 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 2 addresses
Wed Oct 18 20:03:08 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Wed Oct 18 20:03:08 2023 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'wan_6_4' is now down
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'wan_6_4' is disabled
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'wan_6_4' has link connectivity loss
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Network alias '' link is down
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'wan_6' is now down
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Network alias '' link is down
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'wan_6' has link connectivity loss
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'wan_6' is disabled
Wed Oct 18 20:03:08 2023 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Wed Oct 18 20:03:08 2023 daemon.info pppd[2835]: Terminating on signal 15
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Network device 'pppoe-wan' link is down
Wed Oct 18 20:03:08 2023 daemon.notice pppd[2835]: Connection terminated.
Wed Oct 18 20:03:08 2023 daemon.info pppd[2835]: Connect time 41.9 minutes.
Wed Oct 18 20:03:08 2023 daemon.info pppd[2835]: Sent 53534 bytes, received 1054085 bytes.
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'wan6' is now down
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'wan6' is setting up now
Wed Oct 18 20:03:08 2023 daemon.info pppd[2835]: Exit.
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'wan' is now down
Wed Oct 18 20:03:08 2023 kern.info kernel: [ 2537.899558] br-lan: port 2(lan2) entered disabled state
Wed Oct 18 20:03:08 2023 kern.info kernel: [ 2537.905208] br-lan: port 3(lan3) entered disabled state
Wed Oct 18 20:03:08 2023 kern.info kernel: [ 2537.910701] br-lan: port 4(lan4) entered disabled state
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'wan' is disabled
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'wan' is enabled
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'wan' is setting up now
Wed Oct 18 20:03:08 2023 daemon.notice netifd: bridge 'br-lan' link is down
Wed Oct 18 20:03:08 2023 daemon.notice netifd: Interface 'lan' has link connectivity loss
Wed Oct 18 20:03:08 2023 daemon.err insmod: module is already loaded - slhc
Wed Oct 18 20:03:08 2023 daemon.err insmod: module is already loaded - ppp_generic
Wed Oct 18 20:03:08 2023 daemon.err insmod: module is already loaded - pppox
Wed Oct 18 20:03:08 2023 daemon.err insmod: module is already loaded - pppoe
Wed Oct 18 20:03:08 2023 daemon.info pppd[7407]: Plugin pppoe.so loaded.
Wed Oct 18 20:03:08 2023 daemon.info pppd[7407]: PPPoE plugin from pppd 2.4.9
Wed Oct 18 20:03:08 2023 daemon.notice pppd[7407]: pppd 2.4.9 started by root, uid 0
Wed Oct 18 20:03:08 2023 daemon.debug pppd[7407]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Wed Oct 18 20:03:08 2023 daemon.debug pppd[7407]:  dst ff:ff:ff:ff:ff:ff  src XXXXXXXXXXXXXXXXX
Wed Oct 18 20:03:08 2023 daemon.debug pppd[7407]:  [service-name] [host-uniq  ef 1c 00 00]
Wed Oct 18 20:03:09 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Wed Oct 18 20:03:09 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Wed Oct 18 20:03:09 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 2 addresses
Wed Oct 18 20:03:09 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Wed Oct 18 20:03:09 2023 daemon.err odhcpd[2042]: Failed to send to ff02::1%lan@br-lan (Address not available)
Wed Oct 18 20:03:10 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Wed Oct 18 20:03:10 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Wed Oct 18 20:03:10 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 1 addresses
Wed Oct 18 20:03:10 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Wed Oct 18 20:03:10 2023 kern.info kernel: [ 2540.104251] mv88e6085 f1072004.mdio-mii:00 lan2: Link is Up - 1Gbps/Full - flow control rx/tx
Wed Oct 18 20:03:10 2023 kern.info kernel: [ 2540.112840] br-lan: port 2(lan2) entered blocking state
Wed Oct 18 20:03:10 2023 kern.info kernel: [ 2540.118090] br-lan: port 2(lan2) entered forwarding state
Wed Oct 18 20:03:10 2023 daemon.notice netifd: Network device 'lan2' link is up
Wed Oct 18 20:03:10 2023 daemon.notice netifd: bridge 'br-lan' link is up
Wed Oct 18 20:03:10 2023 daemon.notice netifd: Interface 'lan' has link connectivity
Wed Oct 18 20:03:10 2023 kern.info kernel: [ 2540.212220] mv88e6085 f1072004.mdio-mii:00 lan3: Link is Up - 1Gbps/Full - flow control rx/tx
Wed Oct 18 20:03:10 2023 kern.info kernel: [ 2540.220799] br-lan: port 3(lan3) entered blocking state
Wed Oct 18 20:03:10 2023 kern.info kernel: [ 2540.226048] br-lan: port 3(lan3) entered forwarding state
Wed Oct 18 20:03:10 2023 daemon.notice netifd: Network device 'lan3' link is up
Wed Oct 18 20:03:11 2023 kern.info kernel: [ 2540.434346] mv88e6085 f1072004.mdio-mii:00 lan4: Link is Up - 1Gbps/Full - flow control rx/tx
Wed Oct 18 20:03:11 2023 kern.info kernel: [ 2540.442924] br-lan: port 4(lan4) entered blocking state
Wed Oct 18 20:03:11 2023 kern.info kernel: [ 2540.448173] br-lan: port 4(lan4) entered forwarding state
Wed Oct 18 20:03:11 2023 daemon.notice netifd: Network device 'lan4' link is up
Wed Oct 18 20:03:11 2023 daemon.debug pppd[7407]: Recv PPPOE Discovery V1T1 PADT session 0xc93 length 0
Wed Oct 18 20:03:11 2023 daemon.debug pppd[7407]:  dst 62:38:XXXXXXXXX  src XXXXXXXXXXXX
Wed Oct 18 20:03:11 2023 daemon.debug pppd[7407]:
Wed Oct 18 20:03:13 2023 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.2.173 XXXXXXXXXXX
Wed Oct 18 20:03:13 2023 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.2.173 XXXXXXXXXXX DESKTOP-UU
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]:  dst ff:ff:ff:ff:ff:ff  src XXXXXXXXXXX
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]:  [service-name] [host-uniq  ef 1c 00 00]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: Recv PPPOE Discovery V1T1 PADO session 0x0 length 47
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]:  dst 62:38:XXXXXX  src XXXXXXXXXXXX
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]:  [service-name] [AC-name ILMCOS00201] [host-uniq  ef 1c 00 00] [AC-cookie  0d d7 62 b2 35 bd c8 7d 1e 05 f5 ce 48 fa ae 63]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: Send PPPOE Discovery V1T1 PADR session 0x0 length 32
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]:  dst 20:e0XXXXX src XXXXXXXXXXXX
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]:  [service-name] [host-uniq  ef 1c 00 00] [AC-cookie  0d d7 62 b2 35 bd c8 7d 1e 05 f5 ce 48 fa ae 63]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: Recv PPPOE Discovery V1T1 PADS session 0xc9f length 12
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]:  dst 62:XXXXXXXXXXXX  src XXXXXXXXXXXX
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]:  [service-name] [host-uniq  ef 1c 00 00]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: PADS: Service-Name: ''
Wed Oct 18 20:03:13 2023 daemon.info pppd[7407]: PPP session is 3231
Wed Oct 18 20:03:13 2023 daemon.warn pppd[7407]: Connected to 20:e0:XXXXXXXXXXXX via interface wan.7
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: using channel 2
Wed Oct 18 20:03:13 2023 kern.info kernel: [ 2543.181546] pppoe-wan: renamed from ppp0
Wed Oct 18 20:03:13 2023 daemon.info pppd[7407]: Renamed interface ppp0 to pppoe-wan
Wed Oct 18 20:03:13 2023 daemon.info pppd[7407]: Using interface pppoe-wan
Wed Oct 18 20:03:13 2023 daemon.notice pppd[7407]: Connect: pppoe-wan <--> wan.7
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x795c11db>]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: rcvd [LCP ConfReq id=0x2e <mru 1492> <auth chap MD5> <magic 0x47217e77>]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: sent [LCP ConfAck id=0x2e <mru 1492> <auth chap MD5> <magic 0x47217e77>]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: rcvd [LCP ConfAck id=0x1 <mru 1492> <magic 0x795c11db>]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: sent [LCP EchoReq id=0x0 magic=0x795c11db]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: rcvd [CHAP Challenge id=0x1 <300e73b21b7b65f83eea77085523512a>, name = "ILMCOS00201"]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: sent [CHAP Response id=0x1 <fbf825371bc2e0290be61daf3202e5eb>, name = "vodafone-ftthXXXXXXXXXXXX"]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: rcvd [CHAP Success id=0x1 "access accepted : vodafone-ftthXXXXXXXXXXXX"]
Wed Oct 18 20:03:13 2023 daemon.info pppd[7407]: CHAP authentication succeeded: access accepted : vodafone-ftthXXXXXXXXXXXX
Wed Oct 18 20:03:13 2023 daemon.notice pppd[7407]: CHAP authentication succeeded
Wed Oct 18 20:03:13 2023 daemon.notice pppd[7407]: peer from calling number 20:E0XXXXXXXXXXXX authorized
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: sent [IPV6CP ConfReq id=0x1 <addr fe80:XXXXXXXXXXXX>]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: rcvd [IPV6CP ConfReq id=0xb6 <addr fe80:XXXXXXXXXXXX>]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: sent [IPV6CP ConfAck id=0xb6 <addr fe80:XXXXXXXXXXXX>]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: rcvd [LCP ProtRej id=0x2f 80 21 01 01 00 16 03 06 00 00 00 00 81 06 00 00 00 00 83 06 00 00 00 00 00 00 00 00 00 00 00 00 ...]
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: Protocol-Reject for 'Internet Protocol Control Protocol' (0x8021) received
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: rcvd [IPV6CP ConfAck id=0x1 <addr fe80::64c8:0509:c6bb:cd77>]
Wed Oct 18 20:03:13 2023 daemon.notice pppd[7407]: local  LL address fe80:XXXXXXXXXXXX
Wed Oct 18 20:03:13 2023 daemon.notice pppd[7407]: remote LL address fe80:XXXXXXXXXXXX1
Wed Oct 18 20:03:13 2023 daemon.debug pppd[7407]: Script /lib/netifd/ppp6-up started (pid 7660)
Wed Oct 18 20:03:13 2023 daemon.warn dnsmasq[1]: failed to create listening socket for fe80:XXXXXXXXXXXX:9801%pppoe-wan: Address not available
Wed Oct 18 20:03:13 2023 daemon.warn dnsmasq[1]: failed to create listening socket for fe80:XXXXXXXXXXXX:9801%pppoe-wan: Address not available
Wed Oct 18 20:03:13 2023 daemon.notice netifd: Network device 'pppoe-wan' link is up
Wed Oct 18 20:03:13 2023 daemon.notice netifd: Network alias 'pppoe-wan' link is up
Wed Oct 18 20:03:13 2023 daemon.notice netifd: Interface 'wan' is now up
Wed Oct 18 20:03:14 2023 daemon.notice netifd: Interface 'wan_6' is enabled
Wed Oct 18 20:03:14 2023 daemon.notice netifd: Interface 'wan_6' has link connectivity
Wed Oct 18 20:03:14 2023 daemon.notice netifd: Interface 'wan_6' is setting up now
Wed Oct 18 20:03:14 2023 daemon.debug pppd[7407]: Script /lib/netifd/ppp6-up finished (pid 7660), status = 0x0
Wed Oct 18 20:03:14 2023 user.notice firewall: Reloading firewall due to ifup of wan (pppoe-wan)
Wed Oct 18 20:03:17 2023 daemon.warn dnsmasq[1]: failed to create listening socket for fe80:XXXXXXXXXXXX:9801%pppoe-wan: Address not available
Wed Oct 18 20:03:17 2023 daemon.warn dnsmasq[1]: failed to create listening socket for fe80:XXXXXXXXXXXX:9801%pppoe-wan: Address not available
Wed Oct 18 20:03:17 2023 daemon.notice netifd: Network alias 'pppoe-wan' link is up
Wed Oct 18 20:03:17 2023 daemon.notice netifd: Interface 'wan_6' is now up
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq[1]: using nameserver 2a01:860::53#53
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq[1]: using nameserver 2a01:860::153#53
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Wed Oct 18 20:03:17 2023 daemon.notice netifd: Interface 'wan_6_4' is enabled
Wed Oct 18 20:03:17 2023 daemon.notice netifd: Interface 'wan_6_4' has link connectivity
Wed Oct 18 20:03:17 2023 daemon.notice netifd: Interface 'wan_6_4' is setting up now
Wed Oct 18 20:03:17 2023 daemon.notice netifd: Interface 'wan_6_4' is now up
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 2 addresses
Wed Oct 18 20:03:17 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Wed Oct 18 20:03:17 2023 user.notice firewall: Reloading firewall due to ifup of wan_6 (pppoe-wan)
Wed Oct 18 20:03:17 2023 user.notice firewall: Reloading firewall due to ifup of wan_6_4 (pppoe-wan)
Wed Oct 18 20:03:19 2023 daemon.warn dnsmasq[1]: failed to create listening socket for fe80:XXXXXXXXXXXX:9801%pppoe-wan: Address not available
Wed Oct 18 20:03:19 2023 daemon.warn dnsmasq[1]: failed to create listening socket for fe80:XXXXXXXXXXXX:9801%pppoe-wan: Address not available

Thanks, this confirms an IPv6-only connection. However,

also means that 464XLAT is expected to work. We can check whether the ISP is doing NAT64 like this:

curl -v 'http://[64:ff9b::34.223.124.45]'

or

uclient-fetch -O - 'http://[64:ff9b::34.223.124.45]'

Does this result in any output?

The address itself I can't reach at all, mhhh

uclient-fetch -O - 'http://[64:ff9b::34.223.124.45]'
Downloading 'http://[64:ff9b::34.223.124.45]'
Failed to send request: Operation not permitted

PING 64:ff9b::34.223.124.45 (64:ff9b::22df:7c2d): 56 data bytes
--- 64:ff9b::34.223.124.45 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss

So this is not a 464XLAT based connection. We have already excluded 464XLAT and DS-LITE, so maybe it is MAP-T? The package name is map. Unfortunately, I have no experience with such networks.

2 Likes