ISP router gives IPv6 connectivity, OpenWrt client router doesn't

I re-enabled them and it still works fine! :ok_hand:

Great, you're good to go then!

1 Like

On a tangentially related note... My OpenWrt router is setup with DDNS and OpenVPN. The DDNS is currently using the IPv4 address. Is it better to use the IPv6 address now that IPv6 is functioning properly?

You can use either or both.

1 Like

Thank you so much for your help. You have made me a happy man.

I hope to become more competent as I use OpenWrt going forward.

Have a fabulous day!

1 Like

After setting this up at home with my home ISP, it was running very smoothly.

I have now moved the router to its intended final location, but it now offers very poor/choppy connectivity. It's like flipping a coin whether or not a site I visit will load, or time out. If I just quickly open five or six new tabs in Firefox, half of them will fail to load.

I noticed that, unlike my initial problem above, where I wasn't getting prefix deligation, the ISP server I am connected to here (NTT Communications Corporation) does give prefix deligation. So, I rolled back the IPv6 relay setup to the standard settings (I think).

Still, no impact on the poor connectivity. Any insight/advice would be welcome!

> uci export network; \
> uci export dhcp; uci export firewall; \
> head -n -0 /etc/firewall.user; \
> ifstatus wan6; ifstatus wan6
{
        "kernel": "5.4.179",
        "hostname": "ToshimaVPN",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "ELECOM WRC-1750GST2",
        "board_name": "elecom,wrc-1750gst2",
        "release": {
                "distribution": "OpenWrt",
                "version": "21.02.2",
                "revision": "r16495-bf0c965af0",
                "target": "ramips/mt7621",
                "description": "OpenWrt 21.02.2 r16495-bf0c965af0"
        }
}
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd9c:082f:9c1c::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option dhcpv6 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'wan6'
        option interface 'wan6'
        option ignore '1'
        list ra_flags 'none'

package firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone 'lan'
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list device 'tun+'

config zone 'wan'
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option input 'REJECT'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'
        list dest_ip 'fc00::/6'
        list src_ip 'fc00::/6'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Support-UDP-Traceroute'
        option src 'wan'
        option dest_port '33434:33689'
        option proto 'udp'
        option family 'ipv4'
        option target 'REJECT'
        option enabled '0'

config include
        option path '/etc/firewall.user'

config rule
        option name 'Allow-SSH'
        list proto 'tcp'
        option src 'wan'
        option target 'ACCEPT'
        option dest_port '11360'

config rule 'ovpn'
        option name 'Allow-OpenVPN'
        option src 'wan'
        option dest_port '11361'
        option proto 'udp'
        option target 'ACCEPT'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 2441,
        "l3_device": "wan",
        "proto": "dhcpv6",
        "device": "wan",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2400:4050:882:3300:6ab:18ff:fe20:826c",
                        "mask": 64,
                        "preferred": 11022,
                        "valid": 12822
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2400:4050:882:33f0::",
                        "mask": 60,
                        "preferred": 11958,
                        "valid": 11958,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2400:4050:882:33f0::",
                                        "mask": 60
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2400:4050:882:3300::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 12822,
                        "source": "::/0"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::2eff:65ff:fe60:7115",
                        "metric": 512,
                        "valid": 7422,
                        "source": "2400:4050:882:33f0::/60"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::2eff:65ff:fe60:7115",
                        "metric": 512,
                        "valid": 7422,
                        "source": "2400:4050:882:3300:6ab:18ff:fe20:826c/64"
                }
        ],
        "dns-server": [
                "2400:4050:882:3300:2eff:65ff:fe60:7115"
        ],
        "dns-search": [
                "flets-east.jp",
                "iptvf.jp"
        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "0017001024004050088233002eff65fffe607115001800190a666c6574732d65617374026a7000056970747666026a70000016001024004050088233002eff65fffe607115001f0020240401a811020000000000000000000a240401a811020000000000000000000b"
        }
}
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 2441,
        "l3_device": "wan",
        "proto": "dhcpv6",
        "device": "wan",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2400:4050:882:3300:6ab:18ff:fe20:826c",
                        "mask": 64,
                        "preferred": 11022,
                        "valid": 12822
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2400:4050:882:33f0::",
                        "mask": 60,
                        "preferred": 11958,
                        "valid": 11958,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2400:4050:882:33f0::",
                                        "mask": 60
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2400:4050:882:3300::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 12822,
                        "source": "::/0"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::2eff:65ff:fe60:7115",
                        "metric": 512,
                        "valid": 7422,
                        "source": "2400:4050:882:33f0::/60"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::2eff:65ff:fe60:7115",
                        "metric": 512,
                        "valid": 7422,
                        "source": "2400:4050:882:3300:6ab:18ff:fe20:826c/64"
                }
        ],
        "dns-server": [
                "2400:4050:882:3300:2eff:65ff:fe60:7115"
        ],
        "dns-search": [
                "flets-east.jp",
                "iptvf.jp"
        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "0017001024004050088233002eff65fffe607115001800190a666c6574732d65617374026a7000056970747666026a70000016001024004050088233002eff65fffe607115001f0020240401a811020000000000000000000a240401a811020000000000000000000b"
        }
}

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.