Is there UniFi 6 LR v4? (2245K)

Continuing the discussion from UniFi 6 LR v2 ethernet not working:

I have the same question.
Got few months ago UniFi 6 LR with a number of (2245K), also read whole issue on the v1,v2 and v3 matter.
So I waited those few months to see what will happen. Still @ngscb seems to have problem with his model.
I was happy to see v3 fixed issue, until saw this message.
I'm not able to repair bricked device. Too much of a newbe for this.
Also won't risk bricking device.
Anyone can confirm that there is issue with 2245K?

Just bought three 6 LR to use with OpenWrt. Two (date codes 2320V) work fine with V3 23.05.0. The third unit is marked date code 2334V. Installing v3 appears to boot normally-- the LED flashes white for a while then changes to solid blue-- but no communication through the Ethernet port though Ethernet carrier is present. The same thing happens with V2 OpenWrt.

I TFTP flashed the 2334 unit back to stock and examine the stock BZboot log.

[    1.265525] libphy: Fixed MDIO Bus: probed
[    1.270098] mtk_sgmii_init(): detect AQR112C_CARD
[    1.308607] libphy: mdio: probed
[    1.312956] mtk_soc_eth 1b100000.ethernet: connected mac 0 to PHY at fixed-0:00 [uid=00000000, driver=Generic PHY]
[    1.323307] eth0: assigned ifindex: 2
[    1.327258] mtk_soc_eth 1b100000.ethernet eth0: mediatek frame engine at 0xffffff800b680000, irq 250
[    1.336502] i2c /dev entries driver
[    1.341865] MTK_WDT_NONRST_REG(20000000)
[    1.345962] mtk-wdt 10212000.watchdog: register restart_handler on reboot_notifier_list for psci reset
[    1.355269] mtk-wdt 10212000.watchdog: Watchdog enabled (timeout=31 sec, nowayout=0)
[    1.363212] register cpuidle driver!!!!!!!!!!!!!!!!!
[    2.311825] mtk_soc_eth 1b100000.ethernet: path gmac1_sgmii in set_mux_gdm1_to_gmac1_esw updated = 1
[    2.320960] mtk_soc_eth 1b100000.ethernet: mux mux_gmac2_gmac0_to_gephy isn't present on the SoC
[    2.329740] mtk_soc_eth 1b100000.ethernet: mux mux_u3_gmac2_to_qphy isn't present on the SoC
[    2.338179] mtk_soc_eth 1b100000.ethernet: path gmac1_sgmii in set_mux_gmac1_gmac2_to_sgmii_rgmii updated = 1
[    2.348090] mtk_soc_eth 1b100000.ethernet: mux mux_gmac12_to_gephy_sgmii isn't present on the SoC
[    2.357226] mtk_soc_eth 1b100000.ethernet: Disable flow control for AQR PHY mcr:0x105e32b

...
[    3.427931] rtl8367s_hw_reset(): AQR112C_CARD reset...
[    3.934746] [rtl8367s_swconfig_init]

So I'm guessing they went back to an AQR PHY but maybe not the same as the V2 has.

If anyone has a V2 could they please check the boot log for the chip number etc?

1 Like

I have just received a 6 LR with date code 2336K. It came with FW 5.60.8 (which is ancient).

After flashing to FW 6.2.49 I saw:

U6-LR-BZ.6.2.49# dmesg | grep mtk_sgmii_init
[    1.265811] mtk_sgmii_init(): detect AQR112C_CARD

I can confirm that appears to be a v2 hardware and it works fine with 23.05.2 for v2.

Yes after trying again I flashed V2 build and it works. For some reason it was not issuing IPv4 addresses but I was able to SSH in with IPv6 and re-flash.

I got an RMA'ed replacement AP dated 2245K, and the V3 image worked. It appears that firmware 6.0.25 had a broken dmesg (being truncated at the start). Upgrading to firmware 6.6.55 showed the RTL8211 log line; flashing the V3 image worked without a problem.