Is there no samba for my version?

Hi,

I have a brand-new installation and cannot install samba.
Am I doing something wrong?

> cat /etc/openwrt_release 
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='22.03.5'
DISTRIB_REVISION='r20134-5f15225c1e'
DISTRIB_TARGET='ath79/nand'
DISTRIB_ARCH='mips_24kc'
DISTRIB_DESCRIPTION='OpenWrt 22.03.5 r20134-5f15225c1e'
DISTRIB_TAINTS=''
> opkg list | grep samba
luci-app-samba4 - git-21.223.80587-f533f9d - Network Shares - Samba 4 SMB/CIFS fileserver
...
> opkg install luci-app-samba4
Unknown package 'luci-app-samba4'.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency samba4-server for luci-app-samba4
 * pkg_hash_fetch_best_installation_candidate: Packages for luci-app-samba4 found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package luci-app-samba4.

What is the output of the following

opkg update
opkg install luci-app-samba4
1 Like

Did an update before (sorry, forgot to mention that), but just tried again:

> opkg update
Downloading https://downloads.openwrt.org/releases/22.03.5/targets/ath79/nand/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_core
Downloading https://downloads.openwrt.org/releases/22.03.5/targets/ath79/nand/packages/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/22.03.5/packages/mips_24kc/base/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_base
Downloading https://downloads.openwrt.org/releases/22.03.5/packages/mips_24kc/base/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/22.03.5/packages/mips_24kc/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_luci
Downloading https://downloads.openwrt.org/releases/22.03.5/packages/mips_24kc/luci/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/22.03.5/packages/mips_24kc/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_packages
Downloading https://downloads.openwrt.org/releases/22.03.5/packages/mips_24kc/packages/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/22.03.5/packages/mips_24kc/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_routing
Downloading https://downloads.openwrt.org/releases/22.03.5/packages/mips_24kc/routing/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/22.03.5/packages/mips_24kc/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_telephony
Downloading https://downloads.openwrt.org/releases/22.03.5/packages/mips_24kc/telephony/Packages.sig
Signature check passed.

> opkg install luci-app-samba4
Unknown package 'luci-app-samba4'.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency samba4-server for luci-app-samba4
 * pkg_hash_fetch_best_installation_candidate: Packages for luci-app-samba4 found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package luci-app-samba4.

Missing packages in 22.03.5 (strongswan*) - #4 by vgaetera

1 Like

temporary as "in a few days" or as "in a few weeks" - do you have an idea?

I would not have a problem waiting a few days but otherwise I would install another version as I need it.

You could alternatively consider ksmbd

1 Like

Thanks for the suggestion. I've never used that but I'll try it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.