Is There A Problem With Upgrading From Snapshot To Release?

Currently I'm running the 17.01.2 snapshot, and I'm not sure if I read it right about if you are using snapshot you'll need to upgrade to snapshot, is that correct? If so I'll have to revert back to stock and go through the .bin image then the sysupgrade image from the Release builds, but the problem is i'm using the snapshot build since it was the only one that worked for the EA3500 and the release version doesn't flash at all at least back in June, I guess I'm using snapshot builds for now unless somethings changed in the past several months. Regards, onefreeman

I went ahead and used the sysupgrade.tar.xz from the, I had originally had the 17.01.2 snapshot for the linksys ea3500. So far it so good wifi is a bit short on the bandwidth, but stable enough. I just flashed it from GUI didn't save settings but I reset to defaults first, and it's been fine since this last post.

fwiw, 17.01.2 is a LEDE 'stable' release too. ie. not a snapshot.

Not sure what your asking? At the time the snapshot is what worked for the rest of the install process to lede-project firmware, at the time 3 months ago on the linksys ea3500. Since then I updated my OP that i updated to the recent release build.