Is the Wan Mac address override working in 19 with Luci?

The option is there but it doesn't work here with a Linksys EA6350?

If i can't simply change the Wan Mac Address in Luci then i can't get on the internet or swap between multiple routers for testing as i can't wait hours for my ISP to assign a new IP address.

Even bottom end routers have a Wan Mac clone/spoof setting in their firmware GUI so if Openwrt doesn't have it then i can't use it. :frowning_face:

Try setting the MAC of the underlying Ethernet interface, probably eth1.

Is that in Luci as all i can see is override for Wan / Lan?

If I'm reading the makefile right, this looks like one of those devices which creates a separate wan_dev section in the network config.
If that's the case, it needs to be adjusted there.

There was some discussion a little while ago that LUCI was not properly handling this scenario, but I don't recall if or when it was fixed.

If guess it was after v18 though, maybe more like 18.06.2?

Context: MAC override does not work

and an OPEN Luci issue:


I can also confirm 'Override MAC address' in LuCI -> Interfaces -> WAN -> Advanced Settings has no effect even though the entry is correctly added to the 'wan' device in the /etc/config/network file on my EA6350 with OpenWrt 19.07 snapshot.

But if I manually edit wan_dev for 'eth1' in /etc/config/network as suggested by @lantis1008

config device 'wan_dev'
        option name 'eth1'
        option macaddr '60:38:e0:99:11:11'

It does work

root@OpenWrt:/etc/config# ifconfig

eth1      Link encap:Ethernet  HWaddr 60:38:E0:99:11:11
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::6238:e0ff:fe99:1111/64 Scope:Link
          RX packets:2899 errors:0 dropped:12 overruns:0 frame:0
          TX packets:1709 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1335608 (1.2 MiB)  TX bytes:358070 (349.6 KiB)

I can also confirm editing 'MAC address override' option using LuCI still works correctly on HH5A with OpenWrt 19.07 snapshot on WAN device for interface 'eth0.2' as it does for 18.06 and 17.01. (It always puzzled me why 'option macaddr' can appear in both 'wan' and 'wan_dev' sections of the /e/c/network file for the HH5A)


Thanks both for confirming the issue , if i log in via SSH does openwrt have a built in config editor?


yes, it's called 'vi'. There are online guides for vi. I believe there are other editors which you can install.

fwiw, if you just wish to learn the 'very basic commands' with pictures to use vi, see also section 10 of the HH5A guide:

If you are a Windows user, 'winscp' has a built in editor which you can use to make 'simple' changes too.


Thanks both , i've used vi before so i'll give it a go later and report back.

@bill888 any other issues i should be aware of with this router , is 5G WiFi working ok?


TBH, I haven't used the wifi much on my EA6350v3 to be able to comment on stability/reliability. I'm still testing the openvpn client package with one ethernet wired device since I got the router last week to assess vpn speed and stability.

You are probably aware the VLAN functionality is incomplete/broken on ipq4* devices.

1 Like

VLANs can be configured in sophisticated ways, though a little forethought is required. Mainly not using VLAN 1 or 2.


That worked thanks , I'd forgotten just how annoying vi is as a editor but it got the job done.

It's ok doing this as a temp work around but it's of no use long term for family members so i hope they fix it or i can't use openwrt.

Not sure if i've found a bug with Luci or a hardware issue but traffic for WiFi is pegged out on full even though it's disabled , @bill888 could you check yours in the status traffic section?


A wlan0 tab (2.4 GHz) exists even though wifi is Disabled.

(When I check my HH5A using older LEDE 17.01. When wifi disabled, there are no wlan0 or wlan1 tabs, but they both appear when wifi is enabled.)

I'm using older 19.07 snapshot from 25th July btw.
luci-mod-status git-19.190.55584-ab90938-1

Looks like a bug. You could report it here?

fwiw, I tried renaming the interface as shown below.

I know on HH5A, it causes the router to assign a random mac address to the optional ethernet WAN port (when enabled), every time the router is 'power cycled'. But on ea6350v3, it assigns the same mac address as used by eth0.

config device 'wan_dev'
        option name 'dsl0'      # eg. renamed from eth1 to dsl0
        option macaddr '60:38:e0:99:11:11'
1 Like

Thanks Bill , i'll have to look later but i'm pretty sure i'm using Aug 2nd snapshot.

I'll also do a software reset and check from scratch later as i'm not sure if it was a Wlan tab or the Wireless tab but i had a pink block of traffic stuck at 100% moving across the screen.

OpenWrt 19.07-SNAPSHOT r10287-a941d39460

Status / realtime graphs / wireless

In the Wireless tab Wlan0 and Wlan1 the noise level is on full (on the top graph) even though wireless is disabled , is that normal or should i start a new thread?

The Signal strength graph is 'enabled' in OpenWrt 18 and 19 when I checked my spare HH5A with wifi disabled. ie. there is a vertical axis showing range such as -258dBm to -255 dBm in your picture, and the pink graph shows noise level of -255 dBm.

On LEDE 17, the graph is 'disabled'. ie. no vertical axis displayed and no pink graph. 0dBm reported at below the graphs.

Everything is 'normal' for OpenWrt 18 & 19 imho.

Thanks Bill , i'll start a thread to confirm everybody else has it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.