Is the ipopt package already installed in my downloaded firmware?

I just installed OpenWRT
On a Linksys WRT1900AC router. That worked fine.
I set up the wifi and all the usual stuff. That's as far as I got.
I added a iptables firewall rule. To configure TTL.
Then on reading I found that I might have to install this package with package manager.

package: iptables-mod-ipopt

But I thought it might be in there already. Is it? I haven't brought the box online because it's not for this location anyway, so it currently has no internet access to install packages.
But it might be unnecessary.

Is it in there or do I have to install it?
It's been eons since I have use a package manager on unix. Heh.
Any help anyone can give would be appreciated.

SSH in to the router and run the following -

opkg update

opkg list-installed | grep iptables

iptables-mod-ipopt is installed on my device.

1 Like

Yeah, well, that won't currently work since the router has not seen the internet yet. It's not for this location. I suppose I could try to find a way to give it some internet here but I already have a router and it's all set up.
But the question is "Is the ipopt package in the file I used to flash the router?"
or do I have to install it?

...and the answer can be found by

You do not need internet for running a local command on the router.

Most likely the optional package is not installed, yet.

But probably do to use package manager, unless there is a local way to install it. Is there?

The package manager is installed by default.
No need for internet for checking the list of locally installed packages.

Just try it.
You have been arguing against the advice longer than you would have spent actually running the command you were given already in the first answer.

Ps. The list of installed packages is also visible in Luci GUI, software page.


I'm not arguing against the advice. Just asking if I need internet for package manager to install. Like the old apt get stuff on Linux which I used. I appreciate your good advice. It's been ages since I have used any of this.

Unless there is a way to install that package without internet. Is there? I'm reading all the stuff on github, but I haven't done any of that before. So I am a little confused. As you can imagine!

I found this. It's kind of helpful.

For finding out if the package is installed, you do not need internet.

If the package is missing, you could download the package (for your router) as an d.ipk file, transfer that via scp to the router's /tmp , and use opkg to install it from that .ipk file. Again, no public internet needed.

I've been searching for a d.ipk file for ipopt. I haven't found it yet.
I did find a post from a guy who downloaded the latest snapshot build and got errors on install. I guess I don't know how to find it yet. He was told to use the stable build. I looked on github and there are mostly snapshot builds. I didn't find the stable ones, yet.

Before I have to do something I have no experience with I research it. Thanks for the help!
I guess the system knows what to install with package manager. Maybe that's the way to proceed, find a way to get this thing internet. That would be a fairly long cable.

For 21.02.2, Linksys wrt1900ac


That is the underlying kernel module.

The userspace package is in
File iptables-mod-ipopt_1.8.7-1_arm_cortex-a9_vfpv3-d16.ipk

Experience is what you get after you need it.

You're getting good advice from @hnyman.
Alternatively, you could connect the router to the internet, unless this is not physically possible. If you have specific concerns, we can probably address those.

Well, it's not that it couldn't be connected to the internet. It's just inconvenient in this case. I guess it's time to suck it up and connect to the internet and let package manager do it's thing.

Thanks for all the help! I learned some things.

Well, I tried with the UI, it doesn't list ipopt,
So I put
In the install by url luci box, and I got errors.

Collected errors:
 * wfopen: No such file or directory.
 * pkg_init_from_file: Failed to extract control file from

I figured out how to use package manager normally. It all worked!

#### Executing package manager

Installing iptables-mod-ipopt (1.8.7-1) to root... Downloading
Installing kmod-ipt-ipopt (5.4.179-1) to root... Downloading 
Configuring kmod-ipt-ipopt. Configuring iptables-mod-ipopt.

Thanks for all your help.

Oh, this is interesting. I could not login with firefox even though I know my pw. It worked in Chrome.
I read where this can be a cookie problem. I have to look into that.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.