Is STP possible on a vlan with 22.03 / DSA?

I'm using a mesh router as an AP so there are definitely loops in my network topology and I sometimes get the "received packet with own address" warnings which I'm trying to get rid of.

Hard to be certain but I think they are duplicated ARP requests to wifi clients flooded back to me by the AP because I sometimes see 3 copies of them with tcpdump.

Openwrt router (22.03) has DSA style setup with br-lan configured for bridge vlan filtering. STP is enabled and the router does become master for the untagged management VLAN. That is enough to work most of the time but every few days I get bursts of duplicate packets every five minutes for several hours.

For the tagged VLAN's the AP ( an Orbi RBK50 ) creates a separate bridge for each vlan with separate STP instances which I suspect is normal for an swconfig setup but only the untagged bridge recognizes that the router exists.

Is there a way to encourage these to play nicer together or are the periodic warning messages something I just have to live with ?

My config:


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config device
        option name 'br-lan'
        option type 'bridge'
        option igmp_snooping '1'
        option ipv6 '0'
        list ports 'eth1'
        list ports 'eth2'
        list ports 'eth3'
        option mtu '4000'
        option ageing_time '300'
        option priority '1'
        option stp '1'
        option forward_delay '2'

config interface 'lan'
        option proto 'static'
        option defaultroute '0'
        list dns '192.168.2.100'
        option device 'br-lan.50'
        list ipaddr '192.168.1.1/22'
        list ipaddr '192.168.1.11/32'

config interface 'wan'
        option device 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0'
        option proto 'dhcpv6'
        option auto '0'
        option reqaddress 'try'
        option reqprefix 'auto'

config device
        option name 'eth2'
        option mtu '4000'

config device
        option type '8021q'
        option ifname 'br-lan'
        option vid '50'
        option name 'br-lan.50'
        option mtu '4000'
        option ipv6 '0'

config device
        option type '8021q'
        option ifname 'br-lan'
        option vid '10'
        option name 'br-lan.10'
        option mtu '1500'
        option ipv6 '0'

config device
        option type '8021q'
        option ifname 'br-lan'
        option vid '40'
        option name 'br-lan.40'
        option ipv6 '0'

config bridge-vlan
        option device 'br-lan'
        option vlan '10'
        list ports 'eth1:t'
        list ports 'eth2:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '40'
        list ports 'eth1:t'
        list ports 'eth2:u*'
        list ports 'eth3:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '50'
        list ports 'eth1:t'
        list ports 'eth2:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '4'
        list ports 'eth1'

config interface 'GUEST'
        option device 'br-lan.10'
        option proto 'static'
        option defaultroute '0'
        list ipaddr '172.30.10.11/24'
        list ipaddr '172.30.10.1/32'

config interface 'MGMT'
        option device 'br-lan.40'
        option proto 'static'
        option defaultroute '0'
        list ipaddr '172.30.40.11/24'
        list ipaddr '172.30.40.1/32'

config interface 'modem'
        option proto 'static'
        option device '@wan'
        option ipaddr '192.168.100.10'
        option netmask '255.255.255.0'
        option defaultroute '0'
        option delegate '0'

config device
        option name 'eth1'
        option mtu '4000'
        option ipv6 '0'

config bridge-vlan
        option device 'br-lan'
        option vlan '20'
        list ports 'eth1:t*'

config device
        option name 'eth3'
        option mtu '4000'

config device
        option name 'br-lan.20'
        option type '8021q'
        option ifname 'br-lan'
        option vid '20'
        option ipv6 '0'

AP config ( can't easily change )


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config switch
        option name 'switch0'

config globals 'globals'
        option operate_mode 'ap'
        option dns_hijack_enable '0'

config switch 'switch1'
        option name 'switch1'
        option reset '1'
        option enable_vlan '1'

config switch_vlan 'vlan_v1'
        option device 'switch1'
        option vlan '1'
        option vid '1'
        option ports '2 3 6'

config switch_vlan 'vlan_v50'
        option device 'switch1'
        option vlan '2'
        option vid '50'
        option ports '1 2t 3t 6t'

config switch_vlan 'vlan_v10'
        option device 'switch1'
        option vlan '3'
        option vid '10'
        option ports '2t 3t 6t'

config interface 'lan'
        option stp '1'
        option ifname 'eth1 eth0'
        option proto 'dhcp'
        option peerdns '1'
        option macaddr ''
        option priority '32767'
        option type 'bridge'
        option force_link '1'
        option ieee1905managed '1'
        option ageing_time '30'

config interface 'v50'
        option ifname 'eth0-v50 eth1-v50 '
        option priority '32767'
        option proto 'dhcp'
        option peerdns '1'
        option type 'bridge'
        option stp '1'
        option force_link '1'
        option ieee1905managed '0'
        option ageing_time '30'
        option macaddr ''

config interface 'v10'
        option ifname 'eth0-v10 eth1-v10 '
        option priority '32767'
        option proto 'dhcp'
        option peerdns '1'
        option type 'bridge'
        option stp '1'
        option force_link '1'
        option ieee1905managed '0'
        option ageing_time '30'
        option macaddr ''

config device 'eth1'
        option name 'eth1'
        option macaddr ''

config device 'eth0v50'
        option name 'eth0-v50'
        option type '8021q'
        option ifname 'eth0'
        option vid '50'
        option egress_qos '0:0 1:0 2:0 3:0 4:0 5:0 6:0 7:0'

config device 'eth1v50'
        option name 'eth1-v50'
        option type '8021q'
        option ifname 'eth1'
        option vid '50'
        option egress_qos '0:0 1:0 2:0 3:0 4:0 5:0 6:0 7:0'

config device 'eth0v10'
        option name 'eth0-v10'
        option type '8021q'
        option ifname 'eth0'
        option vid '10'
        option egress_qos '0:0 1:0 2:0 3:0 4:0 5:0 6:0 7:0'

config device 'eth1v10'
        option name 'eth1-v10'
        option type '8021q'
        option ifname 'eth1'
        option vid '10'
        option egress_qos '0:0 1:0 2:0 3:0 4:0 5:0 6:0 7:0'

config device 'eth0'
        option name 'eth0'
        option macaddr ''