Is my Linksys EA7500 v2 bricked? Please help!

Hi Everyone,

I'm new to this forum so please feel free to fix me if I post it on wrong place.

I have Linksys Router EA7500 v2. It was working properly, then I saw an update on the Linksys App and I updated it. After a while, I saw my router was off (Its logo was not lighting), I unplugged it from the power source. From that moment, everytime I plugged in my router and it always behaves like this (its logo is blinking endlessly ~ 1sec interval), literally not working (please see the video on Youtube link below). Is it bricked? Is there any way to fix this.

Thank you very much for your support!

https://youtu.be/SQZI_7RsVcI?si=7tF0zZyxx9xAQCL8

I think a good way to fix it is to install openwrt

to boot into the backup firmware

power on the router
wait 15 seconds
power off the router
repeat steps above twice more.
power on the router and you should be in the “other” firmware

https://openwrt.org/toh/linksys/linksys_ea7500_v2

2 Likes

Hi @Lucky1, thanks for your reply. I've tried this method already but it still behaved the same way. My router does not run on OpenWRT. It was running OEM firmware, then it was prompted to install newer version of OEM firmware.

recovery is all the same

next you need to dissemble you router
get a USB to TTL 3.3V to try serial access

so it all depends on how much you want to restore your router

you would want option 2 from the below menu

Please choose the operation:
1: Load system code to SDRAM via TFTP.
2: Load system code then write to Flash via TFTP.
3: Boot system code via Flash (default).
4: Entr boot command line interface.
7: Load Boot Loader code then write to Flash via Serial.
9: Load Boot Loader code then write to Flash via TFTP.

this device is almost the same "EA-8100"
there maybe differing info on it;s page
https://openwrt.org/toh/linksys/ea8100_v1

1 Like

Hi @Lucky1, thanks very much for your suggestion. I have no idea about this, never do it before. I will try to do some research on it. Meanwhile, if you have any related instructions for this router, please give me. Thanks a lot again.

@Lucky1 Hi I just wanna update my situation, after using the USB-TLL, I've got a boot log like this. My router hang at this point (attached image 1). I'm using MacOS 14.4, using a USB-C to RJ45 to connect to the Router Ethernet Port 1. I followed macOS Command-Line Native tftpd to run TFTP Server. I don't know whether my router is really broken or not because its ethernet port does not show any sign of working when I plugged it in (image 2). Please help if you have any idea. Thanks very much.


well you can compare boot log with the one here
https://openwrt.org/toh/linksys/linksys_ea7500_v2

I don't know MacOS at all so i can't help there
but i imagine the leds on the router should tell you something
compare the led between mac and lan & wan looped to lan
do the leds light maybe only when looped ?

1 Like

If you get this far, you should have already passed the menu @Lucky1 posted earlier...

1 Like

I'm stucking here cause the router cannot reach the TFTP server to download file (image 1). I already tested the TFTP Server. It is working and file can be downloadable (image 2). I really doubt my router's LAN may be bricked. Hmmm.


You are testing the TFTP from the host it's running on?

You won't know if there's a fw blocking the access from the LAN.

2 Likes

@nhale
not all TFTP servers work in all cases as well
so do try another if you can
for windows i use "SolarWinds-TFTP-Server"
on openwrt for my voip provisioning i use aftpd

1 Like

@frollic I actually can download the file from TFTP client from another PC over wifi network. So I think firewall does not interrupt it (I also turned it off). I just wonder if the LED light at the router LAN port suppose to light up when I plugged the cable in? Mine is off all the way. :((

No,

it's uboot, it doesn't do fancy stuff like LEDs and ping.

Try a different port on the router.

1 Like

I tried all ports but nothing happened. :(((

the only things I can think of off the top of my head
is to check that you WIFI is not on the same sub net as LAN
maybe disable it while trying
I would have a quick look at the ARP table
unlikely its bad but good to check and maybe flush it

also on pc i would load wire share to see what the network see's

1 Like

Then run (if doable) tcpdump on the TFTP host, check if you can see the requests coming from the router.

1 Like

@Lucky1 @frollic I turned firewall off and run tcpdump but it seems like nothing happened (image 1). I tried with another router and I can see activities logging there but nothing showed up with this bricked one. I tried to load it to this state (image 2), then changed the LAN ports one by one, even the WAN port but see nothing logged out.


Edit: never mind, I already read you have set up everything correctly. Still, please check if you have connected everything correctly. Can you confirm you directly connected the bricked linksys to your TFTP server using an ethernet cable (no router in between) and disabled WiFi to make sure there's no routing issues with a duplicate subnet?

The router saying ETH_STATE_ACTIVE and you saying you can reach the TFTP from a different computer is making me doubt everything is set up correctly.

--

Hi Nha,

The second image, it's a screenshot from your TTY serial console connected to the bricket router right?

A reminder is that the TFTP server is running on your Mac. The router is the client. You should set up TFTP server first. Or use the build-in Mac OS TFTP server daemon. Check https://bacnh.com/howto-start-tftp-server-on-macos for more information. The TFTP server must be able to serve the atlanta.img file (according to your second image).

Second, you must configure the ethernet adapter to use a static IP on your Mac. Directly connect the router with your Mac using an ethernet cable. Disable Wifi on the Mac just to be sure. Check https://support.apple.com/guide/mac-help/use-dhcp-or-a-manual-ip-address-on-mac-mchlp2718/mac how to set a static IP for your ethernet interface. According to your second image, your Mac must be configured as follow:

  • Configure IPv4: Manual
  • IPv4 address: 192.168.1.180
  • Subnetmask: 255.255.255.0
  • Router: leave empty

Good luck. I didn't read this thread carefully, but I hope this helps you.

1 Like

I'm running out of things to add here
the only other thing I have had happen to me
on a different router is the loaded firmware
was loading bad configuration into the switch
and as the boot loaded didn't setup or fix the switch
if didn't let me connect

the result was I have to power off the router for say 10 minutes
let all power drain from everything & hopefully the switch reset
and go strait into uboot "Not let the firmware run at all"
only after I did this a few times I got a connect & fixed it

I don't think this is your problem but who knows

1 Like

Hi @vuhuy and @Lucky1, thanks very much for your suggestion. I will try later whenever I can. Hope everything will work. Thanks a lot.