Is my igmpproxy setup safe?

Setup
I have an Archer C7 V5 router with wan connected to fiber.
I also have a TP link unmanaged switch with IGMP snooping connected to one of the LAN ports of the router.
I have a Set-Top Box iptv device connected to one of the LAN ports of the switch.
After i installed igmpproxy everything worked fine. I can watch tv and everything.

A few questions
But running list altnet 0.0.0.0/0 on igmpproxy upstream is this safe?

Will this allow any IGMP traffic to reach my network, or only the one the set-top-box initiates?

Is there a way to reload config file from /etc/config/igmpproxy without rebooting my device?

What is the best way to tcpdump and limit this a little?

When I have igmp_snooping enabled on lan interface and unmanaged switch supports this, network will not be spammed with IGMP traffic?

Config files
cat /etc/config/igmpproxy

config igmpproxy
option quickleave 1

config phyint
option network wan
option zone wan # the upstream firewall zone for forward rules
option direction upstream
list altnet 0.0.0.0/0 # a description of allowed source addresses for multicast packets

config phyint
option network lan
option zone lan #the downstream firewall zone for forward rules
option direction downstream

cat /etc/config/network


config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option igmp_snooping '1'

config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
option peerdns '0'
option dns '8.8.8.8 8.8.4.4'


It is the default setting to make it work in all cases. If you know the possible source addresses you could add them there.

Since you have enabled igmp_snooping on lan interface it should reach only the device.

service igmpproxy restart ?

I am not sure I understand the question.

I highly doubt that unmanaged switch supports that. Which switch is that, out of curiosity?