Is it possible to limit bandwidth per interface with luci-app-sqm?

My current setup is:

TP-Link Archer C5 v1.2 
LuCI lede-17.01 branch (git-18.180.55366-b78664c)
LEDE Reboot 17.01.5 r3919-38e704be71
DOCSIS 3.0 cable modem with 35Mbps download and 3.5Mbps upload links
luci-app-sqm, sqm-scripts 1.1.3-2

As you can see the bottleneck is the upload speed and my main concern since it turns my rare gaming occasions when I have free time a pita because nobody here cares leaving dozens of torrents uploading data hogging all the upload bandwidth, everyone connected over Wi-Fi, I'm the only one connected in the LAN ports.

I created a second wireless connection in the 2.4GHz radio named wlan1-1 to be shaped so people can give me a relief, under SQM QoS menu I created a single stance to work with 70% of the available download and 1/3 of the available upload bandwidth (24500 kbit/s and 1190 kbit/s respectively), selected wlan1-1 under Interface name, and cake/layer_cake Queuing disciplines and script, but devices connected to this interface always gets full bandwidth no matter what.

I believe I missed something and misunderstood the use o SQM QoS.

Are you confusing upload with download since they are reversed on the LAN side

After a few tests I found that SQM QoS won't work straight after a fresh boot. I have to manually start SQM under "System > Startup" in order to make it work, which is listed in the Initscript with priority 50, and yes, I also tried to wait a few minutes after reboot before checking if it's automatically working. Is this supposed to work this way?

And yes, the first option "Download speed" is upload speed, and the second option "Upload speed" is download speed. I already read somewhere in the forums why that.

Adding /etc/init.d/sqm enable and /etc/init.d/sqm start in /etc/rc.local also won't do anything, it still need to be started manually.

After some investigation and lot of tests I found that SQM QoS fails to works on the wlan interfaces because the wireless radios takes a while to start after booting, about 25s after LuCi is accessible, secondary SSID takes a little more time to show up.

If I select eth0 interface or br-lan (which bridges eth1, wlan0, wlan1 and wlan1-1), SQM QoS starts after those interfaces are ready.

I fixed this by disabling sqm in System > Startup, and adding those lines to /etc/rc.local:

sleep 60
/etc/init.d/sqm start