Is It Possible to Compile miniupnpd v18.06.7 with OpenWrt v19.0.7.1 Firmware?

Hi

There seems to be a bug with the later version of the miniupnpd and LuCI-app-UPnP on OpenWrt 19.07.1.

I've just flashed v18.06.7 and UPnP worked straight away. Knowing that UPnP works on this version, is there a way I can compile version 18.06.7 of the miniupnpd and LuCI-app-upnp into my v19.07.1 router firmware?

Can I just simply take the makefile from the link below and place it into the feeds/packages/net/miniupnpd directory and compile v19.07.1 as normal or is there more to it than that?

Many thanks

Will

Could you provide details of the bug? While what you are suggesting might be a temporary workaround, the more prudent course of action is to fix whatever you're having trouble with at the source (if that is the cause).

1 Like

I originally flashed my own v19.07.1 firmware and noticed UPnP wasn't displaying anything and devices were complaining that UPnP wasn't available. I then downloaded the pre-made official OpenWrt firmware flashed that and UPnP still didn't work. I then tried compiling a bare minimal version with just the basic non-SSL LuCI collection and the LuCI-app-upnp package and that did the same.

To rule out v19.07.1 being the issue I downloaded v18.06.7 and UPnP worked straight away. I then compiled the same bare minimal version as above but on v18.06.7 and it worked.

Over the weekend I cloned both v18.06.7 and v19.07.1 from GitHub into two separate directories. I managed to copy the files for miniupnpd from v18.06.7, replace the ones in v19.07.1 and compile successfully. I now have a OoenWrt v19.07.1 with a working UPnP.

However, even though it works there must be a better way I can apply the v18.06.7 version of miniupnpd to future builds easier rather than replacing files?

Though as you said it'll be good to get to the source of the problem.

Would need someone else using those versions to confirm. I don't use them (i run miniupnpd 2.1. Not even sure what 19.07 runs anymore).

These are the versions between 18.06.7 and 19.07.1

At the moment I am Git cloning two versions of OpenWrt into separate directories, copying the files from 18.06.7 and overwriting the ones in v19.07.1? It works but I was wondering is there an official way I can build OpenWrt v19.07.1 as normal and bake a 18.06.7 package into the final firmware?

I have noticed the same in openwrt 19.07.1. Miniupnpd does not work. On 18.06.7, with the netstat -ant command you can see it listening on port 5000. On 19.07.1 not listening on any port, but if you manually start service (/etc/init.d/miniupnpd start) this appears (although i have not checked if it works).