Is GL.iNet MT3000 a good choice for now?

4 Likes

https://firmware-selector.openwrt.org/?version=23.05.0-rc2&target=mediatek%2Ffilogic&id=glinet_gl-mt3000

2 Likes

Has someone here tried the release candidate for the gl-mt3000?
I'm about to pull the trigger but unsure if I will be happy with it.

Then you flash it back ?

I meant that I am about to buy it but still hesitate.

I have the GL-MT3000 (Beryl AX). I was initially using it with GL-iNet OEM firmware but that contains Mediatek proprietary wifi driver and I experienced some latency (bufferbloat) with it.

I flashed OpenWrt 23.05-SNAPSHOT and it has been wonderful using it with the open-source mt76 wifi driver. Latency wise I feel it is better than the ath11k driver+firmware used in my Dynalink DL-WRX36.

However I feel that GL-MT3000 (Beryl AX) (both GL-iNet OEM firmware and OpenWrt firmware) has a shorter wifi range compared to Dynalink DL-WRX36, which is expected since this is supposed to be a travel router.

I do like the ease of use of GL-iNet OEM firmware interface and the pre-installed packages and preset config. It is a little more work to setup the similar set of features in a vanilla OpenWrt system (packages are there in the repos but the config has to be setup manually).

If you haven't bought the GL-MT3000 (Beryl AX) yet and you need the wifi range of a proper full-sized router, I suggest waiting for the GL-MT6000 (Flint 2) which may launch any day now.

There's already a Pull Request in GitHub for GL-MT6000 https://github.com/openwrt/openwrt/pull/13414

1 Like

I haven't tried the RC, but did run master snapshots in late August for a trip to Iceland. I had power issues specific to my configuration ( GL-MT3000 (MT7981) USB host reliability - #5 by fdm ) but once I solved the power supply issues, it was quite stable.

I saw some evidence of a possible memory leak, I haven't taken the time to track it down, partly because I'm back from my trip.

As others have mentioned, the range is quite poor compared to most other products. Usually wasn't a problem in Iceland, except in one place where I kept the router in the living room of our rental and it had problems reaching phones/tablets in my bedroom.

@ka2107

Have you flashed stock OpenWRT directly from GL.iNet OEM firmware or from UBoot?

From Luci Sysupgrade page under Advanced Settings of GL.iNet OEM Firmware.

1 Like

I bought GL-MT3000 (Beryl AX) to be used as simple Access Point and it works really well and very fast.

I am waiting for my friend to come next week and bring me a MT3000 from China (it's 1/3 cheaper), from what I know the u-boot is different that using GL's firmware you'll have no VPN features, but not applicable to official OpenWrt.

And I think the speed isn't super fast (given the small antenna size) but also not slow, right?

@fakemanhk : I run official OpenWrt and with access point nearby over 5G WiFi frequency I get WAN speed 900 Mbps (download) / 450 Mbps (upload) on my phone, that's my actual Internet speed. I should test LAN speed but my ethernet switched LAN is 1Gbps so I cannot reach above that speed. I tested iperf3 to the MT300 from my (only) WiFi Linux machine but I guess that (old) laptop has slow WiFi (I reach 350 Mbps).

900Mbps on WiFi is actually better than I think! Thanks!

I have > 1G internet at home so I can test it later, looking forward to the new arrival.

Hi everyone, I do have an issue upgrading the MT3000 to the standard OpenWrt firmware. I was trying to upgrade it with the standard OpenWrt 23.05.2 image (openwrt-23.05.2-mediatek-filogic-glinet_gl-mt3000-squashfs-sysupgrade.bin) via the Luci interface included with the OEM firmware. While from the web ui it looks as if the update is successful, it seems that the router does not reboot successfully - I am connected via ethernet and unable to obtain an IP address from the device. I am able to revert to the OEM firmware via uboot failsafe mode, but upgrading to the OpenWrt firmware via the method described above fails reproducibly. Does anyone have success upgrading to OpenWrt 23.05.2, and if so, which method did you use? Thanks in advance!

When you upgrade, did you wipe the settings?

I was pretty sure I did. Just to be sure I tried it another time with the “keep settings” box unchecked, and this time it rebooted successfully. Thanks for the hint!

The other way to do is, boot into the recovery mode and flash from the web recovery, I used this when I flash the MT1300 (Beryl) before.

1 Like

@ulibecker So did you y/n get openwrt-23.05.2 installed and running on your GL-MT3000?

Yes, I installed the sys upgrade image successfully via LuCI

1 Like