Is Asus DSL-AC68U same as RT-AC68U?

There is something confusing about these routers. On the wiki RT-AC68U is this device: https://openwrt.org/toh/asus/rt-ac68u
But when I google the device, Asus says this RT-AC68U, it has a 1.8GHz CPU, much much faster CPU actually, not 800Mhz like in the wiki.
I assume this is some fault? I think it is actually DSL-AC68U in the wiki? Some kind of country-dependant model naming? But I need to know for sure, because I am gonna try flashing that tomorrow.

No, even without knowing the internal components, they are indeed different devices:

The DSL-AC68U has:

  • a DSL modem for the internet connection
  • 4 ethernet ports
  • 1 USB 3.0 port

While the RT-AC68U has:

  • an ethernet port for the internet connection
  • 4 ethernet ports
  • 1 USB 3.0 port and 1 USB 2.0 port

They are clearly different devices, even though they appear closely related. I don't know if they share key components, but sometimes 2 very similar devices visually appear to be the same but are drastically different in terms of the internal chipsets and designs. Even if they are using the same chips, the firmware images for basically all integrated router devices is bespoke -- every model has specific details that must be known to the firmware (down to the way that the CPU and ethernet ports are connected, among other things). The DSL modem absolutely would not work, that much can be guaranteed.

I strongly advise against flashing the firmware for the RT-AC68U onto your DSL-AC68U. If you do decide to flash it anyway, do so at your own risk and understand that you may end up with a completely unrecoverable brick. But for the benefit of the community, please report back what happens if you do it.

I think I am gonna try flashing, I have the luxury to do that. I bought it very cheap. I think I could debrick with atftp if something goes wrong, right? Asus routers have that thing. But, I assume wrong flashing won't damage the device, so atftp would work right?
Btw I enabled the SSH, and went inside. cat /proc/cpuinfo is this:
Processor : ARMv7 Processor rev 0 (v7l)
processor : 0
BogoMIPS : 1599.07

processor : 1
BogoMIPS : 1595.80

Features : swp half thumb fastmult edsp
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x3
CPU part : 0xc09
CPU revision : 0

Hardware : Northstar Prototype
Revision : 0000
Serial : 0000000000000000

Actually flashing worked. I flashed RT-AC68U firmware onto DSL-AC68U and it worked. But CPU is instead stuck on 800MHz. They are indeed different. I think this DSL-AC68U is much newer than that. But on original asus software it was 1500Mhz. Can I somehow overclock it back? I've seen it on the wiki somewhere..
One more question. Since this doesn't have WAN port, can I just change LAN4 for example, to WAN instead? Like lan4.35 sets VLAN ID 35 am I right?