iQrouter 6rd satisfy_dependencies_for

Tried contacting Evenroute, the folks who make the firmware for the iQrouter. The response was basically, "yup it don't work".

So, when I try to install 6rd (Centurylink only delivers IPv6 over 6rd) I'm met with this

Installing 6rd (9-4) to root...

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for 6rd:
 * 	kernel (= 4.9.120-1-adfb989aae12e239d65a2c73ca35b8a3) * 	kernel (= 4.9.120-1-adfb989aae12e239d65a2c73ca35b8a3) * 	kernel (= 4.9.120-1-adfb989aae12e239d65a2c73ca35b8a3) * 
 * opkg_install_cmd: Cannot install package 6rd.

The kernel version is

root@IQrouter:~# opkg list | grep "kernel -" kernel - 4.9.120-1-bb05a367d4346b8dd17d46fa2e9a1bdc

Now I know that the mismatch on the hashes has something to do with the problem, but this is a pre-built firmware, and on top of that my knowledge of code, compiling, etc is very very limited.

My question(s) is this. If I force the install, how likely is it to break my router. Barring the forced install, what other options do I have?

Rather small, this time, as the 6rd package is basically just one shell script (plus one user-space program for ip6 address calculation). If you have the basic architecture (mips_24kc) right, the risk is rather small.

See the source code:;a=tree;f=package/network/ipv6/6rd;h=93fce344a7906994233f0cbd4a3f0e3f621cdf9e;hb=refs/heads/openwrt-18.06

( that naturally assumes that the IQrouter is really based on rather "normal" 18.06.1, and not some exotic modifications)

Well one hard reset later and we're back to square one. Router started bootlooping as soon as I sent the command. The architecture is right (the router itself is a TPlink Archer C7). I guess they've modified 18.06.1 enough that forcing the install breaks things.

This was EvenRoute's response

Sorry, but if that package is not built with compatible dependencies, it will not work with that OS build.

The underlying OS is OpenWRT 18.06.1, so I guess this problem would happen with a vanilla 18.06.1 build as well.
Other packages like nano and others install fine on the IQrouter.

Do NOT force install any package, as it could brick the router. I've tried and it's not pretty :wink: