IPV6 with ISP's bridged router

Hi,
I am trying to replace router functionality of ISP issued box with non-trivial configuration, and can't get IPV6 to work.

  1. When I use ISP router in router mode, everything works
  2. I have separate DNS/DHCP server (pihole), so OpenWRT is just a gateway
  3. I have following interfaces configured: lan (with static IPV4, wan (dhcp client, gets IP4 from modem), wan6 (dhcpv6 client, gets IPv6: /128 and IPv6-PD ::/56 from modem).
  4. I tried to set DHCP settings of WAN6 interface as follows:
    IPV6 Settings/Designated Master and rest of services are in relay mode (dhcp page is "ignore this interface"
    WAN interface is set to "disabled" for all services
    LAN interface is set to relay but no "designated master" and "ignore this interface" for dhcp.

No IPv6 connectivity.
All this try and error with relay and designated master were my attempts to troubleshoot it, if I restore everything to "default" it doesn't work as well.

Hardware: PI4 with USB card. Embedded ethernet is eth0 and is used to connect to the modem, USB dongle (eth1) is used to connect to the unmanaged bridge, where all LAN devices are connected.

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdce:48bb:851c::/48'

config interface 'wlan'
        option proto 'dhcp'
        option device 'wlan0'

config device
        option name 'eth1'

config device
        option name 'wlan0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'

config interface 'wan'
        option device 'eth0'
        option proto 'dhcp'
        option ip6ifaceid '::1'

config interface 'lan'
        option proto 'static'
        option device 'eth1'
        option ipaddr '192.168.10.250'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option type 'bridge'
        option name 'br-wan'
        list ports 'eth0'
        option bridge_empty '1'

config interface 'wan6'
        option proto 'dhcpv6'
        option device '@wan'
        option reqaddress 'try'
        option reqprefix 'auto'


Any help will be appreciated,
Alex

If you get a /56 via pd you do not want to use relay. Look at the option ip6hint. Assign a /64 to each Vlan.

https://openwrt.org/docs/guide-user/network/ipv6/configuration#downstream_configuration_for_lan_interfaces

https://openwrt.org/docs/guide-user/network/ipv6/configuration#slaac_and_dhcpv6

1 Like

Remove this from wan interface.
Your setup is pretty basic so the default configuration will work fine with a few adjustments as soon as you add the usb dongle as wan network.

1 Like