[IPv6] wireguard on desktop vs router

Hello,

I'am trying to read up on this issue, but as a novice user the skills for understanding the problem and implementing a solution are not there.

Problem: IPv6 connectivity versus no IPv6 connectivity on different client
Same wireguard config is being used

  1. Windows11 machine, wireguard client has connectivity to IPv6
  2. Router, wireguard client does not provide IPv6 to connected devices

Details:
ISP -> (wan)NanoPi_R4S(lan) -> switch(lan) - computer and access point
Fiber, speed 700mb/s both directions
NO IPv6 supplied, only IPv4
Using cloudflare warp teams for wireguard config

Before using wireguard I don't have IPv6 connectivity, after using wireguard, I get IPv6, is this worth chasing and implementing?


desktop wireguard client


router wireguard client

Most endpoints (desktops etc) require a GUA IPv6 address before they will try to originate a connection to the v6 Internet. You will need to put an address on the router's lan interface which the DHCP/RA system will then distribute to endpoints.
In the lan section of /etc/config/network:
option ip6addr '2001:db8:abcd::1/64'
Or, in LuCI, edit the lan interface and add this as an IPv6 Address.

Also the same as v4, the VPN service does not know about your local addresses, so you will need to masquerade (NAT) them. In the firewall, in the zone that the VPN tunnel is in, add option masq6 '1'. This can also be done in LuCI by checking the "Masquerade IPv6" box on the Advanced tab of the zone editor.

1 Like

Thank you, I will test your suggestion and reply how it goes

Implemented these fixes and now I'am getting IPv6 connectivity, cheers :wink:

Sorry for incuiring about different topic, I'am further reading information about wireguard and found some conflicting information during wireguard interface setup.

For reference, I followed this video when creating wireguard interface: (Outdated) OpenWRT - Setup Cloudflare WARP+ VPN on OpenWRT (Wireguard) (youtube.com)

As can be seen, wireguard interface firewall zone is being assigned to wan, wan6, but now I found this information

And this is how I currently have it set up

How should I adjust the firewall zone for wireguard interface?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.