IPv6 upstream not connecting on WRT1900AC

Hi everyone! I'm having issues connecting my router to the upstream Comcast ipv6 network. IPv4 upstream works just fine.

Here is my overview page:

due to some issues with windows internet connectivity detection, I had to disable ipv6 downstream support on my router (my WAN6 interface is still there). any suggestions on how I can get my router to connect properly to the upstream IPv6 network would be greatly appreciated.

Thank you!

What is the output of the following command?
uci export network

Use the Preformatted text button </> when you paste console output.


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option dns '8.8.8.8'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'
        option hostname 'dlinkrouter'
        option type 'bridge'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface 'WAN6'
        option proto 'dhcpv6'
        option ifname 'eth1.2'
        option force_link '1'
        option reqprefix '64'
        option reqaddress 'try'

Is your provider indeed using dhcpv6 or something else?

If DHCPv6 indeed, better delete the interface and start from scratch using lowercase letters and leave the required prefix to auto. Disable the force link.

Thank you trendy. Unfortunately that didn't seem to fix it.
Here is the uci export network again:

package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option dns '8.8.8.8'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'
        option hostname 'dlinkrouter'
        option type 'bridge'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth1.2'
        option reqaddress 'try'
        option reqprefix 'auto'

Additionally, I've been researching this issue and have seen people say that Comcast (Xfinity specifically) is using DHCP-PD. im not sure if that is the same thing, but I thought I might mention it.

Additionally, I keep getting this error in the system log that might be relative:

Thu Jan  9 23:55:17 2020 daemon.err odhcp6c[3712]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)

Prefix Delegation is a prefix (usually a /60, /56, or /48) delegated to you by your ISP to use it inside your lan. This is sent as an option in the DHCPv6 packets. So it seems that you should be using DHCPv6 protocol for wan6.

Regarding the permission error, have you incuded the wan6 interface in wan firewall zone?

yes, wan6 is in the wan firewall zone. That might be causing that error? I checked the DHCP and DNS page, and no devices listed there correspond to that ipv6 address.

trendy, thank you for your help, it turns out I was a couple subversions behind (18.02 vs 18.05), I updated and the default setup autoconnected IPv6 upstream, all is well! I am now manually re entering settings to avoid breaking it again!

1 Like

I am glad it worked out eventually! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.