IPv6 upstream doesn't come up

Hi, firstly sorry for my bad english...
I have a TP-Link Archer C60 V2.0, Running latest 18.06.4, connected via bridge to a Fiberhome AN-5506-04 as below:
Fiber from outside the house >>> Fiberhome >>> TP-Link
i was having some memory issues, but separating SSID's from 2.4g and 5ghz solves. But the problem is that i don't have IPv6. Soon after the ISP install the Fiberhome was working normally, i can get IPv6-PD using DHCPv6. But, some time (1 day or less) after it's stopping working and now the router doesn't get tem IPv6-PD anymore. The fiberhome is working normally, for now i dont have other router to test, but doesn't seem a hardware issue. I reseted and updated the OpenWRT, so the OpenWRT install is fresh new, i just flashed and change the WAN to PPPoE. Below is the /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf6:95d5:4deb::/48'

config interface 'lan'
        option type 'bridge' 
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'pppoe'
        option username '*****'
        option password '*****'
        option ipv6 'auto'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

Anyone have any clue what's happening? I already tried everything i know, and nothing helps, i think only thing left is try with another router, to see if its hardware issue...

I reset and tried to work with all default settings, it just doesn't connect, and doesn't acquire the IPv6-PD. The ONU in bridge it's working fine, I'm using only on ipv4 for now...

Try this way:

uci set network.wan6.ifname="@wan"
uci commit network
service network restart

And/or enable IPv6 explicitly:

uci set network.wan.ipv6="1"
uci commit network
service network restart

Then check:

sleep 10; ifstatus wan6

See also:
https://openwrt.org/docs/guide-user/network/wan/isp-configurations

I tried that, doens't get succes. wan6 status:

{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcpv6",
        "device": "pppoe-wan",
        "data": {

        }
}

Wan6 interface is now in LuCI as "alias interface"...
I'm new on openwrt and im a little lost, i will read the ISP config. But my ISP is a local one, i will contact then one more time (they tested and everything is fine on their ONU (i tested too, and the router is the issue...) to ask if they use VLAN, but i don't think so, because the IPv4 works. And it's PPPoE...

If i set the "network.wan.ipv6="auto", once the wan interface is up, a "Virtual dynamic interface (DHCPv6 client)" shows up under "interfaces" in LuCI, if "network.wan.ipv6="1", this dynamic interface doesn't shows. Before when the IPv6 was working, this dynamic interface was the interface who shows the IPv6-PD...

Thank you vgaetera. The solution was in the ISP side, actually the Fiberhome ONU must have some problem, they change the ONU to a Multilaser (local Brand) that Just works on bridge. Now it's working, with all configs out-of-the-box, just reset the openwrt and config PPPoE and wifi. So the ONU was the problem, even that was in bridge mode...

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.