IPV6 topology - OpenWrt in GNS

I have recreated the topology given on https://openwrt.org/docs/guide-user/network/ipv6/routing_with_ipv6, to try out things.
MY setup is OpenWRT (lede-17.01.6-x86-64-combined-ext4.img) in GNS3. From R1, in LuCI, I can ping all endpoints. From the R1 CLI, I can't ping both PC1 to PC2 and vice versa. Firewall is disabled. What am I doing wrong?

@future.now, welcome to the community!

  • I'm confused, why didn't you just make a route on each device for their ULA prefix? (that seems easiest)
  • Do you think you could provide us the configs? (please use the </> button to place the data in codeboxes)
  • Is there a reason you're using an old version of OpenWrt...from when IPv6 was just being implemented well in OpenWrt?
1 Like

Thank you indeed for responding.

  1. I was using latest versions then i faced errors and read on forums that there are some issues so decided to use older. Will use the latest.
  2. Certainly can, nothing pvt, i'd just want to give the ULA prefixes first. Guide me how to do that.
    Here're configs though

R1

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0'
	option proto 'static'
	option ip6addr '2008:a:a:b::1/64'
	option ip6assign '60'

config interface 'lan2'
	option ifname 'eth1'
	option proto 'static'
	option ip6addr '2008:a:a:a::1/64'
	option ip6assign '60'

#config interface 'wan'
#	option ifname 'eth1'
#	option proto 'dhcp'
#config interface 'wan6'
#	option ifname 'eth1'
#	option proto 'dhcpv6'

config globals 'globals'
	option ula_prefix 'fd58:c7b9:863f::/48'

config route6 'default'
	option interface 'lan2'
	option target '2008:a:a:c::/64'
	option target '2008:a:a:d::/64'
	option gateway '2008:a:a:b::2'

WAN

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan2'
	option ifname 'eth1'
	option proto 'static'
	option ip6addr '2008:a:a:c::1/64'
	option ip6assign '60'

config interface 'lan'
	option ifname 'eth0'
	option proto 'static'
	option ip6addr '2008:a:a:b::2/64'
	option ip6assign '60'

#config interface 'wan'
#	option ifname 'eth1'
#	option proto 'dhcp'
#config interface 'wan6'
#	option ifname 'eth1'
#	option proto 'dhcpv6'

config globals 'globals'
	option ula_prefix 'fd58:c7b9:863f::/48'

config route6 'default'
	option interface 'lan'
	option target '2008:a:a:a::1/64'
	option gateway '2008:a:a:b::1'

config route6 'router_outside'
	option interface 'lan2'
	option target '2008:a:a:d::3/64'
	option gateway '2008:a:a:c::2'

R2

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0'
	option proto 'static'
	option ip6addr '2008:a:a:d::1/64'
	option ip6assign '60'

config interface 'lan2'
	option ifname 'eth1'
	option proto 'static'
	option ip6addr '2008:a:a:c::2/64'
	option ip6assign '60'

#config interface 'wan'
#	option ifname 'eth1'
#	option proto 'dhcp'
#config interface 'wan6'
#	option ifname 'eth1'
#	option proto 'dhcpv6'

config globals 'globals'
	option ula_prefix 'fd58:c7b9:863f::/48'

config route6 'default'
	option interface 'lan'
	option gateway '2008:a:a:c::1'

I disabled firewall suspecting it might be hindering.
I appreciate the help

Multiple target entries are not supported.
You should use a separate route6 section per target.

1 Like

Thank you V. Much appreciated. I'll do that.

What If the routing scope is large, can I run some Routing protocols to learn on the routes like RIP OSPF? How do I go about doing that, if possible.

1 Like

study them ( quagga ) and try it... there is nothing very openwrt specific about implementing these...

1 Like