IPv6-test | OpenWrt filtering ICMPv6 messages to computer

Hello everyone,

I'm looking to see what is required of me to receive a 20/20 score using OpenWrt with my IPv6 ISP (Charter Spectrum).

There are many IPv6 tests online, and the majority of them come back green/working. I am experiencing some issues with Microsoft Teams disconnects when IPv6 is enabled, and was looking to do some testing and once site in particular gave me some feedback that I am curious to understand how I would resolve, which is what I would like to focus on with your assistance.

Website: https://ipv6-test.com/

Error Message:

Your router or firewall is filtering ICMPv6 messages sent to your computer. An IPv6 host that cannot receive ICMP messages may encounter problems like some web pages loading partially or not at all.

Screenshot:
https://i.imgur.com/Dbq57BF.png

Traffic Rules:
https://i.imgur.com/TlmzE4W.png

I tried a slightly more permissive version of all of the ICMP rules to no avail, toggling off their current equivalents - which is why you see three rules in a disabled state.

If anyone is able to achieve a 20/20 score, or has any insight on this test and what new rule or rule adjustment I could make to allow this it would be greatly appreciated - thank you very much!

Hi

I'm guessing that you are using Windows

The Windows firewall blocks ICMP, by default

To allow ICMP, open an adminstrator cmd window and run the following:

netsh advfirewall firewall add rule name="ICMPv4 Allow incoming" protocol=icmpv4:any,any dir=in action=allow

netsh advfirewall firewall add rule name="ICMPv6 Allow incoming" protocol=icmpv6:any,any dir=in action=allow

Your score should improve

1 Like

Wouldn’t it be easier to change the network from public to private?

Awesome! This did the trick for me here, I'm now getting a 19/20 in Firefox and a 20/20 in Chrome - it seems the hang up with Firefox is more of a browser setting at this point.

I didn't realize that it was going to be a Windows setting but sure enough that did the trick. Here's how I'm looking now

Firefox: https://i.imgur.com/xcS4yqy.png
Chrome: https://i.imgur.com/H3rT05l.png

I also came across this site which seemed like a good resource as a second test/opinion: https://ip6.biz/

It reported similarly as the original site with ICMP and both show green now.

Now I need to check to see if this has any sort of impact at all on the true issue that I was being plagued with - Microsoft Teams disconnects. But that seems like possibly a non-OpenWRT issue, although for me this issue does coincide with me installing my new OpenWRT router (and also IPv6 being enabled at the same time) - so I have lots of variables changing at once trying to narrow things down. For those curious, I also did find some settings to turn off IPv6 in Firefox at a browser level (just for testing as I investigate): https://hpc.mil/solution-areas/networking/ipv6-knowledge-base/ipv6-knowledge-base-applications/ipv6-and-mozilla-firefox

Appreciate the assistance!

Edit for those looking for some more resources, the answers provided inspired me to do a bit more digging and I found these that I thought were good shares.

Alternative Firewall Rule/Solution

Good Reads

https://www.elevenforum.com/t/ipv6-icmp-the-solution-but-do-we-really-need-it.1269/

I understand that I may be taking the wrong approach here or barking up the wrong tree, but I'm a little surprised that even a fresh Windows 11 install out of the box needs these firewall rules applied.

Is there a more elegant, network wide approach to solve this instead of on a per device basis?

I know @flygarn12 mentioned Wouldn’t it be easier to change the network from public to private?

Is there any way to implement this across an entire home network (non-domain joined) or any other solutions?

Like I said, I've received a resolution but I'm just trying to better understand why it's configured in this manner by default.

Also it may be too early to confirm, but today I've been on multiple Teams meetings without issue connected through IPv6. Call it a coincidence, but after the ICMPv6 fix and full green marks on both sites things have been good.

I guess part of me is just realizing that any time I format or setup a new device in my home network, this is an additional step that I'm going to have to take for Windows devices to get them to a full level of compatibility so to speak, which is why I'm racking my head over a more elegant solution :slight_smile:

It is a Windows network setting, Windows always assumes you sit on a public network and have a completely closed firewall as default setting.
If you change it to private network the windows computer firewall ports work as expected from the point of view for a non normal user likes geeks.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.