IPv6 stops after certain time [LEDE 17.01.04, Netgear R7800]

Hello,

I recently switched from a TP-Link WDR4300 to a Netgear R7800. I had a stable (almost default) network configuration running on the WDR4300 (with lede) and almost copied it to my new router. Unfortunaly ipv6 stops working after half an hour of working - it starts again when I do a "service network restart" or similiar restarts.

Log output when ipv6 stops working:

Thu May 17 20:35:32 2018 daemon.notice netifd: wan (565): udhcpc: sending renew
Thu May 17 20:35:32 2018 daemon.notice netifd: wan (565): udhcpc: lease of 192.168.1.30 obtained, lease time 3600
Thu May 17 20:35:34 2018 daemon.info odhcpd[421]: Raising SIGUSR1 due to default route change
Thu May 17 20:35:34 2018 daemon.info odhcpd[421]: Raising SIGUSR1 due to default route change
Thu May 17 20:35:34 2018 daemon.info odhcpd[421]: Raising SIGUSR1 due to default route change
Thu May 17 20:35:35 2018 daemon.info odhcpd[421]: Using a RA lifetime of 1800 seconds on br-lan
Thu May 17 20:35:35 2018 daemon.info odhcpd[421]: Using a RA lifetime of 1800 seconds on br-lan
Thu May 17 20:40:36 2018 daemon.info odhcpd[421]: Using a RA lifetime of 1800 seconds on br-lan

It feels like it stops working when the router advertisement lifetime ends - but I dont know how to debug it further.

I'm testing with https://test-ipv6.com

My network setup contains a isp (unitymedia) cable modem (connect box) which cant be configured as a bridge. I deactivated wifi and firewall and connected it to the WAN port of my R7800. I only got an ipv4-address via ds-lite.

ISP router configuration:
connect-box-2

ISP WAN settings:
connect-box-1

LEDE interfaces overview:
lede-interfaces

/etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
 
config globals 'globals'
        option ula_prefix 'fd9c:a7a2:5cc8::/48'
 
config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'
 
config interface 'wan'
        option ifname 'eth0'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto 'dhcp'
 
config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
 
config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
 
config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6'
 
config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0'

/etc/config/dhcp:

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'
        option nonwildcard '0'
 
config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra_management '1'
        option ra 'server'
        option ra_default '1'
 
config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
 
config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

I tried different settings in the last days:

  • RA/DHCPv6 relay mode
  • only stateless / stateful (in router and model)
  • different ipv6 prefix configuration and assignment lengths
  • added verbose mode and -m 10 to dhcpv6.script in /lib/netifd/proto/dhcpv6.sh
  • added udb port 547 to zone-rule for ra-advertisements in relay mode

.. but nothing helps.

I start thinking it's a problem with the R7800, because everything worked fine on my old WDR4300 with the identical LEDE version.

Does anyone have an idea of solving or hints on (further) debugging the problem?

Thanks in advance for any help,
topy

EDIT: made use of lifted user permissions (multiple links and images in post)