IPv6 Stopped Working Overnight

My IPv6 was working, but today it is not. It said "network device not present" and it seems that a bridged interface can't contain another bridge? But that's how it was setup before... anyway, have tried the various "normal" setups I find on wiki and in forums, but no joy. I tried switching back to just the modem from my ISP in router mode, and that gets IPv6 fine so not an ISP issue.

current wan6 config:

config interface 'wan6'
        option proto 'dhcpv6'
        option reqprefix 'auto'
        option reqaddress 'try'
        option peerdns '0'
        option ifname 'br-wan'

I have also tried ifname of @wan and when it was working it looked like this but also with option type 'bridge'

# ifstatus wan6
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcpv6",
        "device": "br-wan",
        "data": {


ip a shows no global v6 addresses.

If I remove the wan6 interface and run odhcp6c -P0 -e -v br-wan manually it makes the request and then hangs. If I run `odhcp6c -P0 -e -v eth0.2' manually it gives me "permission denied" errors

So, it turned out the firewall somehow got set from allow to deny on WAN input, which was blocking the DHCPv6 replies facepalm

1 Like

Remember to edit the subject to add "[solved]", thank you.

Been there. When you're used to DHCPv4 'just working' in comparison DHCPv6 needing ICMPv6 is rather tricky.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.