Ipv6 public IP

I am using OpenWrt SNAPSHOT r19123-2de86691b6 / LuCI Master git-22.058.70382-d29400e
on tplink archer c6

my isp gives a pppoe connection. with and without dhcpv6 I am only getting a link local address and not
a public address. what to do?

Please, post your network config file.

1 Like

Kind of cleaned it out.. what do I need to add or change?
and do i get my ipv6 public ip through link-local?(noob here)
config interface 'loopback'

option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ip6table 'default'

config interface 'wan'
	option proto 'pppoe'
	option username 'FMRS249'
	option password '249249'
	option device 'wan'
	option peerdns '0'
	list dns '8.8.8.8'
	list dns '1.1.1.1'
	option ipv6 'auto'

Does your ISP support IPv6?

1 Like

It's on their website that they do..
It's bangladesh so maximum they can 'support' is to tell me to restart my router😒
(I did contact them they say its 'auto'
But I am getting an ipv6 link local address so in some form they do have ipv6 right?)

You can see if there is something: ifstatus wan_6

1 Like

This is the reply- any ideas how do i set up?
TIA

{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": true,
        "proto": "dhcpv6",
        "device": "pppoe-wan",
        "data": {

        }
}

You can try to restart it with ifup wan_6 , however I have seen in the past cases where misconfiguration from the ISP side was blocking the IPv6.

The link local address means that your device has IPv6 running
You can also try to capture some packets, but I am not sure we'll see much there.
opkg update; opkg install tcpdump; tcpdump -i pppoe-wan -evn ip6

Restart the WAN interface, then post the logs here.

Wed Mar 23 13:35:26 2022 daemon.notice netifd: Interface 'wan' is now down
Wed Mar 23 13:35:26 2022 daemon.notice netifd: Interface 'wan' is disabled
Wed Mar 23 13:35:26 2022 kern.info kernel: [ 1685.258580] mt7530 mdio-bus:1f wan: Link is Down
Wed Mar 23 13:35:26 2022 kern.info kernel: [ 1685.269420] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Wed Mar 23 13:35:26 2022 kern.info kernel: [ 1685.276446] 8021q: adding VLAN 0 to HW filter on device wan
Wed Mar 23 13:35:26 2022 daemon.notice netifd: Interface 'wan' is enabled
Wed Mar 23 13:35:26 2022 daemon.notice netifd: Interface 'wan' is setting up now
Wed Mar 23 13:35:26 2022 daemon.notice netifd: Network device 'wan' link is down
Wed Mar 23 13:35:26 2022 daemon.notice netifd: Interface 'wan' has link connectivity loss
Wed Mar 23 13:35:27 2022 daemon.notice netifd: Interface 'wan' is now down
Wed Mar 23 13:35:27 2022 daemon.notice netifd: Interface 'wan' is disabled
Wed Mar 23 13:35:27 2022 kern.info kernel: [ 1685.397532] mt7530 mdio-bus:1f wan: configuring for phy/gmii link mode
Wed Mar 23 13:35:27 2022 kern.info kernel: [ 1685.404546] 8021q: adding VLAN 0 to HW filter on device wan
Wed Mar 23 13:35:27 2022 daemon.notice netifd: Interface 'wan' is enabled
Wed Mar 23 13:35:29 2022 kern.info kernel: [ 1688.312702] mt7530 mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control off
Wed Mar 23 13:35:29 2022 kern.info kernel: [ 1688.320186] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
Wed Mar 23 13:35:29 2022 daemon.notice netifd: Network device 'wan' link is up
Wed Mar 23 13:35:29 2022 daemon.notice netifd: Interface 'wan' has link connectivity
Wed Mar 23 13:35:29 2022 daemon.notice netifd: Interface 'wan' is setting up now
Wed Mar 23 13:35:30 2022 daemon.err insmod: module is already loaded - slhc
Wed Mar 23 13:35:30 2022 daemon.err insmod: module is already loaded - ppp_generic
Wed Mar 23 13:35:30 2022 daemon.err insmod: module is already loaded - pppox
Wed Mar 23 13:35:30 2022 daemon.err insmod: module is already loaded - pppoe
Wed Mar 23 13:35:30 2022 daemon.info pppd[3762]: Plugin pppoe.so loaded.
Wed Mar 23 13:35:30 2022 daemon.info pppd[3762]: PPPoE plugin from pppd 2.4.9
Wed Mar 23 13:35:30 2022 daemon.notice pppd[3762]: pppd 2.4.9 started by root, uid 0
Wed Mar 23 13:35:30 2022 daemon.info pppd[3762]: PPP session is 39314
Wed Mar 23 13:35:30 2022 daemon.warn pppd[3762]: Connected to 0c:c4:7a:1e:3d:cc via interface wan
Wed Mar 23 13:35:30 2022 kern.info kernel: [ 1688.702125] pppoe-wan: renamed from ppp0
Wed Mar 23 13:35:30 2022 daemon.info pppd[3762]: Renamed interface ppp0 to pppoe-wan
Wed Mar 23 13:35:30 2022 daemon.info pppd[3762]: Using interface pppoe-wan
Wed Mar 23 13:35:30 2022 daemon.notice pppd[3762]: Connect: pppoe-wan <--> wan
Wed Mar 23 13:35:30 2022 daemon.notice pppd[3762]: CHAP authentication succeeded
Wed Mar 23 13:35:30 2022 daemon.notice pppd[3762]: peer from calling number 0C:C4:7A:1E:3D:CC authorized
Wed Mar 23 13:35:30 2022 daemon.notice pppd[3762]: local  LL address fe80::fcc0:d594:c557:614a
Wed Mar 23 13:35:30 2022 daemon.notice pppd[3762]: remote LL address fe80::0000:0000:00f0:b7a8
Wed Mar 23 13:35:30 2022 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::f0:b7a8%pppoe-wan: Address not available
Wed Mar 23 13:35:30 2022 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::f0:b7a8%pppoe-wan: Address not available
Wed Mar 23 13:35:30 2022 daemon.notice pppd[3762]: local  IP address 10.106.18.180
Wed Mar 23 13:35:30 2022 daemon.notice pppd[3762]: remote IP address 10.106.0.1
Wed Mar 23 13:35:30 2022 daemon.notice pppd[3762]: primary   DNS address 103.179.128.250
Wed Mar 23 13:35:30 2022 daemon.notice pppd[3762]: secondary DNS address 103.179.128.251
Wed Mar 23 13:35:30 2022 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::f0:b7a8%pppoe-wan: Address not available
Wed Mar 23 13:35:30 2022 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::f0:b7a8%pppoe-wan: Address not available
Wed Mar 23 13:35:30 2022 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::f0:b7a8%pppoe-wan: Address not available
Wed Mar 23 13:35:30 2022 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::f0:b7a8%pppoe-wan: Address not available
Wed Mar 23 13:35:30 2022 daemon.notice netifd: Network device 'pppoe-wan' link is up
Wed Mar 23 13:35:30 2022 daemon.notice netifd: Network alias 'pppoe-wan' link is up
Wed Mar 23 13:35:30 2022 daemon.notice netifd: Interface 'wan' is now up
Wed Mar 23 13:35:30 2022 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Wed Mar 23 13:35:30 2022 daemon.info dnsmasq[1]: using nameserver 8.8.8.8#53
Wed Mar 23 13:35:30 2022 daemon.info dnsmasq[1]: using nameserver 1.1.1.1#53
Wed Mar 23 13:35:30 2022 daemon.info dnsmasq[1]: using only locally-known addresses for test
Wed Mar 23 13:35:30 2022 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Wed Mar 23 13:35:30 2022 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Wed Mar 23 13:35:30 2022 daemon.info dnsmasq[1]: using only locally-known addresses for local
Wed Mar 23 13:35:30 2022 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Wed Mar 23 13:35:30 2022 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Wed Mar 23 13:35:30 2022 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Wed Mar 23 13:35:30 2022 daemon.notice netifd: Interface 'wan_6' is enabled
Wed Mar 23 13:35:30 2022 daemon.notice netifd: Interface 'wan_6' has link connectivity
Wed Mar 23 13:35:30 2022 daemon.notice netifd: Interface 'wan_6' is setting up now
Wed Mar 23 13:35:31 2022 user.notice firewall: Reloading firewall due to ifup of wan (pppoe-wan)
Wed Mar 23 13:35:31 2022 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::f0:b7a8%pppoe-wan: Address not available
Wed Mar 23 13:35:31 2022 daemon.warn dnsmasq[1]: failed to create listening socket for fe80::f0:b7a8%pppoe-wan: Address not available
Wed Mar 23 13:35:32 2022 user.notice firewall: Reloading firewall due to ifupdate of wan (pppoe-wan)

tcpdump didn't catch anything?

I'm starting to think its my isp acting up

tcpdump: listening on pppoe-wan, link-type LINUX_SLL (Linux cooked v1), capture size 262144 bytes
14:26:20.383782  In ethertype IPv6 (0x86dd), length 172: (hlim 1, next-header UDP (17) payload length: 116) fe80::f0:b7a8.5678 > ff02::1.5678: [udp sum ok] UDP, length 108
14:26:51.387869 Out ethertype IPv6 (0x86dd), length 166: (flowlabel 0x9083b, hlim 1, next-header UDP (17) payload length: 110) fe80::fcc0:d594:c557:614a.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=b30654 (elapsed-time 65535) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 909a4abef778) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
14:27:20.388872  In ethertype IPv6 (0x86dd), length 172: (hlim 1, next-header UDP (17) payload length: 116) fe80::f0:b7a8.5678 > ff02::1.5678: [udp sum ok] UDP, length 108
14:28:20.387528  In ethertype IPv6 (0x86dd), length 172: (hlim 1, next-header UDP (17) payload length: 116) fe80::f0:b7a8.5678 > ff02::1.5678: [udp sum ok] UDP, length 108

First and two last are Mikrotik Neighbour Discovery, not connected to you.
The second seems to be your DHCP6 solicitation which goes unanswered.

Umm can you suggest me some topics to get my basics on ipv6 ?
I get ipv4 but 6 is pretty new here.(I'm more of an IoT person and trying to run my things over ipv6 cuz ipv4 is scarce or pretty expensive)

Now I reverted to tplink firmware went through all the settings but couldn't get a public address. Maybe it's my isp scamming people promoting themselves having ipv6

I can recommend to read this free e-book, although it is more focused on security.
Also this presentation from ripe.