IPV6 PPPOE connection issues

Hi there I am attemtping to configure my router to support IPV6 with plusnet here in the UK however I am unable to get a IPV6 address on my WAN connection. Here is my router information and current configuration if any one has any ideas please let me know.

Hardware & Openwrt version

Model
Linksys WRT3200ACM
Architecture
ARMv7 Processor rev 1 (v7l)
Firmware Version
OpenWrt 19.07.4 r11208-ce6496d796 / LuCI openwrt-19.07 branch git-20.287.57033-3d52019
Kernel Version
4.14.195

Interfaces / network

config interface 'wan'
        option proto 'pppoe'
        option password 'blahblah'
        option username 'me'
        option ifname 'eth1.2'
        option ipv6 'auto'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'
        option reqprefix 'auto'
        option reqaddress 'try'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.1'

I have added the following items to the firewall as per the ipv6 guide from the main open-wrt website

config rule
        option target 'ACCEPT'
        option src 'wan'
        option proto 'udp'
        option dest_port '547'
        option name 'Allow DHCPv6 (546-to-547)'
        option family 'ipv6'
        option src_port '546'

config rule
        option target 'ACCEPT'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option name 'Allow DHCPv6 (547-to-546)'
        option family 'ipv6'
        option src_port '547'

I also have tried wan6 as both relay and hybrid options for the DHCP config as follows

config dhcp 'wan6'
        option dhcpv6 'hybrid'
        option ra 'hybrid'
        option ndp 'hybrid'
        option master '1'

So that is my setup when i attempt to reset the wan6 interface i get the following error messages

Fri Oct 16 18:34:57 2020 daemon.notice netifd: Interface 'wan6' is now down
Fri Oct 16 18:34:57 2020 daemon.notice netifd: Interface 'wan6' is disabled
Fri Oct 16 18:34:57 2020 daemon.notice netifd: Interface 'wan6' is enabled
Fri Oct 16 18:34:57 2020 daemon.notice netifd: Interface 'wan6' is setting up now
Fri Oct 16 18:34:57 2020 daemon.err odhcp6c[8172]: Failed to send RS (Permission denied)
Fri Oct 16 18:34:57 2020 daemon.err odhcp6c[8172]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Fri Oct 16 18:34:58 2020 daemon.err odhcp6c[8172]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Fri Oct 16 18:35:00 2020 cron.info crond[2284]: USER root pid 8238 cmd /etc/cronfw.sh
Fri Oct 16 18:35:00 2020 daemon.err odhcp6c[8172]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Fri Oct 16 18:35:01 2020 daemon.err odhcp6c[8172]: Failed to send RS (Permission denied)
Fri Oct 16 18:35:05 2020 daemon.err odhcp6c[8172]: Failed to send RS (Permission denied)
Fri Oct 16 18:35:05 2020 daemon.err odhcp6c[8172]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Fri Oct 16 18:35:09 2020 daemon.err odhcp6c[8172]: Failed to send RS (Permission denied)
Fri Oct 16 18:35:13 2020 daemon.err odhcp6c[8172]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Fri Oct 16 18:35:30 2020 daemon.err odhcp6c[8172]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)

Does anyone have any suggestions?


has a collection of ISP specific configuration examples. Yes, the guide is predominantly for different hardware with included VDSL modem hardware, but the same principles apply here as well; I guess you're just missing proper VLAN tagging on the WAN interface.

Yeah I forgot I have a VDSL modem setup this can get an IPV4&6 address when setup as a router, this issue remains the same with a second modem in bridge mode