Ipv6 not working

Hii,
I am trying to get ipv6 working from my router(B).
Atm it is configured like this: cable connection goes inside my isp router(A). I have on it ipv6 host exposure activated for my router(B), and gave it a reserved IP there (192.168.2.2). The isp router (A) is set to be on 192.168.2.1 .
According to my isp router (A) webinterface my router (B) is getting an ipv6 address from it. but when i try to ping6 openwrt.org from the diagonstics web interface (B) i get "ping6: sendto: Permission denied" (ping via ipv4 works fine).
I think i configured something wrong but i am new to all of this (i did my first open wrt install yesterday and i am a bit overwhelmed from the amount of configuration that is possible compared to my isps router) and don't really know where to look for my mistake.

Thank you in advance :slight_smile:

EDIT:
PS: i marked my isps router with (A) and my tp link router with openwrt with (B). i hope this helps

here is my current network configuration

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd8a:e1cc:af04::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.2'
	option proto 'static'
	option ipaddr '192.168.2.2'
	option netmask '255.255.255.0'
	option gateway '192.168.2.1'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 5t'

config route6
	option interface 'wan6'
	option target '2000::/3'
	option gateway 'fe80::f6ca:e5xx:fyyy:zzzb'

Why did you add that route6? The default configuration should work fine in most of the cases.

because i was kinda desperate and found it on a website and hoped that it would fix it. - but it didn't. i guess i should remove it.

1 Like

Remove it, then post the following:

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; ifstatus wan6

Alrighty, this should work:

root@OpenWrt:~# ubus call system board; \
> uci export network; uci export dhcp; uci exp
ort firewall; \
> head -n -0 /etc/firewall.user; \
> ip -6 addr ; ip -6 ro li tab all ; ip -6 ru;
 \
> ls -l  /etc/resolv.* /tmp/resolv.* /tmp/reso
lv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.
* /tmp/resolv.*/* ; ifstatus wan6
{
	"kernel": "5.4.188",
	"hostname": "OpenWrt",
	"system": "Atheros AR9132 rev 2",
	"model": "TP-Link TL-WR1043ND v1",
	"board_name": "tplink,tl-wr1043nd-v1",
	"release": {
		"distribution": "OpenWrt",
		"version": "21.02.3",
		"revision": "r16554-1d4dea6d4f",
		"target": "ath79/generic",
		"description": "OpenWrt 21.02.3 r16554-1d4dea6d4f"
	}
}
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd8a:e1cc:af04::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.2'
	option proto 'static'
	option ipaddr '192.168.2.2'
	option netmask '255.255.255.0'
	option gateway '192.168.2.1'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 5t'

package dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option localservice '1'
	option ednspacket_max '1232'
	list server '1.1.1.1'
	list server '2606:4700:4700::1111'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ra 'relay'
	list ra_flags 'none'
	option dhcpv6 'relay'
	option ndp 'relay'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option master '1'
	option ra 'relay'
	list ra_flags 'none'
	option dhcpv6 'relay'
	option ndp 'relay'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

package firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::12fe:edff:fe37:45c6/64 scope link 
       valid_lft forever preferred_lft forever
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd8a:e1cc:af04::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::12fe:edff:fe37:45c6/64 scope link 
       valid_lft forever preferred_lft forever
7: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::12fe:edff:fe37:45c6/64 scope link 
       valid_lft forever preferred_lft forever
8: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::12fe:edff:fe37:45c6/64 scope link 
       valid_lft forever preferred_lft forever
fd8a:e1cc:af04::/64 dev br-lan  metric 1024 
unreachable fd8a:e1cc:af04::/48 dev lo  metric 2147483647 
fe80::/64 dev eth0  metric 256 
fe80::/64 dev eth0.2  metric 256 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev wlan0  metric 256 
local ::1 dev lo table local  metric 0 
anycast fd8a:e1cc:af04:: dev br-lan table local  metric 0 
local fd8a:e1cc:af04::1 dev br-lan table local  metric 0 
anycast fe80:: dev eth0 table local  metric 0 
anycast fe80:: dev eth0.2 table local  metric 0 
anycast fe80:: dev br-lan table local  metric 0 
anycast fe80:: dev wlan0 table local  metric 0 
local fe80::12fe:edff:fe37:45c6 dev eth0 table local  metric 0 
local fe80::12fe:edff:fe37:45c6 dev eth0.2 table local  metric 0 
local fe80::12fe:edff:fe37:45c6 dev br-lan table local  metric 0 
local fe80::12fe:edff:fe37:45c6 dev wlan0 table local  metric 0 
multicast ff00::/8 dev eth0 table local  metric 256 
multicast ff00::/8 dev br-lan table local  metric 256 
multicast ff00::/8 dev eth0.2 table local  metric 256 
multicast ff00::/8 dev wlan0 table local  metric 256 
0:	from all lookup local 
32766:	from all lookup main 
4200000001:	from all iif lo lookup unspec 12
4200000005:	from all iif br-lan lookup unspec 12
4200000007:	from all iif eth0.2 lookup unspec 12
lrwxrwxrwx    1 root     root            16 Apr 16 14:59 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            47 May 25 15:19 /tmp/resolv.conf
-rw-r--r--    1 root     root             0 May 25 15:17 /tmp/resolv.conf.d/resolv.conf.auto

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root             0 May 25 15:17 resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
{
	"up": false,
	"pending": true,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"proto": "dhcpv6",
	"device": "eth0.2",
	"data": {
		
	}
}

It doesn't seem to be up.

Try to run a ifup wan6

Apart from that:

there is some configuration for ipv6 relay. This should be used in very specific cases only, as a workaround. Then post again the same.

mhm apperently it does not come up if with ifup :frowning:

here is the command output for it with the ipv6 relay stuff disabled.

root@OpenWrt:~# ubus call system board; \
> uci export network; uci export dhcp; uci exp
ort firewall; \
> head -n -0 /etc/firewall.user; \
> ip -6 addr ; ip -6 ro li tab all ; ip -6 ru;
 \
> ls -l  /etc/resolv.* /tmp/resolv.* /tmp/reso
lv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.
* /tmp/resolv.*/* ; ifstatus wan6
{
	"kernel": "5.4.188",
	"hostname": "OpenWrt",
	"system": "Atheros AR9132 rev 2",
	"model": "TP-Link TL-WR1043ND v1",
	"board_name": "tplink,tl-wr1043nd-v1",
	"release": {
		"distribution": "OpenWrt",
		"version": "21.02.3",
		"revision": "r16554-1d4dea6d4f",
		"target": "ath79/generic",
		"description": "OpenWrt 21.02.3 r16554-1d4dea6d4f"
	}
}
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd8a:e1cc:af04::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.2'
	option proto 'static'
	option ipaddr '192.168.2.2'
	option netmask '255.255.255.0'
	option gateway '192.168.2.1'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 5t'

package dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option localservice '1'
	option ednspacket_max '1232'
	list server '1.1.1.1'
	list server '2606:4700:4700::1111'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	list ra_flags 'none'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list ra_flags 'none'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

package firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::12fe:edff:fe37:45c6/64 scope link 
       valid_lft forever preferred_lft forever
7: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::12fe:edff:fe37:45c6/64 scope link 
       valid_lft forever preferred_lft forever
9: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd8a:e1cc:af04::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::12fe:edff:fe37:45c6/64 scope link 
       valid_lft forever preferred_lft forever
11: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::12fe:edff:fe37:45c6/64 scope link 
       valid_lft forever preferred_lft forever
[redacted ipv6 adrerss] dev eth0.2  metric 1024 
fd8a:e1cc:af04::/64 dev br-lan  metric 1024 
unreachable fd8a:e1cc:af04::/48 dev lo  metric 2147483647 
fe80::/64 dev eth0  metric 256 
fe80::/64 dev eth0.2  metric 256 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev wlan0  metric 256 
local ::1 dev lo table local  metric 0 
anycast fd8a:e1cc:af04:: dev br-lan table local  metric 0 
local fd8a:e1cc:af04::1 dev br-lan table local  metric 0 
anycast fe80:: dev eth0 table local  metric 0 
anycast fe80:: dev eth0.2 table local  metric 0 
anycast fe80:: dev br-lan table local  metric 0 
anycast fe80:: dev wlan0 table local  metric 0 
local fe80::12fe:edff:fe37:45c6 dev eth0 table local  metric 0 
local fe80::12fe:edff:fe37:45c6 dev eth0.2 table local  metric 0 
local fe80::12fe:edff:fe37:45c6 dev br-lan table local  metric 0 
local fe80::12fe:edff:fe37:45c6 dev wlan0 table local  metric 0 
multicast ff00::/8 dev eth0 table local  metric 256 
multicast ff00::/8 dev eth0.2 table local  metric 256 
multicast ff00::/8 dev br-lan table local  metric 256 
multicast ff00::/8 dev wlan0 table local  metric 256 
0:	from all lookup local 
32766:	from all lookup main 
4200000001:	from all iif lo lookup unspec 12
4200000007:	from all iif eth0.2 lookup unspec 12
4200000009:	from all iif br-lan lookup unspec 12
lrwxrwxrwx    1 root     root            16 Apr 16 14:59 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            47 May 25 19:51 /tmp/resolv.conf
-rw-r--r--    1 root     root             0 May 25 19:46 /tmp/resolv.conf.d/resolv.conf.auto

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root             0 May 25 19:46 resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
{
	"up": false,
	"pending": true,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"proto": "dhcpv6",
	"device": "eth0.2",
	"data": {
		
	}
}

Now the lan interface is not sending any RAs or DHCP6. I see that there are not so many configurations, so maybe it would be a good idea to take a backup if you need, then reset to defaults. The default configuration works with IPv4v6 immediately, so we'll rule out any misconfiguration.

so i reverted back to the default settings, still no working ipv6

root@OpenWrt:~# ubus call system board; \
> uci export network; uci export dhcp; uci exp
ort firewall; \
> head -n -0 /etc/firewall.user; \
> ip -6 addr ; ip -6 ro li tab all ; ip -6 ru;
 \
> ls -l  /etc/resolv.* /tmp/resolv.* /tmp/reso
lv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.
* /tmp/resolv.*/* ; ifstatus wan6
{
	"kernel": "5.4.188",
	"hostname": "OpenWrt",
	"system": "Atheros AR9132 rev 2",
	"model": "TP-Link TL-WR1043ND v1",
	"board_name": "tplink,tl-wr1043nd-v1",
	"release": {
		"distribution": "OpenWrt",
		"version": "21.02.3",
		"revision": "r16554-1d4dea6d4f",
		"target": "ath79/generic",
		"description": "OpenWrt 21.02.3 r16554-1d4dea6d4f"
	}
}
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde6:fdde:2c6f::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 5t'

package dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

package firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::12fe:edff:fe37:45c6/64 scope link 
       valid_lft forever preferred_lft forever
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fde6:fdde:2c6f::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::12fe:edff:fe37:45c6/64 scope link 
       valid_lft forever preferred_lft forever
7: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::12fe:edff:fe37:45c6/64 scope link 
       valid_lft forever preferred_lft forever
fde6:fdde:2c6f::/64 dev br-lan  metric 1024 
fde6:fdde:2c6f:4::/62 via fe80::2d8:61ff:fe9d:c847 dev br-lan  metric 1024 
unreachable fde6:fdde:2c6f::/48 dev lo  metric 2147483647 
fe80::/64 dev eth0  metric 256 
fe80::/64 dev eth0.2  metric 256 
fe80::/64 dev br-lan  metric 256 
local ::1 dev lo table local  metric 0 
anycast fde6:fdde:2c6f:: dev br-lan table local  metric 0 
local fde6:fdde:2c6f::1 dev br-lan table local  metric 0 
anycast fe80:: dev eth0 table local  metric 0 
anycast fe80:: dev eth0.2 table local  metric 0 
anycast fe80:: dev br-lan table local  metric 0 
local fe80::12fe:edff:fe37:45c6 dev eth0 table local  metric 0 
local fe80::12fe:edff:fe37:45c6 dev eth0.2 table local  metric 0 
local fe80::12fe:edff:fe37:45c6 dev br-lan table local  metric 0 
multicast ff00::/8 dev eth0 table local  metric 256 
multicast ff00::/8 dev br-lan table local  metric 256 
multicast ff00::/8 dev eth0.2 table local  metric 256 
0:	from all lookup local 
32766:	from all lookup main 
4200000001:	from all iif lo lookup unspec 12
4200000005:	from all iif br-lan lookup unspec 12
4200000007:	from all iif eth0.2 lookup unspec 12
lrwxrwxrwx    1 root     root            16 Apr 16 12:59 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            47 Apr 16 13:00 /tmp/resolv.conf
-rw-r--r--    1 root     root            39 Apr 16 13:00 /tmp/resolv.conf.d/resolv.conf.auto

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root            39 Apr 16 13:00 resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface wan
nameserver 192.168.2.1
{
	"up": false,
	"pending": true,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"proto": "dhcpv6",
	"device": "eth0.2",
	"data": {
		
	}
}

It doesn't seem to me that IPv6 actually works. But let's check that.

opkg update
opkg install tcpdump
tcpdump -evni eth0.2 ip6 & \
sleep 3; \
killall -SIGUSR1 odhcp6c; \
sleep 20; \
killall tcpdump

well i had it actually working once for a short time but other problems - it broke again and well.

here is the output:

root@OpenWrt:~# tcpdump -evni eth0.2 ip6 & \
> sleep 3; \
> killall -SIGUSR1 odhcp6c; \
> sleep 20; \
> killall tcpdump
tcpdump: listening on eth0.2, link-type EN10MB (Ethernet), capture size 262144 bytes
22:18:23.294548 [redacted mac address of my isp router] > [redacted mac address of my device], ethertype IPv6 (0x86dd), length 118: (flowlabel 0x1d774, hlim 64, next-header ICMPv6 (58) payload length: 64) fe80::422b:50ff:fee8:b177 > fe80::12fe:edff:fe37:45c6: [icmp6 sum ok] ICMP6, echo request, seq 0
22:18:23.294863 [redacted mac address of my device] > [redacted mac address of my isp router], ethertype IPv6 (0x86dd), length 118: (flowlabel 0x06b37, hlim 64, next-header ICMPv6 (58) payload length: 64) fe80::12fe:edff:fe37:45c6 > fe80::422b:50ff:fee8:b177: [icmp6 sum ok] ICMP6, echo reply, seq 0
22:18:23.825814 [redacted mac address of my isp router] > 33:33:ff:00:51:36, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:5136: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::5136
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:23.982168 [redacted mac address of my isp router] > 33:33:00:00:00:01, ethertype IPv6 (0x86dd), length 158: (flowlabel 0x68483, hlim 255, next-header ICMPv6 (58) payload length: 104) fe80::422b:50ff:fee8:b177 > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 104
	hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 3600000ms, retrans timer 0ms
	  rdnss option (25), length 24 (3):  lifetime 300s, addr: [redacted ipv6 address]
	  prefix info option (3), length 32 (4): 2a02:908:1d4:c320::/64, Flags [onlink, auto], valid time 0s, pref. time 0s
	  route info option (24), length 24 (3):  ::/0, pref=medium, lifetime=1800s
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:24.756399 [redacted mac address of my device] > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 164: (flowlabel 0xa1099, hlim 1, next-header UDP (17) payload length: 110) fe80::12fe:edff:fe37:45c6.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=497210 (elapsed-time 0) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 10feed3745c6) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
22:18:24.849541 [redacted mac address of my isp router] > 33:33:ff:00:51:36, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:5136: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::5136
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:24.858143 [redacted mac address of my isp router] > 33:33:ff:00:90:e0, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:90e0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::90e0
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:25.817272 [redacted mac address of my device] > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 164: (flowlabel 0xa1099, hlim 1, next-header UDP (17) payload length: 110) fe80::12fe:edff:fe37:45c6.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=497210 (elapsed-time 106) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 10feed3745c6) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
22:18:25.873559 [redacted mac address of my isp router] > 33:33:ff:00:90:e0, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:90e0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::90e0
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:25.873698 [redacted mac address of my isp router] > 33:33:ff:00:51:36, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:5136: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::5136
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:25.888357 [redacted mac address of my isp router] > 33:33:ff:00:83:45, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:8345: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::8345
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:26.897492 [redacted mac address of my isp router] > 33:33:ff:00:83:45, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:8345: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::8345
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:26.897680 [redacted mac address of my isp router] > 33:33:ff:00:90:e0, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:90e0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::90e0
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:26.955240 [redacted mac address of my isp router] > 33:33:ff:00:51:36, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:5136: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::5136
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:26.984026 [redacted mac address of my isp router] > 33:33:00:00:00:01, ethertype IPv6 (0x86dd), length 158: (flowlabel 0x68483, hlim 255, next-header ICMPv6 (58) payload length: 104) fe80::422b:50ff:fee8:b177 > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 104
	hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 3600000ms, retrans timer 0ms
	  rdnss option (25), length 24 (3):  lifetime 300s, addr: [redacted ipv6 address]
	  prefix info option (3), length 32 (4): 2a02:908:1d4:c320::/64, Flags [onlink, auto], valid time 0s, pref. time 0s
	  route info option (24), length 24 (3):  ::/0, pref=medium, lifetime=1800s
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:27.991607 [redacted mac address of my isp router] > 33:33:ff:00:83:45, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:8345: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::8345
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:27.991608 [redacted mac address of my isp router] > 33:33:ff:00:51:36, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:5136: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::5136
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:27.991609 [redacted mac address of my isp router] > 33:33:ff:00:90:e0, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:90e0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::90e0
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:28.025351 [redacted mac address of my device] > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 164: (flowlabel 0xa1099, hlim 1, next-header UDP (17) payload length: 110) fe80::12fe:edff:fe37:45c6.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=497210 (elapsed-time 326) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 10feed3745c6) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
22:18:28.409042 [redacted mac address of my device] > [redacted mac address of my isp router], ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::12fe:edff:fe37:45c6 > fe80::422b:50ff:fee8:b177: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::422b:50ff:fee8:b177
	  source link-address option (1), length 8 (1): [redacted mac address of my device]
22:18:28.410559 [redacted mac address of my isp router] > [redacted mac address of my device], ethertype IPv6 (0x86dd), length 78: (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::422b:50ff:fee8:b177 > fe80::12fe:edff:fe37:45c6: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::422b:50ff:fee8:b177, Flags [router, solicited]
22:18:29.009419 [redacted mac address of my isp router] > 33:33:ff:00:51:36, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:5136: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::5136
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:29.009547 [redacted mac address of my isp router] > 33:33:ff:00:90:e0, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:90e0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::90e0
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:29.040801 [redacted mac address of my isp router] > 33:33:ff:00:83:45, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:8345: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::8345
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:29.987187 [redacted mac address of my isp router] > 33:33:00:00:00:01, ethertype IPv6 (0x86dd), length 158: (flowlabel 0x68483, hlim 255, next-header ICMPv6 (58) payload length: 104) fe80::422b:50ff:fee8:b177 > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 104
	hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 3600000ms, retrans timer 0ms
	  rdnss option (25), length 24 (3):  lifetime 300s, addr: [redacted ipv6 address]
	  prefix info option (3), length 32 (4): 2a02:908:1d4:c320::/64, Flags [onlink, auto], valid time 0s, pref. time 0s
	  route info option (24), length 24 (3):  ::/0, pref=medium, lifetime=1800s
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:30.034834 [redacted mac address of my isp router] > 33:33:ff:00:90:e0, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:90e0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::90e0
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:30.098210 [redacted mac address of my isp router] > 33:33:ff:00:83:45, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:8345: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::8345
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:31.121374 [redacted mac address of my isp router] > 33:33:ff:00:83:45, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:8345: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::8345
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:32.441272 [redacted mac address of my device] > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 164: (flowlabel 0xa1099, hlim 1, next-header UDP (17) payload length: 110) fe80::12fe:edff:fe37:45c6.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=497210 (elapsed-time 768) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 10feed3745c6) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
22:18:32.989638 [redacted mac address of my isp router] > 33:33:00:00:00:01, ethertype IPv6 (0x86dd), length 158: (flowlabel 0x68483, hlim 255, next-header ICMPv6 (58) payload length: 104) fe80::422b:50ff:fee8:b177 > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 104
	hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 3600000ms, retrans timer 0ms
	  rdnss option (25), length 24 (3):  lifetime 300s, addr: [redacted ipv6 address]
	  prefix info option (3), length 32 (4): 2a02:908:1d4:c320::/64, Flags [onlink, auto], valid time 0s, pref. time 0s
	  route info option (24), length 24 (3):  ::/0, pref=medium, lifetime=1800s
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:35.304712 [redacted mac address of my isp router] > [redacted mac address of my device], ethertype IPv6 (0x86dd), length 118: (flowlabel 0x1d774, hlim 64, next-header ICMPv6 (58) payload length: 64) fe80::422b:50ff:fee8:b177 > fe80::12fe:edff:fe37:45c6: [icmp6 sum ok] ICMP6, echo request, seq 0
22:18:35.305045 [redacted mac address of my device] > [redacted mac address of my isp router], ethertype IPv6 (0x86dd), length 118: (flowlabel 0x06b37, hlim 64, next-header ICMPv6 (58) payload length: 64) fe80::12fe:edff:fe37:45c6 > fe80::422b:50ff:fee8:b177: [icmp6 sum ok] ICMP6, echo reply, seq 0
22:18:35.992618 [redacted mac address of my isp router] > 33:33:00:00:00:01, ethertype IPv6 (0x86dd), length 158: (flowlabel 0x68483, hlim 255, next-header ICMPv6 (58) payload length: 104) fe80::422b:50ff:fee8:b177 > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 104
	hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 3600000ms, retrans timer 0ms
	  rdnss option (25), length 24 (3):  lifetime 300s, addr: [redacted ipv6 address]
	  prefix info option (3), length 32 (4): 2a02:908:1d4:c320::/64, Flags [onlink, auto], valid time 0s, pref. time 0s
	  route info option (24), length 24 (3):  ::/0, pref=medium, lifetime=1800s
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:37.042986 [redacted mac address of my isp router] > 33:33:ff:00:51:36, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:5136: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::5136
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:38.075475 [redacted mac address of my isp router] > 33:33:ff:00:90:e0, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:90e0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::90e0
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:38.098353 [redacted mac address of my isp router] > 33:33:ff:00:51:36, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:5136: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::5136
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:38.994682 [redacted mac address of my isp router] > 33:33:00:00:00:01, ethertype IPv6 (0x86dd), length 158: (flowlabel 0x68483, hlim 255, next-header ICMPv6 (58) payload length: 104) fe80::422b:50ff:fee8:b177 > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 104
	hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 3600000ms, retrans timer 0ms
	  rdnss option (25), length 24 (3):  lifetime 300s, addr: [redacted ipv6 address]
	  prefix info option (3), length 32 (4): 2a02:908:1d4:c320::/64, Flags [onlink, auto], valid time 0s, pref. time 0s
	  route info option (24), length 24 (3):  ::/0, pref=medium, lifetime=1800s
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:39.109185 [redacted mac address of my isp router] > 33:33:ff:00:83:45, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:8345: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::8345
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:39.121127 [redacted mac address of my isp router] > 33:33:ff:00:51:36, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:5136: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::5136
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:39.121265 [redacted mac address of my isp router] > 33:33:ff:00:90:e0, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:90e0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::90e0
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:40.145114 [redacted mac address of my isp router] > 33:33:ff:00:90:e0, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:90e0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::90e0
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:40.145251 [redacted mac address of my isp router] > 33:33:ff:00:83:45, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:8345: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::8345
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:40.174388 [redacted mac address of my isp router] > 33:33:ff:00:51:36, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:5136: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::5136
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:40.593761 [redacted mac address of my isp router] > [redacted mac address of my device], ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::422b:50ff:fee8:b177 > fe80::12fe:edff:fe37:45c6: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::12fe:edff:fe37:45c6
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:40.594010 [redacted mac address of my device] > [redacted mac address of my isp router], ethertype IPv6 (0x86dd), length 78: (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::12fe:edff:fe37:45c6 > fe80::422b:50ff:fee8:b177: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::12fe:edff:fe37:45c6, Flags [router, solicited]
22:18:41.169160 [redacted mac address of my isp router] > 33:33:ff:00:83:45, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:8345: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::8345
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:41.217414 [redacted mac address of my isp router] > 33:33:ff:00:90:e0, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:90e0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::90e0
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:41.233066 [redacted mac address of my isp router] > 33:33:ff:00:51:36, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:5136: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::5136
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:41.369279 [redacted mac address of my device] > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 164: (flowlabel 0xa1099, hlim 1, next-header UDP (17) payload length: 110) fe80::12fe:edff:fe37:45c6.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=497210 (elapsed-time 1661) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 10feed3745c6) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0))
22:18:41.999205 [redacted mac address of my isp router] > 33:33:00:00:00:01, ethertype IPv6 (0x86dd), length 158: (flowlabel 0x68483, hlim 255, next-header ICMPv6 (58) payload length: 104) fe80::422b:50ff:fee8:b177 > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 104
	hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 3600000ms, retrans timer 0ms
	  rdnss option (25), length 24 (3):  lifetime 300s, addr: [redacted ipv6 address]
	  prefix info option (3), length 32 (4): 2a02:908:1d4:c320::/64, Flags [onlink, auto], valid time 0s, pref. time 0s
	  route info option (24), length 24 (3):  ::/0, pref=medium, lifetime=1800s
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:42.251147 [redacted mac address of my isp router] > 33:33:ff:00:83:45, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:8345: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::8345
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:42.257142 [redacted mac address of my isp router] > 33:33:ff:00:51:36, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:5136: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::5136
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:42.257282 [redacted mac address of my isp router] > 33:33:ff:00:90:e0, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:90e0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::90e0
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:43.281977 [redacted mac address of my isp router] > 33:33:ff:00:90:e0, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:90e0: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::90e0
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:43.282117 [redacted mac address of my isp router] > 33:33:ff:00:83:45, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:8345: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::8345
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]
22:18:44.306085 [redacted mac address of my isp router] > 33:33:ff:00:83:45, ethertype IPv6 (0x86dd), length 86: (hlim 255, next-header ICMPv6 (58) payload length: 32) [redacted ipv6 address] > ff02::1:ff00:8345: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2a02:908:1d4:c320::8345
	  source link-address option (1), length 8 (1): [redacted mac address of my isp router]

56 packets captured
56 packets received by filter
0 packets dropped by kernel

I can see some DHCP solicitations from the OpenWrt, but none of them is answered, so most likely the ISP router is not offering DHCPv6. I believe you can verify that from the ISP router web interface, or ask your ISP.
I can also see a few Router Advertisements from the ISP router, however the prefix info option has valid time and preference time 0. I am not sure if this is meant to mean indefinite or is it a mistake. I believe this is the reason that the OpenWrt is not getting a GUA address from the ISP router and remains with the link local, which is not used to communicate to the internet.

That being said, you'll need to enable the IPv6 relay for the lan hosts to get IPv6.
But is any other device connected to the ISP router able to get a GUA IPv6 address?