IPv6 not working

Hi, I installed OpenWRT 21.02.2 on my Linksys WRT1900AC router because IPv6 wasn't working with the original firmware, but it's still not working. I tried setting it to relay mode for IPv6, but that didn't work either. Another router that I plugged in just works but that one only has 100 MBit ethernet ports, so I can't use it...

The router is connected to a Speedport Hybrid from Deutsche Telekom. IPv6 works from the router, but not the clients, neither wireless nor wired.

/etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	list server '208.67.222.222'
	list server '208.67.220.220'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	list ra_flags 'none'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config host
	option mac '1C:1B:0D:EC:7F:9E'
	option ip '192.168.1.205'

config host
	option mac '50:C7:BF:00:ED:75'
	option ip '192.168.1.106'

config host
	option mac 'B8:27:EB:6F:C9:85'
	option ip '192.168.1.153'

config host
	option mac '48:E1:E9:51:26:B3'
	option ip '192.168.1.152'

config host
	option mac '00:09:B0:E6:B0:D3'
	option ip '192.168.1.196'

config host
	option mac '50:C7:BF:03:6D:57'
	option ip '192.168.1.120'

config host
	option mac '50:C7:BF:03:6E:EB'
	option ip '192.168.1.68'

config host
	option mac '50:C7:BF:05:FB:A1'
	option ip '192.168.1.63'

config host
	option mac '50:C7:BF:09:0F:5B'
	option ip '192.168.1.249'

config host
	option mac '50:C7:BF:09:14:36'
	option ip '192.168.1.206'

config host
	option mac '50:C7:BF:28:BA:FF'
	option ip '192.168.1.97'

config host
	option mac 'AC:9B:0A:EC:A6:48'
	option ip '192.168.1.85'

config dhcp 'wan6'
	option interface 'wan6'
	option ra 'relay'
	option dhcpv6 'relay'
	option ndp 'relay'
	option master '1'
	option ignore '1'
	list ra_flags 'none'

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd49:682e:4634::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config device
	option name 'lan1'
	option macaddr '94:10:3e:9a:6a:01'

config device
	option name 'lan2'
	option macaddr '94:10:3e:9a:6a:01'

config device
	option name 'lan3'
	option macaddr '94:10:3e:9a:6a:01'

config device
	option name 'lan4'
	option macaddr '94:10:3e:9a:6a:01'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr '94:10:3e:9a:6a:01'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option peerdns '0'
	list dns '208.67.222.222'
	list dns '208.67.220.220'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

/etc/config/firewall

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option output 'ACCEPT'
	option mtu_fix '1'
	option masq '1'
	option input 'REJECT'
	option forward 'REJECT'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'

Btw. I've registered a domain and set its A record to 192.168.1.153 (my Raspberry Pi), but it won't resolve that domain anymore since I've installed OpenWRT. How could that be?

You may have mixed the relay and server mode...

You should have relay in both lan and wan.

Btw,

Registered where? In a device in your local LAN?

Note that 192.168.x.x is an address area for private IP addressing insideLAN, and is non-routable from public internet perspective.

Oh. Well, it works now, thanks.

I have a TLD for my business and I added a subdomain and set its A record to 192.168.1.153. This should just resolve to that address and the browser should then attempt to connect to 192.168.1.153, which will work in the local network. It has worked before, it only broke when I installed OpenWRT. Typing in 192.168.1.153 manually works, so it's not a big deal, but still weird.

Turn off DNS Rebind Protection.

screen359

1 Like