IPv6 not working on my phone

Can someone please help me configure IPv6 on my phone, because it doesn't work, but should be.
I have static prefix /60 from my wireguard tunnel. IPv6 works on my wi-fi connected laptop, on my wire connected PC, but not on my phone.

On router main page I see 3 DHCP leases, and only two DHCPv6 leases:

tcpdump shows something is going on:

DNS query

IP6 (flowlabel 0x90d1b, hlim 64, next-header UDP (17) payload length: 39) fd42:42:42:0:b85a:2394:f6a8:6b0e.51949 > fd42:42:42:0:8e59:73ff:fef9:d50e.53: [udp sum ok] 3412+ A? instagram.com.

but not with tracert6:


IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fd42:42:42:0:b85a:2394:f6a8:6b0e > fe80::8e59:73ff:fef9:d50e: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fd42:42:42:0:b85a:2394:f6a8:6b0e, Flags [router, solicited]

As per your last thread, please show the mobile's config.

What mobile config? It's not wireguard client. I've already told you the case is not about mobile configuration.
Or maybe your are talking about this configuration?


1 Like

If it's an Android mobile then it's expected since it doesn't support DHCPv6. (Some vendors might have their own DHCPv6 implementation, I'm not sure.)
Android and ChromeOS require SLAAC.

Edit: I see that it's an Android mobile, and it has got IPv6 addresses. Don't know why it doesn't work.
(Though it uses incorrect ULA prefix, but it shouldn't matter. A ULA prefix should be generated using a random value.)


Yeap Android

Maybe I could configure it somehow?

It is configured, but you should remove the other ULA prefix since Android might use that instead.

1 Like

What other? I have only one


fd42:42:42::/64 is also a ULA prefix (though not created using the ULA algorithm which uses a random value). You should make sure all prefixes you assign to the LAN interface can be used since it's up to the clients to choose which prefix/address they use at a given time.

Edit: Maybe you should use ip6class = wg06 on the lan interface.


I'm starting to think the mobile issue may be use of an ULA and NAT6 upstream.

@vanyaindigo, can you install a traceroute app on your mobile to determine where your IPv6 packets stop in the trace?

1 Like

Already done:


1 Like

Yeap, that helped! ULA prefix was excess.
Now it's look like


/ect/config/network 'lan' part

config interface 'lan'
option type 'bridge'
option ifname 'eth1.1'
option proto 'static'
option ipaddr ''
option netmask ''
option ip6hint 'abcd'
list ip6class 'wg06'
option ip6assign '64'

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.