IPv6 not working (19.07.2)

I can't get IPv6 working after updating to OpenWrt 19.07.2, r10947-65030d81f3. It was working with OpenWrt 19.07.1 but I guess I've messed up and can't fix it without some help.

IPv4 is working OK.

When I use the OpenWRT diagnostics I get:

IPv6 ping

PING openwrt.org (2a03:b0c0:3:d0::1af1:1): 56 data bytes
64 bytes from 2a03:b0c0:3:d0::1af1:1: seq=0 ttl=48 time=395.128 ms
64 bytes from 2a03:b0c0:3:d0::1af1:1: seq=1 ttl=48 time=394.753 ms
64 bytes from 2a03:b0c0:3:d0::1af1:1: seq=2 ttl=48 time=394.677 ms
64 bytes from 2a03:b0c0:3:d0::1af1:1: seq=3 ttl=48 time=394.377 ms
64 bytes from 2a03:b0c0:3:d0::1af1:1: seq=4 ttl=48 time=394.312 ms

--- openwrt.org ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 394.312/394.649/395.128 ms

IPv6 traceroute

<h1>Bad Gateway</h1>The process did not produce any response

Here's my network configuration:

cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd95:12ba:a87c::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'pppoe'
	option username 'myname@myisp.net'
	option peerdns '0'
	option password 'XXXXXXXXXX'
	option keepalive '500 5'
	option ipv6 'auto'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	list dns '2606:4700:4700::64'
	list dns '2606:4700:4700::6400'

config interface 'wan6'
	option keepalive '500 5'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option ifname '@wan'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '5t 3 2 1 0'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '6t 4t'

config interface 'guest'
	option proto 'static'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'
	option type 'bridge'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

Any suggestions or pointers to reading I should do would be appreciated.

First remove the

	list dns '1.1.1.1'
	list dns '1.0.0.1'

from lan and guest interfaces.
Then you have option ipv6 'auto' in wan, which means that the wan_6 will be automatically spawned. If you want to make it manually in wan6, change from auto to 1. No need for keepalive in wan6.
Post also the ifstatus wan6 or ifstatus wan_6 and ifstatus lan

root@OpenWrt:~# ifstatus wan6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 11960,
        "l3_device": "pppoe-wan",
        "proto": "dhcpv6",
        "device": "pppoe-wan",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2001:44b8:36:130:5ce5:acad:5ee1:9b7b",
                        "mask": 64,
                        "preferred": 5801,
                        "valid": 5801
                }
        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2001:44b8:36:130::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 5801,
                        "source": "::/0"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::522f:a8ff:fe44:a300",
                        "metric": 512,
                        "valid": 5741,
                        "source": "2001:44b8:36:130:5ce5:acad:5ee1:9b7b/64"
                }
        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}
root@OpenWrt:~# ifstatus lan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 33069,
        "l3_device": "br-lan",
        "proto": "static",
        "device": "br-lan",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.1.1",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [
                {
                        "address": "2001:44b8:37:2e4::",
                        "mask": 64,
                        "preferred": 2296,
                        "valid": 5897,
                        "local-address": {
                                "address": "2001:44b8:37:2e4::1",
                                "mask": 64
                        }
                },
                {
                        "address": "fd95:12ba:a87c::",
                        "mask": 60,
                        "local-address": {
                                "address": "fd95:12ba:a87c::1",
                                "mask": 60
                        }
                }
        ],
        "route": [

        ],
        "dns-server": [
                "1.1.1.1",
                "1.0.0.1"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}
root@OpenWrt:~# ifstatus wan_6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": true,
        "uptime": 12271,
        "l3_device": "pppoe-wan",
        "proto": "dhcpv6",
        "device": "pppoe-wan",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2001:44b8:36:130:5ce5:acad:5ee1:9b7b",
                        "mask": 64,
                        "preferred": 5497,
                        "valid": 5497
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2001:44b8:37:2e4::",
                        "mask": 64,
                        "preferred": 2141,
                        "valid": 5742,
                        "class": "wan_6",
                        "assigned": {
                                "lan": {
                                        "address": "2001:44b8:37:2e4::",
                                        "mask": 64
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2001:44b8:36:130::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 5497,
                        "source": "::/0"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::522f:a8ff:fe44:a300",
                        "metric": 512,
                        "valid": 5437,
                        "source": "2001:44b8:36:130:5ce5:acad:5ee1:9b7b/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::522f:a8ff:fe44:a300",
                        "metric": 512,
                        "valid": 5437,
                        "source": "2001:44b8:37:2e4::/64"
                }
        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [
                        "2001:44b8:1::1",
                        "2001:44b8:2::2"
                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "001500160373697009696e7465726e6f6465026f6e036e65740000170020200144b8000100000000000000000001200144b8000200000000000000000002001f0010200144b8000100000000000000000001",
                "zone": "wan"
        }
}

You have 2 interfaces for ipv6 and there is conflict.
Remove one of them as I described in my previous post.

Done that and now it's working fine.

Thanks for your help. :smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.