IPv6 is not working

DNS is working fine, the address is resolved. Why it is not working is not clear. However your setup of dhcp/dhcpv6 on the wan/wan6 works right out of the box. Therefore to rule out any accidental misconfiguration from your side, take a backup of the configuration (just in case), and reset OpenWrt to defaults.

Hello Trendy,
Thank you for your patience.
I have started again as you've instructed (using x64 openwrt)
Windows 10 was able to get a WAN IP and route to the internet: Speed test was 800Mbps/90Mbps.
(Capture of windows 10 negotiation with the modem is available if that would help)

No internet with debian11 or openwrt but they get IPs.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 21.02.1, r16325-88151b8303
 -----------------------------------------------------
root@OpenWrt:~# ping 1.1.1.1
PING 1.1.1.1 (1.1.1.1): 56 data bytes
ping: sendto: Network unreachable
root@OpenWrt:~# ping bbc.com
ping: bad address 'bbc.com'
root@OpenWrt:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP group default qlen 1000
    link/ether f0:de:f1:77:bc:d2 brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:0e:c6:8e:15:89 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::20e:c6ff:fe8e:1589/64 scope link
       valid_lft forever preferred_lft forever
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether f0:de:f1:77:bc:d2 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd6b:310a:57ef::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::f2de:f1ff:fe77:bcd2/64 scope link
       valid_lft forever preferred_lft forever
root@OpenWrt:~# ifstatus wan
{
        "up": false,
        "pending": true,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcp",
        "device": "eth1",
        "data": {

        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd6b:310a:57ef::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth1'
        option hostname '*'

root@OpenWrt:~# echo "applying wan6 changes"
applying wan6 changes



root@OpenWrt:~# uci set network.wan6=interface
root@OpenWrt:~# uci set network.wan6.device='eth1'
root@OpenWrt:~# uci set network.wan6.proto='dhcpv6'
root@OpenWrt:~# uci set network.wan6.reqaddress='try'
root@OpenWrt:~# uci set network.wan6.reqprefix='auto'
root@OpenWrt:~# uci del firewall.wan.network
uci: Entry not found
root@OpenWrt:~# uci add_list firewall.wan.network='wan'
uci: Invalid argument
root@OpenWrt:~# uci add_list firewall.wan.network='wan6'
uci: Invalid argument
root@OpenWrt:~# uci commit network
root@OpenWrt:~# uci commit firewall
root@OpenWrt:~# ifup wan6
root@OpenWrt:~# sync
root@OpenWrt:~# reboot
root@OpenWrt:~#


Using username "root".
root@192.168.1.1's password:
Send automatic password


BusyBox v1.33.1 (2021-10-24 09:01:35 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 21.02.1, r16325-88151b8303
 -----------------------------------------------------
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd6b:310a:57ef::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth1'
        option hostname '*'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

root@OpenWrt:~# ping bbc.com
ping: bad address 'bbc.com'

root@OpenWrt:~# ping 1.1.1.1
PING 1.1.1.1 (1.1.1.1): 56 data bytes
ping: sendto: Network unreachable

root@OpenWrt:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan


root@OpenWrt:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP group default qlen 1000
    link/ether f0:de:f1:77:bc:d2 brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:0e:c6:8e:15:89 brd ff:ff:ff:ff:ff:ff
    inet6 2a10:4440:100:0:20e:c6ff:fe8e:1589/64 scope global dynamic noprefixroute
       valid_lft 2591980sec preferred_lft 604780sec
    inet6 fe80::20e:c6ff:fe8e:1589/64 scope link
       valid_lft forever preferred_lft forever
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether f0:de:f1:77:bc:d2 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd6b:310a:57ef::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::f2de:f1ff:fe77:bcd2/64 scope link
       valid_lft forever preferred_lft forever

root@OpenWrt:~# ping -6 bbc.com
ping: bad address 'bbc.com'
root@OpenWrt:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable


root@OpenWrt:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan
root@OpenWrt:~#

Wow!
opkg update: Works
opkg install gcc: Works
ping bbc.co.uk : Fails
ping 1.1.1.1 : Works

Could a minute change fix this?

root@OpenWrt:~# opkg update
Downloading https://downloads.openwrt.org/releases/21.02.1/targets/x86/64/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_core
Downloading https://downloads.openwrt.org/releases/21.02.1/targets/x86/64/packages/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/21.02.1/packages/x86_64/base/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_base
Downloading https://downloads.openwrt.org/releases/21.02.1/packages/x86_64/base/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/21.02.1/packages/x86_64/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_luci
Downloading https://downloads.openwrt.org/releases/21.02.1/packages/x86_64/luci/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/21.02.1/packages/x86_64/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_packages
Downloading https://downloads.openwrt.org/releases/21.02.1/packages/x86_64/packages/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/21.02.1/packages/x86_64/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_routing
Downloading https://downloads.openwrt.org/releases/21.02.1/packages/x86_64/routing/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/21.02.1/packages/x86_64/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_telephony
Downloading https://downloads.openwrt.org/releases/21.02.1/packages/x86_64/telephony/Packages.sig
Signature check passed.


root@OpenWrt:~# ping bbc.com
PING bbc.com (2a04:4e42::81): 56 data bytes
^C
--- bbc.com ping statistics ---
9 packets transmitted, 0 packets received, 100% packet loss

root@OpenWrt:~# ping 1.1.1.1
PING 1.1.1.1 (1.1.1.1): 56 data bytes
64 bytes from 1.1.1.1: seq=0 ttl=54 time=17.832 ms
64 bytes from 1.1.1.1: seq=1 ttl=54 time=15.885 ms
64 bytes from 1.1.1.1: seq=2 ttl=54 time=15.880 ms
^C
--- 1.1.1.1 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 15.880/16.532/17.832 ms

root@OpenWrt:~# opkg install gcc
Installing gcc (7.4.0-5) to root...
Downloading https://downloads.openwrt.org/releases/21.02.1/packages/x86_64/packages/gcc_7.4.0-5_x86_64.ipk
Configuring gcc.
root@OpenWrt:~#

root@OpenWrt:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         212.135.1.129  0.0.0.0         UG    0      0        0 eth1
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan
212.135.1.128  *               255.255.255.128 U     0      0        0 eth1
root@OpenWrt:~#

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*; \
ifstatus wan6; ifstatus lan

Here it is:

root@OpenWrt:~# ubus call system board; \
ifstatus wan6; ifstatus lan> uci export network; \
> uci export dhcp; uci export firewall; \
> head -n -0 /etc/firewall.user; \
> ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
> ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
> ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*; \
> ifstatus wan6; ifstatus lan
{
        "kernel": "5.4.154",
        "hostname": "OpenWrt",
        "system": "Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz",
        "model": "LENOVO 4290CZ2",
        "board_name": "lenovo-4290cz2",
        "release": {
                "distribution": "OpenWrt",
                "version": "21.02.1",
                "revision": "r16325-88151b8303",
                "target": "x86/64",
                "description": "OpenWrt 21.02.1 r16325-88151b8303"
        }
}
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd6b:310a:57ef::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth1'
        option hostname '*'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        list ra_flags 'none'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

package firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option drop_invalid '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'DROP'
        option forward 'DROP'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option family 'ipv4'
        list icmp_type 'echo-request'
        option target 'DROP'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Support-UDP-Traceroute'
        option src 'wan'
        option dest_port '33434:33689'
        option proto 'udp'
        option family 'ipv4'
        option target 'REJECT'
        option enabled '0'

config include
        option path '/etc/firewall.user'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    inet 212.135.1.254/25 brd 212.135.1.255 scope global eth1
       valid_lft forever preferred_lft forever
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
default via 212.135.1.129 dev eth1 proto static src 212.135.1.254
192.168.1.0/24 dev br-lan proto kernel scope link src 192.168.1.1
212.135.1.128/25 dev eth1 proto kernel scope link src 212.135.1.254
broadcast 127.0.0.0 dev lo table local proto kernel scope link src 127.0.0.1
local 127.0.0.0/8 dev lo table local proto kernel scope host src 127.0.0.1
local 127.0.0.1 dev lo table local proto kernel scope host src 127.0.0.1
broadcast 127.255.255.255 dev lo table local proto kernel scope link src 127.0.0.1
broadcast 192.168.1.0 dev br-lan table local proto kernel scope link src 192.168.1.1
local 192.168.1.1 dev br-lan table local proto kernel scope host src 192.168.1.1
broadcast 192.168.1.255 dev br-lan table local proto kernel scope link src 192.168.1.1
broadcast 212.135.1.128 dev eth1 table local proto kernel scope link src 212.135.1.254
local 212.135.1.254 dev eth1 table local proto kernel scope host src 212.135.1.254
broadcast 212.135.1.255 dev eth1 table local proto kernel scope link src 212.135.1.254
0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 3a10:6969:100:0:20e:c6ff:fe8e:1589/64 scope global dynamic noprefixroute
       valid_lft 2591998sec preferred_lft 604798sec
    inet6 3a10:6969:100::db2/128 scope global dynamic noprefixroute
       valid_lft 86329sec preferred_lft 64729sec
    inet6 fe80::20e:c6ff:fe8e:1589/64 scope link
       valid_lft forever preferred_lft forever
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 3a10:6969:fff:1570::1/60 scope global dynamic noprefixroute
       valid_lft 86330sec preferred_lft 64730sec
    inet6 fd6b:310a:57ef::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::f2de:f1ff:fe77:bcd2/64 scope link
       valid_lft forever preferred_lft forever
default from 3a10:6969:100::db2 via fe80::200:ff:feab:cdef dev eth1 proto static metric 384 pref medium
default from 3a10:6969:100::/64 via fe80::200:ff:feab:cdef dev eth1 proto static metric 384 pref medium
default from 3a10:6969:fff:1570::/60 via fe80::200:ff:feab:cdef dev eth1 proto static metric 384 pref medium
3a10:6969:100::/64 dev eth1 proto static metric 256 pref medium
unreachable 3a10:6969:100::/64 dev lo proto static metric 2147483647 pref medium
3a10:6969:fff:1570::/64 dev br-lan proto static metric 1024 pref medium
unreachable 3a10:6969:fff:1570::/60 dev lo proto static metric 2147483647 pref medium
fd6b:310a:57ef::/64 dev br-lan proto static metric 1024 pref medium
unreachable fd6b:310a:57ef::/48 dev lo proto static metric 2147483647 pref medium
fe80::/64 dev br-lan proto kernel metric 256 pref medium
fe80::/64 dev eth1 proto kernel metric 256 pref medium
local ::1 dev lo table local proto kernel metric 0 pref medium
anycast 3a10:6969:100:: dev eth1 table local proto kernel metric 0 pref medium
local 3a10:6969:100::db2 dev eth1 table local proto kernel metric 0 pref medium
local 3a10:6969:100:0:20e:c6ff:fe8e:1589 dev eth1 table local proto kernel metric 0 pref medium
anycast 3a10:6969:fff:1570:: dev br-lan table local proto kernel metric 0 pref medium
local 3a10:6969:fff:1570::1 dev br-lan table local proto kernel metric 0 pref medium
anycast fd6b:310a:57ef:: dev br-lan table local proto kernel metric 0 pref medium
local fd6b:310a:57ef::1 dev br-lan table local proto kernel metric 0 pref medium
anycast fe80:: dev br-lan table local proto kernel metric 0 pref medium
anycast fe80:: dev eth1 table local proto kernel metric 0 pref medium
local fe80::20e:c6ff:fe8e:1589 dev eth1 table local proto kernel metric 0 pref medium
local fe80::f2de:f1ff:fe77:bcd2 dev br-lan table local proto kernel metric 0 pref medium
multicast ff00::/8 dev br-lan table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth1 table local proto kernel metric 256 pref medium
0:      from all lookup local
32766:  from all lookup main
4200000000:     from 3a10:6969:fff:1570::1/60 iif br-lan unreachable
4200000001:     from all iif lo failed_policy
4200000003:     from all iif eth1 failed_policy
4200000003:     from all iif eth1 failed_policy
4200000004:     from all iif br-lan failed_policy
lrwxrwxrwx    1 root     root            16 Oct 24 09:01 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            47 Nov 30 16:03 /tmp/resolv.conf
-rw-r--r--    1 root     root           158 Nov 30 16:05 /tmp/resolv.conf.d/resolv.conf.auto

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root           158 Nov 30 16:05 resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface wan
nameserver 135.125.89.221
nameserver 135.125.89.222
search cpe.cable4.de
# Interface wan6
nameserver 3a10:6969::221
nameserver 3a10:6969::222
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 61,
        "l3_device": "eth1",
        "proto": "dhcpv6",
        "device": "eth1",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "3a10:6969:100::db2",
                        "mask": 128,
                        "preferred": 64729,
                        "valid": 86329
                },
                {
                        "address": "3a10:6969:100:0:20e:c6ff:fe8e:1589",
                        "mask": 64,
                        "preferred": 604797,
                        "valid": 2591997
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "3a10:6969:fff:1570::",
                        "mask": 60,
                        "preferred": 64729,
                        "valid": 86329,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "3a10:6969:fff:1570::",
                                        "mask": 60
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "3a10:6969:100::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 2591997,
                        "source": "::/0"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::200:ff:feab:cdef",
                        "metric": 384,
                        "valid": 2697,
                        "source": "3a10:6969:fff:1570::/60"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::200:ff:feab:cdef",
                        "metric": 384,
                        "valid": 2697,
                        "source": "3a10:6969:100:0:20e:c6ff:fe8e:1589/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::200:ff:feab:cdef",
                        "metric": 384,
                        "valid": 2697,
                        "source": "3a10:6969:100::db2/128"
                }
        ],
        "dns-server": [
                "3a10:6969::221",
                "3a10:6969::222"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "001700202a1044400000000000000000000002212a104440000000000000000000000222"
        }
}
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 173,
        "l3_device": "br-lan",
        "proto": "static",
        "device": "br-lan",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.1.1",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [
                {
                        "address": "3a10:6969:fff:1570::",
                        "mask": 60,
                        "preferred": 64729,
                        "valid": 86329,
                        "local-address": {
                                "address": "3a10:6969:fff:1570::1",
                                "mask": 60
                        }
                },
                {
                        "address": "fd6b:310a:57ef::",
                        "mask": 60,
                        "local-address": {
                                "address": "fd6b:310a:57ef::1",
                                "mask": 60
                        }
                }
        ],
        "route": [

        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}
root@OpenWrt:~#

Looks correct to me. Run a packet capture on the OpenWrt to verify that packets can go out.
tcpdump -i eth1 -vn ip6
Then try to ping or access some ipv6 server and post here the output.

root@OpenWrt:~# tcpdump -i eth1 -vn ip6
tcpdump: listening on eth1, link-type EN10MB (Ethernet), capture size 262144 byt                                                                                                                                                              es
12:19:30.154744 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) 2a10:                                                                                                                                                              4440:100::1 > ff02::1: [icmp6 sum ok] ICMP6, neighbor advertisement, length 32,                                                                                                                                                               tgt is 3a10:6969:100::1, Flags [router, override]
          destination link-address option (2), length 8 (1): 00:00:00:ab:cd:ef
12:19:30.156321 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :200:ff:feab:cdef > ff02::1: [icmp6 sum ok] ICMP6, neighbor advertisement, lengt                                                                                                                                                              h 32, tgt is fe80::200:ff:feab:cdef, Flags [router, override]
          destination link-address option (2), length 8 (1): 00:00:00:ab:cd:ef
12:19:30.710469 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:5e41 > ff02::1:ff23:e3a6: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::2e91:abff:fe23:e3a6
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:30.713524 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:5e41 > ff02::1:ff09:eefc: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::aa97:cdff:fe09:eefc
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:30.718501 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff23:ea98: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::2e91:abff:fe23:ea98
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:30.720412 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff09:efe2: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::aa97:cdff:fe09:efe2
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:30.722248 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:fffa:54b2: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::8a71:b1ff:fefa:54b2
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:30.722636 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff2c:46bc: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::de15:c8ff:fe2c:46bc
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:30.802734 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:fffa:59cb: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::8a71:b1ff:fefa:59cb
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:30.804159 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ffc2:a454: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::c289:abff:fec2:a454
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:30.805745 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff51:e305: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::7254:25ff:fe51:e305
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:30.806093 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ffc0:5792: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::422b:50ff:fec0:5792
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:31.738773 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff2c:46bc: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::de15:c8ff:fe2c:46bc
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:31.740287 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:fffa:54b2: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::8a71:b1ff:fefa:54b2
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:31.740596 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff09:efe2: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::aa97:cdff:fe09:efe2
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:31.741861 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff23:ea98: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::2e91:abff:fe23:ea98
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:31.833965 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff75:bb08: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::2e91:abff:fe75:bb08
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:31.835485 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff23:f2a2: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::2e91:abff:fe23:f2a2
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:31.837462 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff23:eb08: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::2e91:abff:fe23:eb08
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:31.839100 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff23:f04f: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::2e91:abff:fe23:f04f
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:31.843144 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff09:fbe0: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::aa97:cdff:fe09:fbe0
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:31.844791 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ffc0:5792: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::422b:50ff:fec0:5792
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:32.738906 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff75:846d: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::2e91:abff:fe75:846d
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:32.740527 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff2e:23fe: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::de15:c8ff:fe2e:23fe
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:32.740884 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff4a:5371: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::fa8b:37ff:fe4a:5371
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:32.741259 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff51:e63e: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::7254:25ff:fe51:e63e
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:32.865982 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:fffa:59cb: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::8a71:b1ff:fefa:59cb
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:32.867555 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ffc2:a454: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::c289:abff:fec2:a454
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:32.869177 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff51:e305: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::7254:25ff:fe51:e305
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:32.869507 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ffc0:5792: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::422b:50ff:fec0:5792
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:32.869883 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff09:fbe0: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::aa97:cdff:fe09:fbe0
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:32.953892 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff51:cac8: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::7254:25ff:fe51:cac8
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:34.040074 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:5e41 > ff02::1:fff9:f882: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::8a71:b1ff:fef9:f882
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:34.041642 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:5e41 > ff02::1:ff00:3: [icmp6 sum ok] ICMP6, neighbor solicitati                                                                                                                                                              on, length 32, who has 3a10:6969:100::3
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:34.146752 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff4a:6523: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::fa8b:37ff:fe4a:6523
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:34.391569 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:5e41 > ff02::1:ff4e:39c8: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::fa8b:37ff:fe4e:39c8
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:34.582189 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:5e41 > ff02::1:ff51:b2bd: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::7254:25ff:fe51:b2bd
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:35.002441 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:88bf > ff02::1:ff4e:2104: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::fa8b:37ff:fe4e:2104
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:35.162317 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) 2a10:                                                                                                                                                              4440:100::1 > ff02::1: [icmp6 sum ok] ICMP6, neighbor advertisement, length 32,                                                                                                                                                               tgt is 3a10:6969:100::1, Flags [router, override]
          destination link-address option (2), length 8 (1): 00:00:00:ab:cd:ef
12:19:35.163760 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :200:ff:feab:cdef > ff02::1: [icmp6 sum ok] ICMP6, neighbor advertisement, lengt                                                                                                                                                              h 32, tgt is fe80::200:ff:feab:cdef, Flags [router, override]
          destination link-address option (2), length 8 (1): 00:00:00:ab:cd:ef
12:19:35.194189 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) 2a10:                                                                                                                                                              4440:100::1 > ff02::1: [icmp6 sum ok] ICMP6, neighbor advertisement, length 32,                                                                                                                                                               tgt is 3a10:6969:100::1, Flags [router, override]
          destination link-address option (2), length 8 (1): 00:00:00:ab:cd:ef
12:19:35.195993 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :200:ff:feab:cdef > ff02::1: [icmp6 sum ok] ICMP6, neighbor advertisement, lengt                                                                                                                                                              h 32, tgt is fe80::200:ff:feab:cdef, Flags [router, override]
          destination link-address option (2), length 8 (1): 00:00:00:ab:cd:ef
12:19:35.411311 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:5e41 > ff02::1:ff4e:39c8: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::fa8b:37ff:fe4e:39c8
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:35.606316 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:5e41 > ff02::1:ff51:b2bd: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::7254:25ff:fe51:b2bd
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:35.618868 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:5e41 > ff02::1:ffc2:9d92: [icmp6 sum ok] ICMP6, neighbor solicit                                                                                                                                                              ation, length 32, who has fe80::c289:abff:fec2:9d92
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:35.627285 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80:                                                                                                                                                              :8b6a:2811:fe9a:5e41 > ff02::1:ff00:3: [icmp6 sum ok] ICMP6, neighbor solicitati                                                                                                                                                              on, length 32, who has 3a10:6969:100::3
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:36.031555 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:88bf > ff02::1:ff4e:2104: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::fa8b:37ff:fe4e:2104
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:36.402706 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:5e41 > ff02::1:ff09:d999: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::aa97:cdff:fe09:d999
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:36.627680 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:5e41 > ff02::1:ffc2:9d92: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::c289:abff:fec2:9d92
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:36.628998 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:5e41 > ff02::1:ff51:b2bd: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::7254:25ff:fe51:b2bd
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:36.658367 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:5e41 > ff02::1:ff00:3: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 3a10:6969:100::3
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:36.978872 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:5e41 > ff02::1:ffc2:92e3: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::c289:abff:fec2:92e3
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:37.050703 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:88bf > ff02::1:ff4e:2104: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::fa8b:37ff:fe4e:2104
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:37.430836 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:5e41 > ff02::1:ff09:d999: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::aa97:cdff:fe09:d999
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:37.655863 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:5e41 > ff02::1:ffc2:9d92: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::c289:abff:fec2:9d92
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:37.686856 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:5e41 > ff02::1:ff00:3: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 3a10:6969:100::3
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:37.702476 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:88bf > ff02::1:ff75:8523: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::2e91:abff:fe75:8523
          source link-address option (1), length 8 (1): 98:96:69:96:69:bf
12:19:38.007296 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:5e41 > ff02::1:ffc2:92e3: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::c289:abff:fec2:92e3
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:38.202858 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:5e41 > ff02::1:ff51:dc61: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::7254:25ff:fe51:dc61
          source link-address option (1), length 8 (1): 99:55:88:99:55:41
12:19:38.450732 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::8b6a:2811:fe9a:5e41 > ff02::1:ff09:d999: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who h

I would like to thank you for taking the time to help here Trendy,
pinging is not working at the moment:


root@OpenWrt:~# ping hitachi.com
ping: bad address 'hitachi.com'

root@OpenWrt:~# ping ibm.com
ping: bad address 'ibm.com'

root@OpenWrt:~# ping toshiba.com
ping: bad address 'toshiba.com'

root@OpenWrt:~# ping dell.com
ping: bad address 'dell.com'

root@OpenWrt:~# ping apple.com
ping: bad address 'apple.com'

root@OpenWrt:~# ping pornhub.com
ping: bad address 'pornhub.com'

root@OpenWrt:~# ping 1.1.1.1
PING 1.1.1.1 (1.1.1.1): 56 data bytes

ping: sendto: Network unreachable
root@OpenWrt:~# ping 8.8.8.8

PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable

root@OpenWrt:~# ping 9.9.9.9
PING 9.9.9.9 (9.9.9.9): 56 data bytes

ping: sendto: Network unreachable
root@OpenWrt:~#


I am not able to understand what is going on. You have scrambled the addresses in a different way in the tcpdump and the ip -6 addr, so I am not sure which is which.
There are a lot of neighbor solicitations and not too many advertisements. Can you verify with ip neigh show that OpenWrt has an entry for the upstream router?

It seems that you have lost connection to the upstream router.