IPv6 Configuration Issue

This is my setup

[ISP] -> bridged ISP router -> OpenWrt router -> [LAN]

Archer C7 flashed with prebuilt OpenWrt 19.07.4

The bridged router is in Dual Stack config with ipv4 and ipv6

My ISP hasn't officially announced native support for ipv6 but some of the users in my State are able to use ipv6.

The option Obtain IPv6-Address in WAN was set to auto which i think spawned an additional interface WAN_6 with no configurable option but was a DHCPv6 client

The WAN is pppoe connected and i am getting an ipv6 address with ipv6 pd , the problem is that i am not sure whether this means that i have ipv6 or is this some default thing that happens with dual stack config.

this is my config

Also WAN6 created on it own after I set the WAN interface, thus i have two DHCPv6 client, is this odd? or is it normal?

firewall configs are defaults haven' changed a thing

Nonetheless i am not able ping any ipv6 sites from Lan or even from the OpenWrt router,Zero packets are returned.

Traceroute from OpenWrt has just one Hop that i believe is kind of same as the ipv6 address of the DHCPv6 interface.
and traceroute from Lan has that one similar Hop, but with an ipv6 of the lan interface, with an additional Hop showing Destination Unreachable

Things i have tired so far:-

  1. in this article it mentions to set some traffic rules for ports 546 and 547
  2. Tried to mess around some of the settings, but no luck
  3. Manually created another DHCPv6 client and still no connection.

Is this a misconfiguration from my side or might this is be a problem on the ISP side even though i am getting ipv6 and a Delegated Prefix.

Does it need special configs and firewall rules to allow ipv6 in dual stack? or like I said is it a problem with my isp.

can provide additional details if need be;

any help appreciated, thanks in advance

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
1 Like

Posting my /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0d:c292:32d5::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.137'
        option proto 'pppoe'
        option password '*************'
        option username 'ABCD'
        option peerdns '0'
        list dns '94.140.14.14'
        list dns '94.140.15.15'
        option ipv6 'auto'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'
        option macaddr 'AA:AA:AA:AA'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth0.137'
        option reqprefix 'auto'
        option reqaddress 'try'
        option defaultroute '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1t'
        option vid '137'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 1'
        option vid '3'

config interface 'netlink_cpe'
        option ifname 'eth0.3'
        option proto 'static'
        option ipaddr '192.168.0.2'
        option netmask '255.255.255.0'
        option delegate '0'
        option force_link '0'
        option gateway '192.168.0.1'

Have you tried disabling wan(ipv4) and inputting PPPoE login details onto the wan6?

I think you can try PPPoE with the ISP router, checking if ipv6 works when ISP router is not in bridge mode but in PPPoE mode. Maybe some insufficient config like 4to6 tunnel not provided by ISP might be the cause.

That being said, I am a noob so please go easy on me if I said something wrong.

I had tired that, trying to use ipv6 with the isp router in non bridged bode, with dual stack config,But can't connect to ipv6.
Yet status shows ipv6 is up with a default gateway and i am getting a delegated prefix. But my traceroutes are Destination Unreachable.
I don't know what else to try more now.
I think it might be the problem with my isp.

1 Like