IPv6 configuration and Network Access Error

My ISP give a PPPoE IPv4 and a DHCP6 xxxx:xxxx:xxxx:x00::/56 static IPv6

This is my router ER-X 21.02.3 configuration and router and PC route.
I see some mix in my lan routing, it should have just '02' address as ip6hint but there are also some '00' address in the routes that may be wrong.

Did I do some mistake in the router configuration or with IPv6 Subnetting?

When I have IPv4 and IPv6 active on the PC, sometimes (randomly 5% of total time) the PC firefox stop loading webpages like youtube (even twitter that isn't IPv6) in the middle of normal usage, if I refresh the page then load again, IPv6 mtr tests doesn't show any problems in routes or packet loss, if I disable IPv6 on the PC leaving active just IPv4 I never get the youtube and twitter like problems.

root@router:/etc/config# cat network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'xxxx:xxxx:xxxx::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'eth2'
	list ports 'eth3'
	list ports 'eth4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ip6hint '02'
	option ip6ifaceid 'random'

config interface 'wan'
	option device 'eth0.835'
	option proto 'pppoe'
	option username 'user'
	option password 'password'
	option ipv6 '1'
	option peerdns '0'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	option keepalive '10 5'

config interface 'wan6'
	option proto 'dhcpv6'
	option device '@wan'
	option reqaddress 'try'
	option reqprefix 'auto'
	option peerdns '0'
	list dns '2606:4700:4700::1111'
	list dns '2606:4700:4700::1001'
root@router:/etc/config# cat dhcp 

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	list interface 'lan'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	list ra_flags 'none'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'
root@router:/etc/config# ip -6 route
default from xxxx:xxxx:xxxx:x00::/56 via fe80::xxxx:xxxx:xxxx:xxxx dev pppoe-wan  metric 4096 
xxxx:xxxx:xxxx:x02::/64 dev br-lan  metric 1024 
unreachable xxxx:xxxx:xxx:x00::/56 dev lo  metric 2147483647 
......
anycast xxxx:xxxx:xxx:x02:: dev br-lan  metric 0 
......
openx@pc:~$ ip -6 route
.....
xxxx:xxxx:xxxx:x02:xxxx:xxxx:x:xxxx dev enp2s0f0 proto kernel metric 100 pref medium
xxxx:xxxx:xxxx:x02::/64 dev enp2s0f0 proto ra metric 100 pref medium
xxxx:xxxx:xxxx:x00::/56 via fe80::xxxx:xxxx:xxxx:xxxx dev enp2s0f0 proto ra metric 100 pref medium
......
default via fe80::xxxx:xxxx:xxxx:xxxx dev enp2s0f0 proto ra metric 100 pref medium

The configuration looks alright.

I suppose you mean

which is the expected.

I mean that my PC has IP

inet6 xxxx:xxxx:xxxx:x02:xxxx:xxxx:xxxx:xxxx/64 scope global temporary dynamic

and show this in the routing table

OpenX@pc:~$ ip -6 route
.....
xxxx:xxxx:xxxx:x00::/56 via fe80::xxxx:xxxx:xxxx:xxxx dev enp2s0f0 proto ra metric 100 pref medium
.....

So the router configuration is ok and my problem should be somewhere else, I need to do more investigation, maybe ISP side? I use fibra.aruba.it that become also an FTTH ISP just last year.

Thanks for your support trendy!

It is expected, as it is included in the router advertisement.

I don't see anything wrong and this is pretty basic configuration. The intermittent network operation says that something else is the problem and not the configuration.
Check the logs when it happens logread for any clues.

1 Like