Ipv6 assigned but not connect-able on wireless

I have been living with openwrt for a couple weeks, now. It has been a relatively smooth transition from ddwrt. I do get a bit confused at times with the cli commands and the gui presentation when I read howtos, but have worked it out for the most part. I have a pretty simple install with really only dyndns and openvpn running on top of the basic install. This is on a Netgear R7800. My latest issue is with ipv6 clients, and only with wireless ipv6 clients. I have never seen this with the ethernet clients.

I am doing development work on an rpi and have to make changes and check things out and reboot quite a bit. What I have noticed is that I always get ipv4 connectivity to this wireless device, but ipv6 sometimes requires a router reboot to actually allow a connection. What I note is that sometimes after a reboot, the device gets an address, but none of the other machines on my LAN can connect with ipv6. The RPi is using connman/iwd to set up the connection. It has a solid signal and gets an address very quickly. I just cannot connect to it on its ipv6 address.

Keith

What can I check? I cannot even ping it on its ipv6 until I reboot the router.

If I ping it on its ipv4, I get <1ms ping times, If I try its ipv6, I get 'Destination Host Unreachable"

I would suggest to test a different duo for these two services first, neither connman, nor iwd are really common on linux, so I'd test them for potential issues first. Especially the RPi should make it rather easy to test another system (using ifupdown, network-manager or systemd-networkd instead of connman - and/ or wpa_supplicant instead of iwd) temporarily. While this is just a hunch, it should be easy to test (on a another µSD card).

1 Like

So, it seems that it isn't just ipv6, but it is appears to be an either/or situation. I left the ipv6 connected web of this RPi up over night on a different machine. This morning, the IPv6 connection is viable to the RPi, but the ipv4 is not. Http as well as ssh work but only via the ipv6 address to this RPi. If I log into the RPi with the ipv6 only connectivity, I can connect and ping other ipv6 or ipv4 devices on the LAN/web from that RPi. This seems to only happen with wifi only connected devices. On wired devices, I can get to both addresses without issue.

This is the wifi only RPi's ifconfig

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
         inet 192.168.2.41  netmask 255.255.255.0  broadcast 192.168.2.255
         inet6 fdcb:9d61:70f3:0:ba27:xxff:xxxx:xxxx  prefixlen 64  scopeid 0x0<global>
         inet6 fe80::ba27:xxff:xxxx:xxxx  prefixlen 64  scopeid 0x20<link>
         inet6 2601:241:4200:255:ba27:xxff:xxxx:xxxx  prefixlen 64  scopeid 0x0<global>
         ether b8:27:xx:xx:xx:xx  txqueuelen 1000  (Ethernet)
         RX packets 1144124  bytes 1607422177 (1.4 GiB)
         RX errors 0  dropped 0  overruns 0  frame 0
         TX packets 1018700  bytes 123744038 (118.0 MiB)
         TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I just tried another scenario. I rebooted a linux laptop on wifi. Opened the browser and tried to connect to my RPis. The laptop has a valid Ipv4 and ipv6 address. It can only connect to other devices on the LAN on their ipv4 address. Tried to connect (on wifi) to ipv6.google.com and it will not connect. Connected an etherrnet cable and it can connect to ipv6.google.com. Rebooted the NetGear R7800 router, reconnected to the router's 5Ghz SSID and now wifi will connect to ipv6.google.com and wired ipv6 addresses on my lan. ...AND... my wifi only connected RPi now is connect-able by both addresses even though I did not reboot it or reset its network configuration. All I did was reboot the router. It is as if the routes are lost.

Which service(s) should I restart on the router if I want to diagnose this further.

I will investigate netctl on the RPis and see if it behaves differently but It is strange that it is only on wifi only connections that this behaves like this. I also think it is strange that I can connect out from the device on both ipv6 and ipv4 addresses, but can only connect in to it on one or the other(after a time). It is as if one goes stale after a while and ceases operation.

so, this is what I have learned. It seems to be with wireless, only. I have not seen this with wired connections.
The RPi will connect and gets an address, and can connect to the internet, but nothing can connect to it. It has an address, it has the router's IP as its DNS server. It gets both IPv6 and IPv4 addresses.

I have tried editing the 'static leases' in the GUI and 'save and apply' to restart the DHCP server(s). The router shows that I have an address. The RPi shows an address and can connect to the internet. I cannot route to it.
If I reboot the router then let the RPi grab the address again, it all starts working. I can connect out from the RPi and connnect to the RPI form my LAN. It seems like the router chokes on it somehow. I have seen this once with the laptop as well, but only once and have not been able to diadnose it even as far as I have gotten with the RPi.

Any ideas? I have updated all packages on the router and even re-flashed the router. I still see this pretty regularly.

Doing a bit of log inspection and I see a ton of this:

ath10k_pci 0001:01:00.0: failed to increase tx pending count: -16, dropping

which seems to be related to this:
https://www.spinics.net/lists/linux-wireless/msg198213.html

Am I the only one with this issue? When this happens, I have strange wireless response. It will get an address, but I cannot connect to it though it can connect to the internet.

Yeah, I am getting this too: kern.warn kernel: [2658368.762642] ath10k_pci 0001:01:00.0: failed to increase tx pending count: -16, dropping

I’ve noticed Delays in the WiFi, especially 2.4 ghz, but it would go away. I finally looked at the logs and saw the above problem.

Thanks for the hint. If I get this fixed, I’ll make a post.

I noticed another ath10k_pci error that showed up as well:

I just loaded the snapshot version of OpenWRT: r13630-635f111148

Will see if it is any better. I thought it was my RPi, but it seems like it is the router. I tried 2.4 and 5 Ghz and it happens on both. I have some devices which are WiFi only and that seem to be rock solid (connections in and out are fine), and others which are flaky. It appears to me to be exhibited more LAN connectivity more than internet connectivity. I can get OUT, just not connect to local devices. My phone (on 5Ghz) could connect to the internet and I could connect to some local IP addresses, but all avahi (mdns) was hosed until I rebooted the router.

Keith

I am using the release build for 19.07.3 on my TP-Link C2600. Previously has been rock solid.

I was using 19.07.3 as well on my Netgear R7800. I just switched to openWRT from DDWRT and this is the first image I tried. Do not know how 19.07.2 was. I guess I could flash an older image.

May switch back to ddwrt if it is not stable on this. Never had a problem before.

This morning, I rebooted and the 5Ghz radio would not come up. Tried a power down then back up. Still no 5Ghz (2.5 was fine). I flashed the snapshot and the 5Ghz radio came back online. Sounds like some issue with the Ath_10K module. I hope is is fixed with the snapshot.

Running the snapshot for a day ~24 hrs give a bit. It seems more stable. I still get some errors but it does not hang everything on the 5Ghz radio. A day later, the mDNS seens to still e intact and I have not disconnected my 5Ghz RPi client that used to get disconnected about once a day.:

[  342.222723] ath10k_pci 0000:01:00.0: Invalid VHT mcs 15 peer stats
[32273.381390] ath10k_pci 0001:01:00.0: wmi: fixing invalid VHT TX rate code 0xff
[90944.814819] ath10k_pci 0001:01:00.0: Invalid peer id 0 or peer stats buffer, peer: 284f5023  sta: 00000000