[Solved] IPv6 announcement for WDS client interface

Hello, I have set up a WDS coniguration, based on this wiki article. All is good, I have both WDS host and client LAN interfaces with a static IPv4 adress (192.168.0.1-2).

The main WAN router is the WDS host (access point) itself, 192.168.0.1, I get a delegated global IPv6 prefix and address, just as any other client connected to this access point and the LAN network itself. From my ISP, I get it through @WAN set up as a DHCPv6 client, and on the LAN side I have RA mode as 'server' and nothing else.

However, the Openwrt LAN interface on the WDS client, 192.168.0.1, does not get an IPv6 adress at all (the interface on the router itself). I left dnsmasq, odhcpd and firewall services running on this, even though this is not the primary gateway device.

I'm afraid, that setting an IPv6 static address to his, with the common prefix and different suffix won't be proper, as after a WAN reconnect I will get a different subnet/IP.

Did I overlook any setting, or should I need to enable DHCPv6 in server mode on the primary AP?

This wiki article describes a configuration based on relayd, while the WDS article is located elswhere.
Which one did you use?

1 Like

You are correct, I have definately used the WDS article, as I have set up a WDS bridge, not a relayd one.

Please post your configuration here

for ap2 "WDS client":

root@ap2:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option enable_vlan4k '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '5t 1 2 3'
        option description 'lan'

config switch_vlan
        option device 'switch0'
        option vlan '300'
        option ports '5t 4'
        option description 'mgmt'

config interface 'mgmt'
        option proto 'static'
        option ifname 'eth0.300'
        list ipaddr '192.168.1.2/24'

config interface 'ovi'
        option proto 'static'
        option ifname 'eth0.1'
        option ip6assign '64'
        option type 'bridge'
        option stp '1'
        option igmp_snooping '1'
        list ipaddr '172.50.1.2/24'
        option gateway '172.50.1.1'
        list dns '172.20.1.2'
        list dns '172.50.1.1'

root@ap2:~#

for ap1 "WDS access point" "main router/server"

root@ap1:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8c:e0c4:ae46::/48'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'
        option macaddr 'd8:0d:17:c0:29:6f'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 2 3 4'
        option description 'lan'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'
        option vid '2'
        option description 'wan'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '300'
        option description 'mgmt'
        option ports '0t 5'

config interface 'mgmt'
        option proto 'static'
        option ifname 'eth0.300'
        list ipaddr '192.168.1.1/24'
        list ip6addr '::/128'
        option gateway '192.168.1.100'
        list dns '1.1.1.1'
        list dns '1.0.0.1'

config interface 'ovi'
        option proto 'static'
        option ifname 'eth0.1'
        list ipaddr '172.50.1.1/24'
        option ip6assign '64'
        option ip6hint '6f7669'
        option ip6ifaceid '::50:1'
        option type 'bridge'

config interface 'wan'
        option proto 'pppoe'
        option ifname 'eth0.2'
        option force_link '1'
        option username 'REDACTED'
        option password 'REDACTED'
        option ipv6 '1'
        option peerdns '0'
        list dns '94.140.14.14'
        list dns '94.140.15.15'

config interface 'wan_6'
        option proto 'dhcpv6'
        option ifname '@wan'
        option force_link '1'
        option reqaddress 'force'
        option reqprefix 'auto'
        option peerdns '0'

How large IPv6 prefix have you got considering your ip6hint is 24 bits. Which means you need a /40 or shorter.

Sorry, I don't have a lot of experience with the IPv6 options. I thought that 'ipv6hint' means to "customize" the allocated suffixes, but I later I found out that option 'ip6faceid' is mostly meant for that instead. I have removed the former option.

Some time has passed, and also some major versions and changes in OpenWrt. I'm using the recent stable builds now.

I gave another run with WDS bridges. Looks like the issue is still the same now. Apparently IPv6 does not 'get through' a WDS bridge link. Tried even pinging the link-local v6 address of the WDS AP, still no go.

I also did the following: on the WDS client, I set up an alias iface (alias of the lan bridge if) with DHCPv6 protocol, I get the global unique v6 address, but going out to the internet is still no go (ping reply Destination unreachable: No route), from the WDS client, nor the hosts in the lan behind the WDS client.

@mikma I'm confident on your expertise on this. Maybe you can confirm if this is the case, on a WDS bridge IPv6 traffic does not work, and as I observed, multicast does not work either. In comparison, I need to try the same with 802.11s mesh bridges instead.

This seems to have worked for me.

Hello,

Yes, indeed, with the latest versions this issue seems to be fixed!