Ipv4 dhcp issue in OpenWrt 19.07.02

Hello,
seems that in 19.07.02 on ARM SAMA5D31 configuring DHCP in /etc/config/network file do not get any ip address.
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
option type none
option proto dhcp

config interface debug
option ifname usb0
option type none
option proto static
option ipaddr 172.18.0.18
option netmask 255.255.255.0

and /etc/init.d/network restart
at phy level i get the following

root@OpenWrt:/# ifup lan
[10618.894547] macb f802c000.ethernet eth0: PHY [f802c000.ethernet-ffffffff:01] driver [Generic PHY]
[10618.903507] macb f802c000.ethernet eth0: configuring for phy/rmii link mode

also if i start udhcp manually i can't obtain ip address

In rel 19.07.02 /etc/config/network file is different from rev 18.06.2 and differ in the following lines:
config interface lan
option ifname eth0
option type none
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0

config interface lan
option ifname lan1
option type none
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0

Why this difference ?
Thanks in advance
B/R
Fabio

Check available interfaces:

ip link show

Hi,
root@OpenWrt:/# ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
link/ether 00:01:02:03:04:05 brd ff:ff:ff:ff:ff:ff
root@OpenWrt:/#

but no ip get.

Any idea ?
Thanks
Fabio