IPv4 and IPv6 issue when bridge multiple interface

I try to bridge multiple interface to using IPv4 static IP and DHCPv6, but I always can not get IPv6 DHCP IP. Only if disable bridge then I can get DHCPv6 IP and static IPv4 IP.

Below is my setting, in this configuration I can see lan interface with static IPv4 IP, but no lan_6 interface with DHCPv6.

config interface 'lan'
        option type 'bridge'
        option ifname 'eth4'
        option ipaddr '192.168.1.254'
        option netmask '255.255.255.0'
        option proto 'static'

config interface 'lan_6'
        option type 'bridge'
        option ifname 'eth4'
        option proto 'dhcpv6'

The other setting, in this configuration I can see eth4 interface with static IPv4 IP and DHCPv6 IP.

config interface 'lan'
        option ifname 'eth4'
        option ipaddr '192.168.70.254'
        option netmask '255.255.255.0'
        option proto 'static'

config interface 'lan_6'
        option ifname 'eth4'
        option proto 'dhcpv6'

Does there any limitation to support IPv4 and IPv6 with bridge interface?

https://openwrt.org/docs/guide-user/network/network_interface_alias

1 Like