IPv4 and IPv6 dhcp relay with dnsmasq

Hey folks,

i installed an openwrt with version 22.03. I have different subnets (vlans 1, 180) that I am trying to supply with ip addresses using a dhcp relay. I got IPv4. Unfortunately IPv6 does not work.

The DHCP server is in the network LAN / LAN6 and has the IPv4 192.168.178.6 and IPv6 fddd:40a8:552a:40b2::6

Clients in the network LAN are provided with IPv4 and IPv6 addresses. Clients in the network UNSAFE only with IPv4. Can someone help me?

here my configuration:

/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        list server '8.8.8.8'
        list server '8.8.4.4'
        list server '2001:4860:4860::8888'
        list server '2001:4860:4860::8844'

config relay '1'
        option interface 'LAN'
        option local_addr '192.168.180.10'
        option server_addr '192.168.178.6'

config relay '2'
        option interface 'LAN6'
        option local_addr 'fddd:180::10'
        option server_addr 'fddd:40a8:552a:40b2::6'

/etc/config/network

config device
        option name 'eth0'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'eth0:u*'

config bridge-vlan
        option device 'br-lan'
        list ports 'eth0:t'
        option vlan '180'

config device
        option name 'br-lan.1'
        option type '8021q'
        option ifname 'br-lan'
        option vid '1'

config device
        option name 'br-lan.180'
        option type '8021q'
        option ifname 'br-lan'
        option vid '180'

config interface 'LAN'
        option proto 'static'
        option device 'br-lan.1'
        option netmask '255.255.255.0'
        option gateway '192.168.178.1'
        option ipaddr '192.168.178.10'

config interface 'LAN6'
        option proto 'dhcpv6'
        option device 'br-lan.1'
        option reqaddress 'try'
        option reqprefix 'auto'

config interface 'UNSAFE'
        option proto 'static'
        option device 'br-lan.180'
        option netmask '255.255.255.0'
        option ipaddr '192.168.180.10'
        option ip6prefix 'fddd:180::/64'
        list ip6addr 'fddd:180::10'

I don't have the time to look into the details now, so just some general observations:

  • avoid upper case (or otherwise special) interface names, while technically possible, it's a guarantee for trouble
  • overloading the term lan/ br-lan is quite tricky, better call the switch something else (e.g. sw0.xyz or switch0.xyz).

Hi slh,

thanks for reply. I have changed this without an success.