IPTV streaming not working, though IGMP configured

Hello everyone!

Will someone assist me in troubleshooting non working IPTV streaming, please?. I have been struggling for 2 weeks now and cannot find the cause.

Setup: iptv box is connected by cable to lan4. Provider said to either use bridge (which is not suitable for me as I need both wifi and iptv) or igmpproxy v2.

I configured the latter according to the IPTV/UDP openwrt guide - it didn't work. I then tried adding udpxy - that didn't work either.

I'm attaching cofings at the end of the post.

I'm also attaching tcpdump -i eth1 igmp (altnet 0.0.0.0.0/0, because I don't know what ISP they use).

P.S. I read that one solution is to configure VLAN, but as far as I know the provider does not use it and I am not sure what ID to specify there.

P.P.S.
IGMP logs gives the following error: user.warn igmpproxy[28549]: MRT_DEL_MFC; Errno(2): No such file or directory. Multi-forwarding is on for wan.

Configs

/etc/config/network

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd6b:e337:27a9::/48'

config device
option name 'br-lan'
option type bridge
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
option igmp_snooping '1'

config device
option name 'lan1'
option macaddr 'c8:7f:54:ba:1d:c6'

config device
option name 'lan2'
option macaddr 'c8:7f:54:ba:1d:c6'

config device
option name 'lan3'
option macaddr 'c8:7f:54:ba:1d:c6'

config device
option name 'lan4'
option macaddr 'c8:7f:54:ba:1d:c6'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option igmp_snooping 1

config device
option name 'eth1'
option macaddr 'c8:7f:54:ba:1d:c6'

config interface 'wan'
option device 'eth1'
option proto 'pppoe'
option username ‘username’
option password ‘password’
option ipv6 'auto'

config interface 'wan6'
option device 'eth1'
option proto 'dhcpv6'

/etc/config/firewall

config defaults
option syn_flood '1'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'

config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'

config include 'miniupnpd'
option type 'script'
option path '/usr/share/miniupnpd/firewall.include'

config rule
option name 'Allow-IPTV-IGMPPROXY'
option src 'wan'
option proto 'udp'
option dest 'lan'
option dest_ip '224.0.0.0/4'
option target 'ACCEPT'

/etc/config/igmpproxy

config igmpproxy
option quickleave 1

option verbose [0-3](none, minimal[default], more, maximum)

config phyint
option network wan
option zone wan
option direction upstream
list altnet 0.0.0.0/0

config phyint
option network lan
option zone lan
option direction downstream

root@OpenWrt:~# tcpdump -i eth1 igmp
tcpdump: verbose output suppressed, use -v[v]... for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), snapshot length 262144 bytes
09:22:47.560311 IP 10.14.0.1 > all-systems.mcast.net: igmp query v2 [max resp time 50]
09:23:12.567558 IP 10.14.0.1 > all-systems.mcast.net: igmp query v2 [max resp time 50]
09:23:37.593500 IP 10.14.0.1 > all-systems.mcast.net: igmp query v2 [max resp time 50]
09:25:42.601971 IP 10.14.0.1 > all-systems.mcast.net: igmp query v2 [max resp time 50]
09:25:44.424604 IP 10.14.0.1 > 239.195.64.8: igmp query v2 [max resp time 50] [gaddr 239.195.64.8]
09:25:49.351813 IP 10.14.0.1 > 239.195.64.8: igmp query v2 [max resp time 50] [gaddr 239.195.64.8]
09:29:39.171978 IP 10.14.0.1 > 239.195.64.3: igmp query v2 [max resp time 50] [gaddr 239.195.64.3]
09:29:44.176651 IP 10.14.0.1 > 239.195.64.3: igmp query v2 [max resp time 50] [gaddr 239.195.64.3]

I do understand that this post may be duplicated many times, but I didn't find any solutions in them.
If any additional information is needed - I'll provide it at once

If the provider don’t want to tell you what data they use,

Well, hack it…
Connect it to the internet and run wireshark on the data line to see what they use.

well, basically I can identify ID to use set-up VLAN and it should work?
Will try!
However, what are the basic troubleshooting steps for why igmp proxy doesn't work?
I checked rules in network, checked igmp proxy config and whether igmp proxy is enabled. But in logs there's an error, that I was not able to get much info about